summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-04-21 06:24:18 +0000
committerMike Frysinger <vapier@gentoo.org>2012-04-21 06:24:18 +0000
commit9934d704db809a22759a5970e98c11faad3a590a (patch)
tree4bdd26949e192dc65a45b76375893f875c075a9b /sys-apps/util-linux/util-linux-2.20.1-r1.ebuild
parentMissing Categories Utility and TextTools in xfce4-dict.desktop (as required b... (diff)
downloadgentoo-2-9934d704db809a22759a5970e98c11faad3a590a.tar.gz
gentoo-2-9934d704db809a22759a5970e98c11faad3a590a.tar.bz2
gentoo-2-9934d704db809a22759a5970e98c11faad3a590a.zip
Add support for older C libraries that do not support latest POSIX standard (%as flags) #406303 by Ed Wildgoose.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/util-linux/util-linux-2.20.1-r1.ebuild')
-rw-r--r--sys-apps/util-linux/util-linux-2.20.1-r1.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/sys-apps/util-linux/util-linux-2.20.1-r1.ebuild b/sys-apps/util-linux/util-linux-2.20.1-r1.ebuild
index 9bcec28ba5bd..b0fc3eea93fb 100644
--- a/sys-apps/util-linux/util-linux-2.20.1-r1.ebuild
+++ b/sys-apps/util-linux/util-linux-2.20.1-r1.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.20.1-r1.ebuild,v 1.6 2012/03/03 15:31:19 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.20.1-r1.ebuild,v 1.7 2012/04/21 06:24:18 vapier Exp $
EAPI="3"
EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux/util-linux.git"
-inherit eutils toolchain-funcs libtool flag-o-matic
+AUTOTOOLS_AUTO_DEPEND="no"
+inherit eutils toolchain-funcs libtool flag-o-matic autotools
[[ ${PV} == "9999" ]] && inherit git autotools
MY_PV=${PV/_/-}
@@ -36,7 +37,8 @@ RDEPEND="!sys-process/schedutils
ncurses? ( >=sys-libs/ncurses-5.2-r2 )
perl? ( dev-lang/perl )
selinux? ( sys-libs/libselinux )
- slang? ( sys-libs/slang )"
+ slang? ( sys-libs/slang )
+ uclibc? ( ${AUTOTOOLS_DEPEND} )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
virtual/os-headers"
@@ -49,7 +51,10 @@ src_prepare() {
else
use loop-aes && epatch "${WORKDIR}"/util-linux-*.diff
fi
- use uclibc && sed -i -e s/versionsort/alphasort/g -e s/strverscmp.h/dirent.h/g mount/lomount.c
+ if use uclibc ; then
+ epatch "${FILESDIR}"/${P}-no-printf-alloc.patch #406303
+ eautoreconf
+ fi
elibtoolize
}