summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-05-29 23:49:28 +0000
committerMike Frysinger <vapier@gentoo.org>2009-05-29 23:49:28 +0000
commit14eaa385c38fd7510911ec460a107e02ef031207 (patch)
tree11210c4f4c8f050c20c8304a9b40c7c9ec758fd4 /sys-apps/util-linux
parentold (diff)
downloadgentoo-2-14eaa385c38fd7510911ec460a107e02ef031207.tar.gz
gentoo-2-14eaa385c38fd7510911ec460a107e02ef031207.tar.bz2
gentoo-2-14eaa385c38fd7510911ec460a107e02ef031207.zip
Add fix from upstream for locale build failure on uClibc #271154 by Gianluigi Tiesi.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/ChangeLog7
-rw-r--r--sys-apps/util-linux/files/util-linux-2.15-locale.patch42
-rw-r--r--sys-apps/util-linux/util-linux-2.15-r1.ebuild3
3 files changed, 50 insertions, 2 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index 05011cf089eb..74e6a9689f00 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/util-linux
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.267 2009/05/24 18:38:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.268 2009/05/29 23:49:28 vapier Exp $
+
+ 29 May 2009; Mike Frysinger <vapier@gentoo.org> util-linux-2.15-r1.ebuild,
+ +files/util-linux-2.15-locale.patch:
+ Add fix from upstream for locale build failure on uClibc #271154 by
+ Gianluigi Tiesi.
24 May 2009; Mike Frysinger <vapier@gentoo.org> util-linux-2.15-r1.ebuild:
Re-order patches when USE=loop-aes #271041 by Lars Wendler and add
diff --git a/sys-apps/util-linux/files/util-linux-2.15-locale.patch b/sys-apps/util-linux/files/util-linux-2.15-locale.patch
new file mode 100644
index 000000000000..43f5d9463e60
--- /dev/null
+++ b/sys-apps/util-linux/files/util-linux-2.15-locale.patch
@@ -0,0 +1,42 @@
+http://bugs.gentoo.org/271154
+
+From a88057d9a329c11a5d4eaf7e15ce25b09be800e5 Mon Sep 17 00:00:00 2001
+From: Tom Prince <tom.prince@ualberta.net>
+Date: Thu, 14 May 2009 22:43:02 -0400
+Subject: [PATCH] cal: uClibc has langinfo.h but not _NL_TIME_WEEK_1STDAY.
+
+Signed-off-by: Tom Prince <cougar@hermes>
+---
+ configure.ac | 2 ++
+ misc-utils/cal.c | 2 +-
+ 2 files changed, 3 insertions(+), 1 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 1abf688..af946a1 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -105,6 +105,8 @@ AC_CHECK_HEADERS([linux/raw.h],
+ [AM_CONDITIONAL([HAVE_RAW], [true])],
+ [AM_CONDITIONAL([HAVE_RAW], [false])])
+
++AC_CHECK_DECLS([_NL_TIME_WEEK_1STDAY],[],[],[[#include <langinfo.h>]])
++
+ AC_CHECK_FUNCS(
+ [inet_aton \
+ fsync \
+diff --git a/misc-utils/cal.c b/misc-utils/cal.c
+index f2d52e8..a8534b8 100644
+--- a/misc-utils/cal.c
++++ b/misc-utils/cal.c
+@@ -291,7 +291,7 @@ main(int argc, char **argv) {
+ * the locale database, which can be overridden with the
+ * -s (Sunday) or -m (Monday) options.
+ */
+-#ifdef HAVE_LANGINFO_H
++#if HAVE_DECL__NL_TIME_WEEK_1STDAY
+ /*
+ * You need to use 2 locale variables to get the first day of the week.
+ * This is needed to support first_weekday=2 and first_workday=1 for
+--
+1.6.3
+
diff --git a/sys-apps/util-linux/util-linux-2.15-r1.ebuild b/sys-apps/util-linux/util-linux-2.15-r1.ebuild
index 066dd612d76a..31a863e037b7 100644
--- a/sys-apps/util-linux/util-linux-2.15-r1.ebuild
+++ b/sys-apps/util-linux/util-linux-2.15-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.15-r1.ebuild,v 1.2 2009/05/24 18:38:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.15-r1.ebuild,v 1.3 2009/05/29 23:49:28 vapier Exp $
EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux-ng/util-linux-ng.git"
inherit eutils autotools
@@ -51,6 +51,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-losetup-symlinks.patch #269264
fi
epatch "${FILESDIR}"/${P}-old-libselinux.patch #270168
+ epatch "${FILESDIR}"/${P}-locale.patch #271154
eautoreconf
fi
use uclibc && sed -i -e s/versionsort/alphasort/g -e s/strverscmp.h/dirent.h/g mount/lomount.c