summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-21 16:30:59 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-21 16:30:59 +0000
commit460a47cfd84accada659090fbc3dfdacb8536446 (patch)
tree0fedd915d96a20c2f894b11a95f7d70834ca3bec /sys-apps/util-linux
parentFix xml, bug #82789 (diff)
downloadgentoo-2-460a47cfd84accada659090fbc3dfdacb8536446.tar.gz
gentoo-2-460a47cfd84accada659090fbc3dfdacb8536446.tar.bz2
gentoo-2-460a47cfd84accada659090fbc3dfdacb8536446.zip
Version bump.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/ChangeLog7
-rw-r--r--sys-apps/util-linux/files/digest-util-linux-2.12q4
-rw-r--r--sys-apps/util-linux/util-linux-2.12q.ebuild141
3 files changed, 151 insertions, 1 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index 9dbdbcce93ab..744cdf995244 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/util-linux
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.100 2005/02/06 20:02:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.101 2005/02/21 16:30:59 vapier Exp $
+
+*util-linux-2.12q (21 Feb 2005)
+
+ 21 Feb 2005; Mike Frysinger <vapier@gentoo.org> +util-linux-2.12q.ebuild:
+ Version bump.
*util-linux-2.12p-r1 (06 Feb 2005)
diff --git a/sys-apps/util-linux/files/digest-util-linux-2.12q b/sys-apps/util-linux/files/digest-util-linux-2.12q
new file mode 100644
index 000000000000..d23da45ac8d5
--- /dev/null
+++ b/sys-apps/util-linux/files/digest-util-linux-2.12q
@@ -0,0 +1,4 @@
+MD5 004b971441ef89e0b93076c21806cc7d util-linux-2.12q.tar.gz 1992810
+MD5 6e0deccf97db98d2ae751577d019efa4 util-linux-2.12i.tar.gz 1975468
+MD5 dee120b17425e1edf0a0c64f0e249c20 util-linux-2.12i-cryptoapi-losetup.patch.bz2 4800
+MD5 96110562e89bfaa501aeebc6e525e1ca util-linux-2.12p.diff.bz2 35205
diff --git a/sys-apps/util-linux/util-linux-2.12q.ebuild b/sys-apps/util-linux/util-linux-2.12q.ebuild
new file mode 100644
index 000000000000..cd12b3e98942
--- /dev/null
+++ b/sys-apps/util-linux/util-linux-2.12q.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12q.ebuild,v 1.1 2005/02/21 16:30:59 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+OLD_CRYPT_VER=2.12i
+DESCRIPTION="Various useful Linux utilities"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
+SRC_URI="mirror://kernel/linux/utils/${PN}/${P}.tar.gz
+ old-crypt? (
+ mirror://kernel/linux/utils/${PN}/${PN}-${OLD_CRYPT_VER}.tar.gz
+ mirror://gentoo/util-linux-${OLD_CRYPT_VER}-cryptoapi-losetup.patch.bz2
+ )
+ crypt? ( http://loop-aes.sourceforge.net/updates/util-linux-2.12p.diff.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="crypt old-crypt nls static pam selinux perl"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r2
+ >=sys-fs/e2fsprogs-1.34
+ selinux? ( sys-libs/libselinux )
+ pam? ( sys-apps/pam-login )
+ crypt? ( app-crypt/hashalot )
+ perl? ( dev-lang/perl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/os-headers"
+
+OLD_CRYPT_P=${WORKDIR}/${PN}-${OLD_CRYPT_VER}
+
+yesno() { useq $1 && echo yes || echo no; }
+
+src_unpack() {
+ unpack ${A}
+
+ # Old crypt support
+ if use old-crypt ; then
+ cd ${OLD_CRYPT_P}
+ epatch ${WORKDIR}/util-linux-${OLD_CRYPT_VER}-cryptoapi-losetup.patch
+ fi
+
+ cd "${S}"
+
+ # crypto support
+ ! use old-crypt && \
+ use crypt && epatch ${WORKDIR}/util-linux-2.12p.diff
+
+ # Fix rare failures with -j4 or higher
+ epatch ${FILESDIR}/${PN}-2.11z-parallel-make.patch
+
+ # Fix unreadable df output when using devfs ... this check is kind of
+ # a hack, but whatever, the output isnt critical at all :P
+ [[ -e /dev/.devfsd ]] && epatch ${FILESDIR}/no-symlink-resolve.patch
+
+ # Add the O option to agetty to display DNS domainname in the issue
+ # file, thanks to Marius Mauch <genone@genone.de>, bug #22275.
+ #
+ # NOTE: Removing this will break future baselayout, so PLEASE
+ # consult with me before doing so.
+ #
+ # <azarah@gentoo.org> (17 Jul 2003)
+ epatch ${FILESDIR}/${PN}-2.11z-agetty-domainname-option.patch
+
+ # Add NFS4 support (kernel 2.5/2.6)
+ epatch ${FILESDIR}/${PN}-2.12i-nfsv4.patch
+
+ # ignore managed/kudzu options #70873
+ epatch ${FILESDIR}/${PN}-2.12i-ignore-managed.patch
+
+ # Allow util-linux to be built with -fPIC
+ epatch ${FILESDIR}/${PN}-2.12i-pic.patch
+
+ # swapon gets confused by symlinks in /dev #69162
+ epatch ${FILESDIR}/${PN}-2.12p-swapon-check-symlinks.patch
+
+ # Enable random features
+ local mconfigs="MCONFIG"
+ use old-crypt && mconfigs="${mconfigs} ${OLD_CRYPT_P}/MCONFIG"
+ sed -i \
+ -e "/^HAVE_PAM=/s:no:$(yesno pam):" \
+ -e "/^HAVE_SELINUX=/s:no:$(yesno selinux):" \
+ -e "/^DISABLE_NLS=/s:no:$(yesno !nls):" \
+ -e "/^HAVE_KILL=/s:no:yes:" \
+ -e "/^HAVE_SLN=/s:no:yes:" \
+ -e "/^HAVE_TSORT/s:no:yes:" \
+ -e "s:-pipe -O2 \$(CPUOPT) -fomit-frame-pointer:${CFLAGS}:" \
+ -e "s:CPU=.*:CPU=${CHOST%%-*}:" \
+ -e "s:SUIDMODE=.*4755:SUIDMODE=4711:" \
+ ${mconfigs} || die "MCONFIG sed"
+}
+
+src_compile() {
+ append-ldflags -Wl,-z,now
+ use static && append-ldflags -static
+ export CC="$(tc-getCC)"
+
+ econf || die "configure failed"
+ emake || die "emake failed"
+
+ cd partx
+ has_version sys-kernel/linux26-headers && append-flags -include linux/compiler.h
+ emake CFLAGS="${CFLAGS}" || die "make partx failed"
+
+ if use old-crypt ; then
+ cd ${OLD_CRYPT_P}
+ econf || die "old configure failed"
+ emake -C lib || die "old lib failed"
+ emake -C mount losetup mount || die "old make failed"
+ fi
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "install failed"
+ dosym ../man8/agetty.8 /usr/share/man/man1/getty.1
+ dosbin partx/{addpart,delpart,partx} || die "dosbin"
+ use perl || rm -f "${D}"/usr/bin/chkdupexe
+
+ dodoc HISTORY MAINTAINER README VERSION
+ docinto examples
+ dodoc example.files/*
+
+ if use old-crypt ; then
+ cd ${OLD_CRYPT_P}/mount
+ into /
+ newsbin mount mount-old-crypt || die
+ newsbin losetup losetup-old-crypt || die
+ fi
+}
+
+pkg_postinst() {
+ if ! use old-crypt ; then
+ ewarn "This version of util-linux includes crypto support"
+ ewarn "for loop-aes instead of the old cryptoapi."
+ ewarn "If you need the older support, please re-emerge"
+ ewarn "util-linux with USE=old-crypt. This will create"
+ ewarn "/sbin/mount-old-crypt and /sbin/losetup-old-crypt."
+ fi
+}