summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-04-25 01:19:47 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-04-25 01:19:47 +0000
commit74ce313677e6b68ce7346a1dadecf2416ddcbc6d (patch)
tree6b420754dabf33acd5cbbf45e7f7fa1bbe3ba767 /sys-apps/util-linux
parentSee ChangeLog and bug 19597 (diff)
downloadgentoo-2-74ce313677e6b68ce7346a1dadecf2416ddcbc6d.tar.gz
gentoo-2-74ce313677e6b68ce7346a1dadecf2416ddcbc6d.tar.bz2
gentoo-2-74ce313677e6b68ce7346a1dadecf2416ddcbc6d.zip
See ChangeLog and bug 19597
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/ChangeLog11
-rw-r--r--sys-apps/util-linux/Manifest4
-rw-r--r--sys-apps/util-linux/files/digest-util-linux-2.11z-r22
-rw-r--r--sys-apps/util-linux/util-linux-2.11z-r2.ebuild91
4 files changed, 105 insertions, 3 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index 5ed1acf4ab8d..2c857b01c0ca 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-apps/util-linux
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.30 2003/04/22 22:16:26 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.31 2003/04/25 01:19:38 lostlogic Exp $
+
+*util-linux-2.11z-r2 (24 Apr 2003)
+
+ 24 Apr 2003; Brandon Low <lostlogic@gentoo.org> util-linux-2.11z-r2.ebuild:
+ Several changes, including support for USE=static the use of sed -i, proper
+ die messages, econf instead of ./configure. Please test this and let me know
+ if there are any regressions
+
+ See bug 19597
*util-linux-2.11z (03 Feb 2003)
diff --git a/sys-apps/util-linux/Manifest b/sys-apps/util-linux/Manifest
index 1e4b0df2bfe8..155be326f7a9 100644
--- a/sys-apps/util-linux/Manifest
+++ b/sys-apps/util-linux/Manifest
@@ -1,8 +1,8 @@
MD5 565d1b898a530f0b451df4f0c4555239 util-linux-2.11y.ebuild 2111
-MD5 9569204f22e4c085f3d7acbe11a19b08 util-linux-2.11z-r2.ebuild 2233
+MD5 762ad536429872ccc946edc3bd96fc22 util-linux-2.11z-r2.ebuild 2256
MD5 59486f0e0487356259342c9f48af09a6 util-linux-2.11z-r1.ebuild 2334
MD5 f57fa14eb16fc800e4aa7a32802a3bd7 util-linux-2.11o-r3.ebuild 1718
-MD5 897b3f3d414c7ed899c97b242eedc429 ChangeLog 4895
+MD5 c1ee28027a26b69862f00a7af88dbe0b ChangeLog 5219
MD5 48e36b9b6ea3bed4ea25292f9ae5a958 files/digest-util-linux-2.11y 152
MD5 e3697bc8fd6a344e8cba1c7d32e34790 files/util-linux-2.11y-parallel-make.patch 369
MD5 939305c630f0d2196de84e79f220dd8d files/digest-util-linux-2.11o-r3 138
diff --git a/sys-apps/util-linux/files/digest-util-linux-2.11z-r2 b/sys-apps/util-linux/files/digest-util-linux-2.11z-r2
new file mode 100644
index 000000000000..b479cd78fc10
--- /dev/null
+++ b/sys-apps/util-linux/files/digest-util-linux-2.11z-r2
@@ -0,0 +1,2 @@
+MD5 abaab0a441233d6b7763b89ea5ab4078 util-linux-2.11z.tar.bz2 1266784
+MD5 9d6c4c8a99188b6696b0735fa48f67c2 util-linux-2.11z-crypt-gentoo.patch.bz2 18249
diff --git a/sys-apps/util-linux/util-linux-2.11z-r2.ebuild b/sys-apps/util-linux/util-linux-2.11z-r2.ebuild
new file mode 100644
index 000000000000..13e203e9659b
--- /dev/null
+++ b/sys-apps/util-linux/util-linux-2.11z-r2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.11z-r2.ebuild,v 1.1 2003/04/25 01:19:38 lostlogic Exp $
+
+IUSE="crypt nls selinux static"
+
+inherit eutils flag-o-matic
+
+filter-flags -fPIC
+
+S=${WORKDIR}/${P}
+CRYPT_PATCH_P="${P}-crypt-gentoo"
+DESCRIPTION="Various useful Linux utilities"
+SRC_URI="http://www.kernel.org/pub/linux/utils/${PN}/${P}.tar.bz2
+ crypt? ( mirror://gentoo/${CRYPT_PATCH_P}.patch.bz2 )"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha arm ~mips"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ >=sed-4.0.5
+ >=sys-libs/ncurses-5.2-r2
+ !selinux? ( sys-apps/pam-login )
+ selinux? ( sys-apps/shadow )"
+
+RDEPEND="${DEPEND} dev-lang/perl
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ if [ ! -z "`use crypt`" ] ; then
+ epatch ${DISTDIR}/${CRYPT_PATCH_P}.patch.bz2
+ fi
+
+ # Fix rare failures with -j4 or higher
+ epatch ${FILESDIR}/${P}-parallel-make.patch
+
+ # Fix unreadable df output
+ epatch ${FILESDIR}/no-symlink-resolve.patch
+
+ # <kumba@gentoo.org> (22 Apr 2003)
+ # Fix fdisk so it works on SGI Disk Labels and lets the user
+ # Actually select a partition, rather than automatically
+ # choosing "4".
+ if [ "${ARCH}" = "mips" ]
+ then
+ epatch ${FILESDIR}/${P}-mips-fdisk-fix.patch
+ fi
+
+
+ sed -i \
+ -e "s:-pipe -O2 \$(CPUOPT) -fomit-frame-pointer:${CFLAGS}:" \
+ -e "s:CPU=.*:CPU=${CHOST%%-*}:" \
+ -e "s:HAVE_PAM=no:HAVE_PAM=yes:" \
+ -e "s:HAVE_SLN=no:HAVE_SLN=yes:" \
+ -e "s:HAVE_TSORT=no:HAVE_TSORT=yes:" \
+ -e "s:usr/man:usr/share/man:" \
+ -e "s:usr/info:usr/share/info:" \
+ MCONFIG || die "MCONFIG sed"
+
+ if [ -z "`use nls`" ] ; then
+ sed -i -e 's/DISABLE_NLS=no/DISABLE_NLS=yes/' MCONFIG ||
+ die "MCONFIG nls sed"
+ fi
+}
+
+src_compile() {
+
+ econf || die "configure failed"
+
+ if [ "`use static`" ] ; then
+ export LDFLAGS=-static
+ fi
+ emake || die "emake failed"
+ cd sys-utils && makeinfo *.texi || die "makeinfo failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+
+ dodoc HISTORY MAINTAINER README VERSION
+ docinto licenses
+ dodoc licenses/* HISTORY
+ docinto examples
+ dodoc example.files/*
+}