summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-04-28 14:40:55 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-04-28 14:40:55 +0000
commit9692b7e6692c1e8058209b6829438fd5e41f8716 (patch)
treefbe23e6b68ebbb2972b3bb6693f94519a5389821 /sys-apps/util-linux
parentslotify (diff)
downloadgentoo-2-9692b7e6692c1e8058209b6829438fd5e41f8716.tar.gz
gentoo-2-9692b7e6692c1e8058209b6829438fd5e41f8716.tar.bz2
gentoo-2-9692b7e6692c1e8058209b6829438fd5e41f8716.zip
pam-login support
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/ChangeLog8
-rw-r--r--sys-apps/util-linux/files/digest-util-linux-2.11o-r32
-rw-r--r--sys-apps/util-linux/util-linux-2.11o-r3.ebuild67
3 files changed, 76 insertions, 1 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index 6006827bda35..d8a48ba5cb8a 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/util-linux
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.5 2002/04/26 05:42:18 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.6 2002/04/28 14:40:08 azarah Exp $
+
+*util-linux-2.11o-r3 (28 Apr 2002)
+
+ 28 Apr 2002; Martin Schlemmer <azarah@gentoo.org> :
+
+ Removed /bin/login in favour of pam-login.
*util-linux-2.11o-r2 (25 Apr 2002)
diff --git a/sys-apps/util-linux/files/digest-util-linux-2.11o-r3 b/sys-apps/util-linux/files/digest-util-linux-2.11o-r3
new file mode 100644
index 000000000000..30b511b04c19
--- /dev/null
+++ b/sys-apps/util-linux/files/digest-util-linux-2.11o-r3
@@ -0,0 +1,2 @@
+MD5 38ddea8feec3af4847012d7a0be2f9ae util-linux-2.11o.tar.gz 1490079
+MD5 dc020755682a383607c792b37b36d94e util-linux-2.11o.patch.gz 18710
diff --git a/sys-apps/util-linux/util-linux-2.11o-r3.ebuild b/sys-apps/util-linux/util-linux-2.11o-r3.ebuild
new file mode 100644
index 000000000000..86d566b8b165
--- /dev/null
+++ b/sys-apps/util-linux/util-linux-2.11o-r3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.11o-r3.ebuild,v 1.1 2002/04/28 14:40:08 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Various useful Linux utilities"
+SRC_URI="http://www.kernel.org/pub/linux/utils/${PN}/${P}.tar.gz
+ http://www.kernel.org/pub/linux/kernel/people/hvr/util-linux-patch-int/${P}.patch.gz"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2-r2
+ sys-apps/pam-login"
+
+RDEPEND="$DEPEND sys-devel/perl
+ nls? ( sys-devel/gettext )"
+
+SLOT="0"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${WORKDIR}
+ cd ${S}
+ gunzip -c ${DISTDIR}/${P}.patch.gz | patch -p0
+ cp MCONFIG MCONFIG.orig
+ sed -e "s:-pipe -O2 \$(CPUOPT) -fomit-frame-pointer:${CFLAGS}:" \
+ -e "s:CPU=.*:CPU=${CHOST%%-*}:" \
+ -e "s:HAVE_PAM=no:HAVE_PAM=yes:" \
+ -e "s:HAVE_SLN=no:HAVE_SLN=yes:" \
+ -e "s:HAVE_TSORT=no:HAVE_TSORT=yes:" \
+ -e "s:usr/man:usr/share/man:" \
+ -e "s:usr/info:usr/share/info:" \
+ MCONFIG.orig > MCONFIG
+}
+
+src_compile() {
+
+ ./configure || die
+
+ if [ -z "`use nls`" ]
+ then
+ cp defines.h defines.h.orig
+ cp Makefile Makefile.orig
+
+ sed -e "s/#define ENABLE_NLS//g" \
+ -e "s/#define HAVE_libintl_h//g" \
+ defines.h.orig > defines.h
+
+ sed "s/\(^SUBDIRS=\)po/\1lib/g" \
+ Makefile.orig > Makefile
+ fi
+
+ emake LDFLAGS="" || die
+ cd sys-utils; makeinfo *.texi || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc HISTORY MAINTAINER README VERSION
+ docinto licenses
+ dodoc licenses/* HISTORY
+ docinto examples
+ dodoc example.files/*
+}
+