summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2007-12-28 14:42:33 +0000
committerMichael Januszewski <spock@gentoo.org>2007-12-28 14:42:33 +0000
commit3c9c828bda4cd35ba67b396648b84315b15af18a (patch)
tree27942f708956a3018bd3d0fc693241200154c07f /sys-apps/v86d/v86d-0.1.3-r1.ebuild
parentAdd the x86emu USE flag for sys-apps/v86d. (diff)
downloadgentoo-2-3c9c828bda4cd35ba67b396648b84315b15af18a.tar.gz
gentoo-2-3c9c828bda4cd35ba67b396648b84315b15af18a.tar.bz2
gentoo-2-3c9c828bda4cd35ba67b396648b84315b15af18a.zip
Add the 'x86emu' USE flag to make it possible to fix problems similar to the ones described in bug #196848.
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'sys-apps/v86d/v86d-0.1.3-r1.ebuild')
-rw-r--r--sys-apps/v86d/v86d-0.1.3-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sys-apps/v86d/v86d-0.1.3-r1.ebuild b/sys-apps/v86d/v86d-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..3a131fc74fb2
--- /dev/null
+++ b/sys-apps/v86d/v86d-0.1.3-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/v86d-0.1.3-r1.ebuild,v 1.1 2007/12/28 14:42:32 spock Exp $
+
+inherit linux-info
+
+DESCRIPTION="A daemon to run x86 code in an emulated environment."
+HOMEPAGE="http://dev.gentoo.org/~spock/projects/uvesafb/"
+SRC_URI="http://dev.gentoo.org/~spock/projects/uvesafb/archive/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug x86emu"
+
+DEPEND="dev-libs/klibc"
+RDEPEND=""
+
+S="${WORKDIR}/${P//_*/}"
+
+pkg_setup() {
+ if [ -z "$(grep V86D /usr/lib/klibc/include/linux/connector.h)" ]; then
+ eerror "You need to compile klibc against a kernel tree patched with uvesafb"
+ eerror "prior to merging this package."
+ die "Kernel not patched with uvesafb."
+ fi
+ linux-info_pkg_setup
+}
+
+src_compile() {
+ local myconf=""
+ if use x86emu ; then
+ myconf="--with-x86emu"
+ fi
+
+ ./configure --with-klibc $(use_with debug) ${myconf}
+ make KDIR=${KV_DIR} || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodoc README ChangeLog
+
+ insinto /usr/share/${PN}
+ doins misc/initramfs
+}
+
+pkg_postinst() {
+ elog "If you wish to place v86d into an initramfs image, you might want to use"
+ elog "'/usr/share/${PN}/initramfs' in your kernel's CONFIG_INITRAMFS_SOURCE."
+}