summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-04-12 17:01:03 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-04-12 17:01:03 +0000
commit72f6e1b4bffdb4c74edc9222516fac04e91d7957 (patch)
treefeaa4e90e6855e485025df9e4b660e03c2f3f550 /sys-apps/vcron
parentsmall fix (diff)
downloadgentoo-2-72f6e1b4bffdb4c74edc9222516fac04e91d7957.tar.gz
gentoo-2-72f6e1b4bffdb4c74edc9222516fac04e91d7957.tar.bz2
gentoo-2-72f6e1b4bffdb4c74edc9222516fac04e91d7957.zip
small fix
Diffstat (limited to 'sys-apps/vcron')
-rw-r--r--sys-apps/vcron/ChangeLog6
-rw-r--r--sys-apps/vcron/Manifest4
-rw-r--r--sys-apps/vcron/vcron-3.0.1-r1.ebuild15
3 files changed, 16 insertions, 9 deletions
diff --git a/sys-apps/vcron/ChangeLog b/sys-apps/vcron/ChangeLog
index 554175432f86..8fde825ac9bb 100644
--- a/sys-apps/vcron/ChangeLog
+++ b/sys-apps/vcron/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for sys-apps/vcron
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/vcron/ChangeLog,v 1.12 2003/03/23 19:20:05 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/vcron/ChangeLog,v 1.13 2003/04/12 17:01:01 seemant Exp $
*vcron-3.0.1-r1 (20 Apr 2002)
+ 12 Apr 2003; Seemant Kulleen <seemant@gentoo.org> Manifest,
+ vcron-3.0.1-r1.ebuild:
+ slight syntax fix to not inherit eutils
+
23 Mar 2003; Joshua Brindle <method@gentoo.org> vcron-3.0.1-r1.ebuild:
added selinux support, thanks pebenito
diff --git a/sys-apps/vcron/Manifest b/sys-apps/vcron/Manifest
index 923d4b0a3ff8..9ca63ab8ee4e 100644
--- a/sys-apps/vcron/Manifest
+++ b/sys-apps/vcron/Manifest
@@ -1,5 +1,5 @@
-MD5 feb9474fe8ced1e1ca7ecfe5b353dd0c ChangeLog 1675
-MD5 daeec6007d58532dee73d1d964c90c39 vcron-3.0.1-r1.ebuild 1575
+MD5 22ff3b322c7e57291fe12c776c48950c ChangeLog 1806
+MD5 cdef7af4d797c31fcf06525a1532c7fe vcron-3.0.1-r1.ebuild 1576
MD5 6a065c2a4012e573ebb852275516a1d4 files/crontab 563
MD5 21a88e40cea6fde9bf6163e501b993dd files/digest-vcron-3.0.1-r1 140
MD5 7f79290c2f51c9dcee459c8a5636f652 files/vcron.rc6 520
diff --git a/sys-apps/vcron/vcron-3.0.1-r1.ebuild b/sys-apps/vcron/vcron-3.0.1-r1.ebuild
index ee90a482e3e3..292b03efb67d 100644
--- a/sys-apps/vcron/vcron-3.0.1-r1.ebuild
+++ b/sys-apps/vcron/vcron-3.0.1-r1.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/vcron/vcron-3.0.1-r1.ebuild,v 1.18 2003/03/23 19:20:05 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/vcron/vcron-3.0.1-r1.ebuild,v 1.19 2003/04/12 17:01:01 seemant Exp $
+
+inherit eutils
IUSE="selinux"
+
MY_P=${P/vcron/vixie-cron}
S=${WORKDIR}/${MY_P}
DESCRIPTION="The Vixie cron daemon"
@@ -12,15 +15,16 @@ HOMEPAGE="http://www.vix.com/"
KEYWORDS="x86 ppc sparc alpha arm mips"
SLOT="0"
LICENSE="as-is"
-inherit eutils
-DEPEND="virtual/glibc
+DEPEND=">=sys-apps/portage-2.0.47-r10
+ >=sys-apps/sed-4.0.5
selinux? ( sys-apps/selinux-small )"
RDEPEND="!virtual/cron
sys-apps/cronbase
virtual/mta
selinux? ( sys-apps/selinux-small )"
+
PROVIDE="virtual/cron"
src_unpack() {
@@ -28,12 +32,11 @@ src_unpack() {
cd ${S}
- patch -p1 < ${FILESDIR}/${MY_P}-gentoo.patch || die
+ epatch ${FILESDIR}/${MY_P}-gentoo.patch
use selinux && epatch ${DISTDIR}/${P}-selinux.patch.bz2
- cp Makefile Makefile.orig
- sed -e "s:-O2:${CFLAGS}:" Makefile.orig > Makefile
+ sed -i "s:-O2:${CFLAGS}:" Makefile
}
src_compile() {