summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-12-11 16:19:37 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-12-11 16:19:37 +0000
commit5a73baff87c37c297688da613ffa8647eb98d9b2 (patch)
tree0d6422d6097912f9af0e9b3cccbba72548349149 /sys-apps/vixie-cron/vixie-cron-3.0.1-r4.ebuild
parentvixie-cron added -- vcron to be removed soon (diff)
downloadgentoo-2-5a73baff87c37c297688da613ffa8647eb98d9b2.tar.gz
gentoo-2-5a73baff87c37c297688da613ffa8647eb98d9b2.tar.bz2
gentoo-2-5a73baff87c37c297688da613ffa8647eb98d9b2.zip
vixie-cron added -- vcron to be removed soon
Diffstat (limited to 'sys-apps/vixie-cron/vixie-cron-3.0.1-r4.ebuild')
-rw-r--r--sys-apps/vixie-cron/vixie-cron-3.0.1-r4.ebuild86
1 files changed, 86 insertions, 0 deletions
diff --git a/sys-apps/vixie-cron/vixie-cron-3.0.1-r4.ebuild b/sys-apps/vixie-cron/vixie-cron-3.0.1-r4.ebuild
new file mode 100644
index 000000000000..86a4c0c0e784
--- /dev/null
+++ b/sys-apps/vixie-cron/vixie-cron-3.0.1-r4.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/vixie-cron/vixie-cron-3.0.1-r4.ebuild,v 1.1 2003/12/11 16:19:36 seemant Exp $
+
+inherit eutils
+
+IUSE="selinux"
+
+SELINUX_PATCH="${P}-selinux.diff.bz2"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The Vixie cron daemon"
+HOMEPAGE=""
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~arm ~mips ~hppa ~ia64"
+
+DEPEND=">=sys-apps/portage-2.0.47-r10
+ >=sys-apps/sed-4.0.5
+ selinux? ( sys-libs/libselinux )"
+
+RDEPEND="!virtual/cron
+ >=sys-apps/cronbase-0.2.1-r3
+ virtual/mta
+ selinux? ( sys-libs/libselinux )"
+
+PROVIDE="virtual/cron"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-gentoo.patch
+ epatch ${FILESDIR}/${P}-close_stdin.diff
+
+ use selinux && epatch ${FILESDIR}/${SELINUX_PATCH}
+
+ sed -i "s:-O2:${CFLAGS}:" Makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ #this does not work if the directory exists already
+ diropts -m0750 -o root -g cron
+ dodir /var/spool/cron/crontabs
+ keepdir /var/spool/cron/crontabs/
+
+ doman crontab.1 crontab.5 cron.8
+
+ dodoc CHANGES CONVERSION FEATURES MAIL MANIFEST README THANKS
+
+ diropts -m0755 ; dodir /etc/cron.d
+ keepdir /etc/cron.d/
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/vixie-cron.rc6 vixie-cron
+
+ insinto /etc
+ insopts -o root -g root -m 0644
+ newins ${FILESDIR}/crontab-3.0.1-r4 crontab
+
+ dodoc ${FILESDIR}/crontab
+
+ insinto /usr/sbin
+ insopts -o root -g root -m 0750 ; doins cron
+
+ insinto /usr/bin
+ insopts -o root -g cron -m 4750 ; doins crontab
+}
+
+pkg_postinst() {
+
+ if [ -f ${ROOT}/etc/init.d/vcron ]
+ then
+ ewarn "Please run:"
+ ewarn "rc-update del vcron"
+ ewarn "rc-update add vixie-cron"
+ fi
+}
+