summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-01-17 01:48:15 +0000
committerMike Frysinger <vapier@gentoo.org>2007-01-17 01:48:15 +0000
commit874c31a94f3de6089857da9431c790b6d6436c3d (patch)
tree230dd00831349a7cd628e3aeac7f4005bb864e82 /sys-apps/watchdog
parentadd back in KEYWORDS (diff)
downloadgentoo-2-874c31a94f3de6089857da9431c790b6d6436c3d.tar.gz
gentoo-2-874c31a94f3de6089857da9431c790b6d6436c3d.tar.bz2
gentoo-2-874c31a94f3de6089857da9431c790b6d6436c3d.zip
Version bump and header cleanup.
(Portage version: 2.1.2)
Diffstat (limited to 'sys-apps/watchdog')
-rw-r--r--sys-apps/watchdog/ChangeLog10
-rw-r--r--sys-apps/watchdog/files/digest-watchdog-5.2.6_p66
-rw-r--r--sys-apps/watchdog/files/watchdog-5.2.6-headers.patch102
-rw-r--r--sys-apps/watchdog/watchdog-5.2.6_p6.ebuild42
4 files changed, 158 insertions, 2 deletions
diff --git a/sys-apps/watchdog/ChangeLog b/sys-apps/watchdog/ChangeLog
index 137ae81b4307..46589da643db 100644
--- a/sys-apps/watchdog/ChangeLog
+++ b/sys-apps/watchdog/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/watchdog
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/watchdog/ChangeLog,v 1.13 2006/07/13 17:16:49 phreak Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/watchdog/ChangeLog,v 1.14 2007/01/17 01:48:15 vapier Exp $
+
+*watchdog-5.2.6_p6 (17 Jan 2007)
+
+ 17 Jan 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/watchdog-5.2.6-headers.patch, +watchdog-5.2.6_p6.ebuild:
+ Version bump and header cleanup.
*watchdog-5.2.6_p2 (13 Jul 2006)
diff --git a/sys-apps/watchdog/files/digest-watchdog-5.2.6_p6 b/sys-apps/watchdog/files/digest-watchdog-5.2.6_p6
new file mode 100644
index 000000000000..c404dbea6cb5
--- /dev/null
+++ b/sys-apps/watchdog/files/digest-watchdog-5.2.6_p6
@@ -0,0 +1,6 @@
+MD5 6e9a66f3e4c312bc76253b7714d65312 watchdog_5.2.6-6.diff.gz 4446
+RMD160 c86f9fd4d8ac00dffa7977ca6fb6e8206fdce906 watchdog_5.2.6-6.diff.gz 4446
+SHA256 f9dc5d99c8191b1a7df8021f77097cd58a6296245534de94a1b7c19e5a08e60c watchdog_5.2.6-6.diff.gz 4446
+MD5 43c33708ac07d458bdbd416812481bab watchdog_5.2.6.orig.tar.gz 138446
+RMD160 accd68437bb986583f02ec9fe7af0c996a7dcaaf watchdog_5.2.6.orig.tar.gz 138446
+SHA256 84f08d17eebb052e165ce69cf4bbf86ff3da8ec2c3f078391a6d999f90b66baf watchdog_5.2.6.orig.tar.gz 138446
diff --git a/sys-apps/watchdog/files/watchdog-5.2.6-headers.patch b/sys-apps/watchdog/files/watchdog-5.2.6-headers.patch
new file mode 100644
index 000000000000..aa03366253b3
--- /dev/null
+++ b/sys-apps/watchdog/files/watchdog-5.2.6-headers.patch
@@ -0,0 +1,102 @@
+pull in more headers for prototypes
+
+--- watchdog-5.2.6/src/fstab.c
++++ watchdog-5.2.6/src/fstab.c
+@@ -2,6 +2,7 @@
+ #include "config.h"
+ #endif
+
++#define _GNU_SOURCE /* for strsignal() */
+ #include <unistd.h>
+ #include <errno.h>
+ #include <stdio.h>
+--- watchdog-5.2.6/src/nfsmount.c
++++ watchdog-5.2.6/src/nfsmount.c
+@@ -41,6 +41,7 @@
+ #include <rpc/pmap_prot.h>
+ #include <rpc/pmap_clnt.h>
+ #include <sys/socket.h>
++#include <time.h>
+ #include <sys/time.h>
+ #include <sys/utsname.h>
+ #include <sys/stat.h>
+--- watchdog-5.2.6/src/pidfile.c
++++ watchdog-5.2.6/src/pidfile.c
+@@ -4,6 +4,10 @@
+
+ #include <errno.h>
+ #include <fcntl.h>
++#include <unistd.h>
++#include <sys/types.h>
++#include <stdlib.h>
++#include <signal.h>
+ #include "extern.h"
+ #include "watch_err.h"
+
+--- watchdog-5.2.6/src/shutdown.c
++++ watchdog-5.2.6/src/shutdown.c
+@@ -2,6 +2,8 @@
+ #include "config.h"
+ #endif
+
++#define _GNU_SOURCE /* for getsid() */
++
+ #include <dirent.h>
+ #include <errno.h>
+ #include <fcntl.h>
+@@ -12,6 +14,7 @@
+ #include <signal.h>
+ #include <string.h>
+ #include <stdlib.h>
++#include <time.h>
+ #include <utmp.h>
+ #include <sys/mman.h>
+ #include <sys/param.h>
+--- watchdog-5.2.6/src/test_binary.c
++++ watchdog-5.2.6/src/test_binary.c
+@@ -8,6 +8,7 @@
+ #include <unistd.h>
+ #include <stdlib.h>
+ #include <sys/wait.h>
++#include <time.h>
+ #include "extern.h"
+ #include "watch_err.h"
+
+--- watchdog-5.2.6/src/wd_keepalive.c
++++ watchdog-5.2.6/src/wd_keepalive.c
+@@ -15,6 +15,7 @@
+ *
+ ***********************************************************/
+
++#define _GNU_SOURCE
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <sched.h>
+@@ -23,7 +24,7 @@
+ #include <stdlib.h>
+ #include <sys/mman.h>
+ #include <sys/wait.h>
+-#define __USE_GNU
++#include <unistd.h>
+ #include <string.h>
+ #include <syslog.h>
+
+--- watchdog-5.2.6/src/watchdog.c
++++ watchdog-5.2.6/src/watchdog.c
+@@ -11,6 +11,8 @@
+
+ #include "extern.h"
+
++#include <sys/stat.h>
++#include <libgen.h>
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <getopt.h>
+@@ -21,7 +23,6 @@
+ #include <arpa/inet.h>
+ #include <sys/mman.h>
+ #include <sys/wait.h>
+-#define __USE_GNU
+ #include <string.h>
+
+ #if !defined(__GLIBC__) /* __GLIBC__ */
diff --git a/sys-apps/watchdog/watchdog-5.2.6_p6.ebuild b/sys-apps/watchdog/watchdog-5.2.6_p6.ebuild
new file mode 100644
index 000000000000..970675e7f425
--- /dev/null
+++ b/sys-apps/watchdog/watchdog-5.2.6_p6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/watchdog/watchdog-5.2.6_p6.ebuild,v 1.1 2007/01/17 01:48:15 vapier Exp $
+
+inherit eutils
+
+MY_P=${PN}_${PV/_p*/}
+S="${WORKDIR}"/${P/_p*/}.orig
+PATCH_LEVEL=${PV##*_p}
+
+DESCRIPTION="A software watchdog"
+HOMEPAGE="http://www.ibiblio.org/pub/Linux/system/daemons/watchdog/"
+SRC_URI="mirror://debian/pool/main/w/watchdog/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/w/watchdog/${MY_P}-${PATCH_LEVEL}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~m68k ~mips ~ppc ~s390 ~sh ~x86"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-${PV/_p*/}-sundries.patch
+ epatch "${FILESDIR}"/${PN}-${PV/_p*/}-headers.patch
+ epatch "${FILESDIR}"/${PN}-${PV/_p*/}-uclibc.patch
+ epatch "${WORKDIR}"/${MY_P}-${PATCH_LEVEL}.diff
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ newconfd "${FILESDIR}"/${PN}-conf.d ${PN}
+ newinitd "${FILESDIR}"/${PN}-init.d ${PN}
+
+ dodoc AUTHORS README TODO
+ docinto examples
+ dodoc examples/*
+}