summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-03-22 22:12:34 +0000
committerMike Frysinger <vapier@gentoo.org>2009-03-22 22:12:34 +0000
commitc4c7b9c1f82d31fbf62a5564c9a5b8f4374b9d1a (patch)
tree1eebb9c2588d400a53bc90d450ef57f0a65d19c7 /sys-apps/watchdog
parentdrop empty DEPEND line (diff)
downloadgentoo-2-c4c7b9c1f82d31fbf62a5564c9a5b8f4374b9d1a.tar.gz
gentoo-2-c4c7b9c1f82d31fbf62a5564c9a5b8f4374b9d1a.tar.bz2
gentoo-2-c4c7b9c1f82d31fbf62a5564c9a5b8f4374b9d1a.zip
Version bump.
(Portage version: 2.2_rc26/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/watchdog')
-rw-r--r--sys-apps/watchdog/ChangeLog8
-rw-r--r--sys-apps/watchdog/files/watchdog-5.6-headers.patch42
-rw-r--r--sys-apps/watchdog/watchdog-5.6.ebuild33
3 files changed, 82 insertions, 1 deletions
diff --git a/sys-apps/watchdog/ChangeLog b/sys-apps/watchdog/ChangeLog
index 2add1721f349..385dea699c57 100644
--- a/sys-apps/watchdog/ChangeLog
+++ b/sys-apps/watchdog/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/watchdog
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/watchdog/ChangeLog,v 1.25 2009/02/25 19:40:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/watchdog/ChangeLog,v 1.26 2009/03/22 22:12:34 vapier Exp $
+
+*watchdog-5.6 (22 Mar 2009)
+
+ 22 Mar 2009; Mike Frysinger <vapier@gentoo.org>
+ +files/watchdog-5.6-headers.patch, +watchdog-5.6.ebuild:
+ Version bump.
*watchdog-5.5 (25 Feb 2009)
diff --git a/sys-apps/watchdog/files/watchdog-5.6-headers.patch b/sys-apps/watchdog/files/watchdog-5.6-headers.patch
new file mode 100644
index 000000000000..846832c6d347
--- /dev/null
+++ b/sys-apps/watchdog/files/watchdog-5.6-headers.patch
@@ -0,0 +1,42 @@
+http://sourceforge.net/tracker/index.php?func=detail&aid=1791328&group_id=172030&atid=860196
+
+pull in more headers for prototypes
+
+--- watchdog-5.6/src/fstab.c
++++ watchdog-5.6/src/fstab.c
+@@ -4,6 +4,7 @@
+ #include "config.h"
+ #endif
+
++#define _GNU_SOURCE /* for strsignal() */
+ #include <unistd.h>
+ #include <errno.h>
+ #include <stdio.h>
+--- watchdog-5.6/src/wd_keepalive.c
++++ watchdog-5.6/src/wd_keepalive.c
+@@ -24,7 +25,7 @@
+ #include <stdlib.h>
+ #include <sys/mman.h>
+ #include <sys/wait.h>
+-#define __USE_GNU
++#include <libgen.h>
+ #include <string.h>
+ #include <syslog.h>
+
+--- watchdog-5.6/src/watchdog.c
++++ watchdog-5.6/src/watchdog.c
+@@ -26,12 +26,10 @@
+ #include <sys/stat.h>
+ #include <sys/types.h>
+ #include <linux/watchdog.h>
+-#define __USE_GNU
+ #include <string.h>
+
+-#if !defined(__GLIBC__) /* __GLIBC__ */
+-extern char *basename(const char *);
+-#endif /* __GLIBC__ */
++#include <sys/ioctl.h>
++#include <libgen.h>
+
+ #include <unistd.h>
+
diff --git a/sys-apps/watchdog/watchdog-5.6.ebuild b/sys-apps/watchdog/watchdog-5.6.ebuild
new file mode 100644
index 000000000000..65ac651efccb
--- /dev/null
+++ b/sys-apps/watchdog/watchdog-5.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/watchdog/watchdog-5.6.ebuild,v 1.1 2009/03/22 22:12:34 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="A software watchdog"
+HOMEPAGE="http://sourceforge.net/projects/watchdog/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~m68k ~mips ~ppc ~s390 ~sh ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-5.6-headers.patch
+ epatch "${FILESDIR}"/${PN}-5.2.6-uclibc.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ newconfd "${FILESDIR}"/${PN}-conf.d ${PN}
+ newinitd "${FILESDIR}"/${PN}-init.d ${PN}
+
+ dodoc AUTHORS README TODO NEWS ChangeLog
+ docinto examples
+ dodoc examples/*
+}