summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-05-04 20:20:43 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-05-04 20:20:43 +0000
commit7843574323ce8ad9b5a93503ea2d0fd60dc16a6a (patch)
tree7c13302372bc594364a5420b273ab277db224e49 /sys-apps/x86info
parentNew ebuild for Dave Jone's x86 cpu util (diff)
downloadgentoo-2-7843574323ce8ad9b5a93503ea2d0fd60dc16a6a.tar.gz
gentoo-2-7843574323ce8ad9b5a93503ea2d0fd60dc16a6a.tar.bz2
gentoo-2-7843574323ce8ad9b5a93503ea2d0fd60dc16a6a.zip
New ebuild for Dave Jone's x86 cpu util
Diffstat (limited to 'sys-apps/x86info')
-rw-r--r--sys-apps/x86info/ChangeLog9
-rw-r--r--sys-apps/x86info/Manifest6
-rw-r--r--sys-apps/x86info/files/digest-x86info-1.111
-rw-r--r--sys-apps/x86info/files/x86info-modules.conf-rc9
-rw-r--r--sys-apps/x86info/x86info-1.11.ebuild73
5 files changed, 95 insertions, 3 deletions
diff --git a/sys-apps/x86info/ChangeLog b/sys-apps/x86info/ChangeLog
new file mode 100644
index 000000000000..00e055532be1
--- /dev/null
+++ b/sys-apps/x86info/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-apps/x86info
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/ChangeLog,v 1.1 2003/05/04 20:20:20 robbat2 Exp $
+
+*x86info-1.11 (04 May 2003)
+
+ 04 May 2003; Robin Johnson <robbat2@gentoo.org> x86info-1.11.ebuild,
+ files/x86info-modules.conf-rc:
+ Initial import. Ebuild submitted by Robin Johnson <robbat2@gentoo.org>.
diff --git a/sys-apps/x86info/Manifest b/sys-apps/x86info/Manifest
index 7facb06d59cf..082db9774b68 100644
--- a/sys-apps/x86info/Manifest
+++ b/sys-apps/x86info/Manifest
@@ -1,4 +1,4 @@
-MD5 9b09698892f36bf3949d62ea67bcf3ea x86info-1.11.ebuild 1826
-MD5 fe1041424b3a13236b73d4c15d83960e ChangeLog 330
+MD5 b247798cb1dabf05bcc9a47d781f15df x86info-1.11.ebuild 1961
+MD5 82ac8d0c63f41a38c11513f3fed67599 ChangeLog 422
MD5 14514d85680a44ebe1a0625f76262b3a files/digest-x86info-1.11 60
-MD5 1d79be846b8d5d7a2242c91370584540 files/x86info-modules.conf-rc 215
+MD5 4291fa4d070c1d2efbabbb2e8cd3fd03 files/x86info-modules.conf-rc 327
diff --git a/sys-apps/x86info/files/digest-x86info-1.11 b/sys-apps/x86info/files/digest-x86info-1.11
new file mode 100644
index 000000000000..6c9e6314afd0
--- /dev/null
+++ b/sys-apps/x86info/files/digest-x86info-1.11
@@ -0,0 +1 @@
+MD5 c383845a7cbaa9c9e9784b1469e19950 x86info-1.11.tgz 40089
diff --git a/sys-apps/x86info/files/x86info-modules.conf-rc b/sys-apps/x86info/files/x86info-modules.conf-rc
new file mode 100644
index 000000000000..5389f135fb22
--- /dev/null
+++ b/sys-apps/x86info/files/x86info-modules.conf-rc
@@ -0,0 +1,9 @@
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/files/x86info-modules.conf-rc,v 1.1 2003/05/04 20:20:20 robbat2 Exp $
+#
+# Aliases needed for x86info to probe data
+# these are so the modules auto-load as needed
+#
+alias char-major-202 msr
+alias char-major-203 cpuid
+alias /dev/cpu/*/msr msr
+alias /dev/cpu/*/cpuid cpuid
diff --git a/sys-apps/x86info/x86info-1.11.ebuild b/sys-apps/x86info/x86info-1.11.ebuild
new file mode 100644
index 000000000000..2e1e33114bb4
--- /dev/null
+++ b/sys-apps/x86info/x86info-1.11.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/x86info-1.11.ebuild,v 1.1 2003/05/04 20:20:20 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Dave Jones' handy, informative x86 CPU diagnostic utility"
+
+HOMEPAGE="http://www.codemonkey.org.uk/x86info/"
+
+SRC_URI="http://www.codemonkey.org.uk/x86info/${P}.tgz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~x86 -ppc -sparc -mips -alpha -arm -hppa"
+
+# fileutils for mknod
+# baselayout for modules-update
+DEPEND="virtual/kernel
+ virtual/glibc
+ sys-apps/fileutils
+ sys-apps/baselayout"
+
+RDEPEND=""
+
+IUSE=""
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ emake x86info CFLAGS="${CFLAGS}" ||die "emake failed"
+}
+
+src_install() {
+ # binaries first
+ into /usr
+ dobin x86info
+ # modules stuff next
+ insinto /etc/modules.d
+ newins ${FILESDIR}/x86info-modules.conf-rc x86info
+ # now we all all the docs
+ dodoc TODO README COPYING ChangeLog
+ doman x86info.1
+ cp -a results ${D}/usr/share/doc/${PF}
+ # prepalldocs rocks! I saw it in net-fs/samba/samba-2.2.8
+ prepalldocs
+ # create device nodes for x86info
+ # based off the scripts/makenode
+ # there isn't any proper devfs support in cpuid/msr
+ mkdir -p ${D}/dev/cpu
+ local numprocs
+ #subtract one because we are using a 0-based count
+ numprocs=$((`grep '^processor' /proc/cpuinfo | wc -l`-1))
+ for i in `seq 0 $numprocs`; do
+ mkdir ${D}/dev/cpu/$i
+ mknod ${D}/dev/cpu/$i/cpuid c 203 $i 2>/dev/null
+ mknod ${D}/dev/cpu/$i/msr c 202 $i 2>/dev/null
+ done
+}
+
+pkg_postinst() {
+ ewarn "Your kernel must be built with the following options"
+ ewarn "set to Y or M"
+ ewarn " Processor type and features ->"
+ ewarn " [*] /dev/cpu/*/msr - Model-specific register support"
+ ewarn " [*] /dev/cpu/*/cpuid - CPU information support"
+ # copied from media-libs/svgalib/svgalib-1.9.17
+ [ "${ROOT}" = "/" ] && /sbin/modules-update &> /dev/null
+}
+
+