summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-07-26 17:53:40 +0000
committerTilman Klar <phoenix@gentoo.org>2002-07-26 17:53:40 +0000
commit73ce526d3463482e58c184a2198b7112ea5ece6b (patch)
tree8a951d32fe5b1e39262dc6b5527dc2665ab75589 /sys-apps/xfsprogs
parentMasked new xfsprogs for testing. (diff)
downloadgentoo-2-73ce526d3463482e58c184a2198b7112ea5ece6b.tar.gz
gentoo-2-73ce526d3463482e58c184a2198b7112ea5ece6b.tar.bz2
gentoo-2-73ce526d3463482e58c184a2198b7112ea5ece6b.zip
Bumped to sys-apps/xfsprogs-20020330-r1 - closes bug #5551
Diffstat (limited to 'sys-apps/xfsprogs')
-rw-r--r--sys-apps/xfsprogs/ChangeLog10
-rw-r--r--sys-apps/xfsprogs/files/digest-xfsprogs-20020330-r11
-rw-r--r--sys-apps/xfsprogs/xfsprogs-20020330-r1.ebuild66
3 files changed, 76 insertions, 1 deletions
diff --git a/sys-apps/xfsprogs/ChangeLog b/sys-apps/xfsprogs/ChangeLog
index 458f5cf9057f..2dfd9099a5b1 100644
--- a/sys-apps/xfsprogs/ChangeLog
+++ b/sys-apps/xfsprogs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/xfsprogs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/xfsprogs/ChangeLog,v 1.3 2002/07/21 21:20:08 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xfsprogs/ChangeLog,v 1.4 2002/07/26 17:53:40 phoenix Exp $
+
+
+*xfsprogs-20020330-r1.ebuild (26 July 2002)
+
+ 26 Jul 2002; phoen][x <phoenix@gentoo.org>:
+ This package will be compiled with -O1 now.
+ Compiling it with a higher setting, breaks xfs_check in
+ a gcc-2.95.3 environment. Closes bug #5551.
*xfsprogs-20020330.ebuild (14 July 2002)
diff --git a/sys-apps/xfsprogs/files/digest-xfsprogs-20020330-r1 b/sys-apps/xfsprogs/files/digest-xfsprogs-20020330-r1
new file mode 100644
index 000000000000..2993709f2f6e
--- /dev/null
+++ b/sys-apps/xfsprogs/files/digest-xfsprogs-20020330-r1
@@ -0,0 +1 @@
+MD5 18bbd9b036cae38073bcaeef8b89ecf6 xfs-cmd-20020330.tar.bz2 1546532
diff --git a/sys-apps/xfsprogs/xfsprogs-20020330-r1.ebuild b/sys-apps/xfsprogs/xfsprogs-20020330-r1.ebuild
new file mode 100644
index 000000000000..6a3fa0e1778c
--- /dev/null
+++ b/sys-apps/xfsprogs/xfsprogs-20020330-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xfsprogs/xfsprogs-20020330-r1.ebuild,v 1.1 2002/07/26 17:53:40 phoenix Exp $
+
+S=${WORKDIR}/cmd/${PN}
+DESCRIPTION="xfs filesystem utilities"
+SRC_URI="http://www.ibiblio.org/gentoo/distfiles/xfs-cmd-${PV}.tar.bz2"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+KEYWORDS="x86 ppc"
+SLOT="0"
+LICENSE="LGPL-2.1"
+oldCFLAGS="${CFLAGS}"
+oldCXXFLAGS="${CXXFLAGS}"
+
+DEPEND="virtual/glibc sys-devel/autoconf sys-devel/make sys-apps/e2fsprogs"
+RDEPEND="virtual/glibc"
+
+ebuild_die() {
+ export CFLAGS="${oldCFLAGS}"
+ export CXXFLAGS="${oldCXXFLAGS}"
+ if([ -n "$LINE" ]) then
+ die "Line ${2}: ${1}"
+ else
+ die "${1}"
+ fi
+}
+
+
+src_compile() {
+ cd ${S}
+ export CFLAGS="`echo ${CFLAGS} | sed "s/ -O[2-9]/ -O1/g"`"
+ export CXXFLAGS="`echo ${CXXFLAGS} | sed "s/ -O[2-9]/ -O1/g"`"
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+ autoconf || die
+ ./configure --prefix=/usr || die
+ # 1) add a ${DESTDIR} prefix to all install paths so we can relocate during the "install" phase
+ # 2) we also set the /usr/share/doc/ directory to the correct value.
+ # 3) we remove a hard-coded "-O1"
+ # 4) we fix some Makefile-created library symlinks that contains absolute paths
+ cp include/builddefs include/builddefs.orig
+ sed -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:" \
+ -e 's:-O1::' \
+ -e '/-S $(PKG/d' \
+ -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' \
+ include/builddefs.orig > include/builddefs || ebuild_die "sed failed" 49
+ emake || ebuild_die "emake failed" 50
+ export ${oldCFLAGS}
+ export ${oldCXXFLAGS}
+}
+
+src_install() {
+ make DESTDIR=${D} DK_INC_DIR=${D}/usr/include/disk install install-dev || ebuild_die "make install failed" 54
+ cat ${S}/libhandle/.libs/libhandle.la | sed -e 's:installed=no:installed=yes:g' > ${D}/usr/lib/libhandle.la
+ dodir /usr/lib /lib
+ insinto /usr/lib
+ doins libhandle.a
+ exeinto /lib
+ doins libhandle.so.1.0.0
+ cd ${D}/lib
+ ln -sf ../usr/lib/libhandle.a libhandle.a
+ ln -sf libhandle.so.1.0.0 libhandle.so.1
+ ln -sf libhandle.so.1 libhandle.so
+ cd ${D}/usr/lib
+ ln -sf ../../lib/libhandle.so libhandle.so
+}