summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-06-28 18:14:11 +0000
committerMike Frysinger <vapier@gentoo.org>2007-06-28 18:14:11 +0000
commit088eb343d1f0976f43c1114df2309197313ec324 (patch)
treec62ce959ea08430363de8a4ea8594fd2f535d5ee /sys-apps
parentAdd mythmovies to plugins list for 0.21 per bug #183538 (diff)
downloadgentoo-2-088eb343d1f0976f43c1114df2309197313ec324.tar.gz
gentoo-2-088eb343d1f0976f43c1114df2309197313ec324.tar.bz2
gentoo-2-088eb343d1f0976f43c1114df2309197313ec324.zip
Version bump.
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/kbd/ChangeLog10
-rw-r--r--sys-apps/kbd/files/digest-kbd-1.133
-rw-r--r--sys-apps/kbd/files/kbd-1.13-dont-use-error.patch14
-rw-r--r--sys-apps/kbd/kbd-1.13.ebuild76
4 files changed, 101 insertions, 2 deletions
diff --git a/sys-apps/kbd/ChangeLog b/sys-apps/kbd/ChangeLog
index 84e889494d99..f68a03b1bea4 100644
--- a/sys-apps/kbd/ChangeLog
+++ b/sys-apps/kbd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/kbd
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kbd/ChangeLog,v 1.61 2006/11/15 13:01:53 corsair Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kbd/ChangeLog,v 1.62 2007/06/28 18:14:11 vapier Exp $
+
+*kbd-1.13 (28 Jun 2007)
+
+ 28 Jun 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/kbd-1.13-dont-use-error.patch, +kbd-1.13.ebuild:
+ Version bump.
15 Nov 2006; Markus Rothe <corsair@gentoo.org> kbd-1.12-r8.ebuild:
Stable on ppc64; bug #153556
diff --git a/sys-apps/kbd/files/digest-kbd-1.13 b/sys-apps/kbd/files/digest-kbd-1.13
new file mode 100644
index 000000000000..de1d94db3669
--- /dev/null
+++ b/sys-apps/kbd/files/digest-kbd-1.13
@@ -0,0 +1,3 @@
+MD5 2639fdfe2412b29cbf6936d7db91cee3 kbd-1.13.tar.bz2 667373
+RMD160 a3d34185d86b532f2cdc8d0834ad5459625b8538 kbd-1.13.tar.bz2 667373
+SHA256 c8a5be1a606d925c3229fa91d3e9dde4e0b61b2c755aff8e699b855f1a402bf6 kbd-1.13.tar.bz2 667373
diff --git a/sys-apps/kbd/files/kbd-1.13-dont-use-error.patch b/sys-apps/kbd/files/kbd-1.13-dont-use-error.patch
new file mode 100644
index 000000000000..eb8cba069da0
--- /dev/null
+++ b/sys-apps/kbd/files/kbd-1.13-dont-use-error.patch
@@ -0,0 +1,14 @@
+dont use GNU-specific function error()
+
+--- openvt/openvt.c
++++ openvt/openvt.c
+@@ -108,7 +108,8 @@
+ for (i=0; i<3; i++) {
+ struct stat st;
+ if (fstat(i, &st) == -1 && open("/dev/null", O_RDWR) == -1)
+- error(EXIT_FAILURE, errno, "open");
++ perror("open(/dev/null/) failed");
++ return EXIT_FAILURE;
+ }
+
+ consfd = getfd(NULL);
diff --git a/sys-apps/kbd/kbd-1.13.ebuild b/sys-apps/kbd/kbd-1.13.ebuild
new file mode 100644
index 000000000000..bb7a65fc8ebb
--- /dev/null
+++ b/sys-apps/kbd/kbd-1.13.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kbd/kbd-1.13.ebuild,v 1.1 2007/06/28 18:14:11 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Keyboard and console utilities"
+HOMEPAGE="http://freshmeat.net/projects/kbd/"
+SRC_URI="ftp://ftp.altlinux.org/pub/people/legion/kbd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^CFLAGS/s:-O2:${CFLAGS}:g" \
+ -e "/^LDFLAGS/s:-s:${LDFLAGS}:" \
+ -e "s:install -s:install:" \
+ src/Makefile.in \
+ openvt/Makefile
+
+ if tc-is-cross-compiler; then
+ tc-export CC
+ # Cross-compiling: don't run test programs
+ sed -i -e "s:&& ./conftest::" configure || \
+ die "Could not do sed configure for cross-compile"
+ fi
+
+ epatch "${FILESDIR}"/${P}-dont-use-error.patch
+ epatch "${FILESDIR}"/${PN}-1.12-configure-LANG.patch #128253
+
+ # fix unimap path issue caused by Debian patch
+ epatch "${FILESDIR}"/${PN}-1.12-unimap.patch
+
+ # Provide a QWERTZ and QWERTY cz map #19010
+ cp data/keymaps/i386/{qwerty,qwertz}/cz.map || die "cz qwerty"
+ epatch "${FILESDIR}"/${PN}-1.12-cz-qwerty-map.patch
+
+ # Fix jp map to recognize Ctrl-[ as Escape #71870
+ epatch "${FILESDIR}"/${PN}-1.12-jp-escape.patch
+
+ # cross-compile fails for powerpc targets bug #133856
+ epatch "${FILESDIR}"/${PN}-1.12-xcompile.patch
+}
+
+src_compile() {
+ local myconf=
+ # Non-standard configure script; --disable-nls to
+ # disable NLS, nothing to enable it.
+ use nls || myconf="--disable-nls"
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --datadir=/usr/share \
+ ${myconf} || die
+
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ mv "${D}"/usr/bin/setfont "${D}"/bin/
+ dosym /bin/setfont /usr/bin/setfont
+
+ dodoc CHANGES CREDITS README
+ dodir /usr/share/doc/${PF}/html
+ cp -dR doc/* "${D}"/usr/share/doc/${PF}/html/
+}