summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-22 04:29:13 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-22 04:29:13 +0000
commit0da81889d23f6b7280e9fdadcc050ad997a6d654 (patch)
treef75581c715b0fed55e80a52364d655e36e7d7efa /sys-apps
parentStable on sparc (Manifest recommit) (diff)
downloadgentoo-2-0da81889d23f6b7280e9fdadcc050ad997a6d654.tar.gz
gentoo-2-0da81889d23f6b7280e9fdadcc050ad997a6d654.tar.bz2
gentoo-2-0da81889d23f6b7280e9fdadcc050ad997a6d654.zip
Remove i686-specific asm code on i486 systems #32429. Fix tail +# syntax #66713. Move [ to same place as test #65296. Fix man-page tests #69216. Fix autotool code #74210. Fix @echo in man/Makefile #53881. Use DESTDIR instead of einstall. Make symlinks absolute #55620.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/coreutils/ChangeLog11
-rw-r--r--sys-apps/coreutils/coreutils-5.2.1-r3.ebuild141
-rw-r--r--sys-apps/coreutils/files/digest-coreutils-5.2.1-r33
3 files changed, 154 insertions, 1 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index ecc7d85db34e..67aa4f51125f 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-apps/coreutils
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.113 2004/09/03 21:03:23 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.114 2004/12/22 04:29:13 vapier Exp $
+
+*coreutils-5.2.1-r3 (21 Dec 2004)
+
+ 21 Dec 2004; Mike Frysinger <vapier@gentoo.org>
+ +coreutils-5.2.1-r3.ebuild:
+ Remove i686-specific asm code on i486 systems #32429. Fix tail +# syntax
+ #66713. Move [ to same place as test #65296. Fix man-page tests #69216. Fix
+ autotool code #74210. Fix @echo in man/Makefile #53881. Use DESTDIR instead
+ of einstall. Make symlinks absolute #55620.
03 Sep 2004; Pieter Van den Abeele <pvdabeel@gentoo.org>
coreutils-5.2.1-r1.ebuild, coreutils-5.2.1-r2.ebuild,
diff --git a/sys-apps/coreutils/coreutils-5.2.1-r3.ebuild b/sys-apps/coreutils/coreutils-5.2.1-r3.ebuild
new file mode 100644
index 000000000000..b24a93541167
--- /dev/null
+++ b/sys-apps/coreutils/coreutils-5.2.1-r3.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.2.1-r3.ebuild,v 1.1 2004/12/22 04:29:13 vapier Exp $
+
+inherit eutils flag-o-matic
+
+PATCH_VER=0.7
+I18N_VER=i18n-0.2
+PATCHDIR=${WORKDIR}/patch
+
+DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls...), text utilities (sort, tr, head, wc..), and shell utilities (whoami, who,...)"
+HOMEPAGE="http://www.gnu.org/software/coreutils/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2
+ mirror://gentoo/${P}-gentoo-${PATCH_VER}.tar.bz2
+ mirror://gentoo/${P}-${I18N_VER}.patch.bz2
+ http://dev.gentoo.org/~seemant/distfiles/${P}-gentoo-${PATCH_VER}.tar.bz2
+ http://dev.gentoo.org/~seemant/distfiles/${P}-${I18N_VER}.patch.bz2
+ http://dev.gentoo.org/~vapier/dist/${P}-gentoo-${PATCH_VER}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls build acl selinux static uclibc"
+
+RDEPEND="selinux? ( sys-libs/libselinux )
+ acl? ( sys-apps/acl sys-apps/attr )
+ nls? ( sys-devel/gettext )
+ >=sys-libs/ncurses-5.3-r5"
+DEPEND="${RDEPEND}
+ virtual/libc
+ >=sys-apps/portage-2.0.49
+ =sys-devel/automake-1.8*
+ >=sys-devel/autoconf-2.58
+ >=sys-devel/m4-1.4-r1
+ !uclibc? ( sys-apps/help2man )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ EPATCH_SUFFIX="patch" epatch ${PATCHDIR}/mandrake
+ epatch ${WORKDIR}/${P}-${I18N_VER}.patch
+
+ # Apply the ACL patches.
+ # WARNING: These CONFLICT with the SELINUX patches
+ if use acl ; then
+ mv ${PATCHDIR}/generic/00{1,2,4}* ${PATCHDIR}/excluded
+ mv ${PATCHDIR}/selinux/001_all_coreutils-noacl* ${PATCHDIR}/excluded
+ EPATCH_SUFFIX="patch" epatch ${PATCHDIR}/acl
+ else
+ mv ${PATCHDIR}/selinux/001_all_coreutils-acl* ${PATCHDIR}/excluded
+ fi
+
+ # patch to remove Stallman's su/wheel group rant (which doesn't apply,
+ # since Gentoo's su is not GNU/su, but that from shadow.
+ # do not include su infopage, as it is not valid for the su
+ # from sys-apps/shadow that we are using.
+ # Patch to add processor specific info to the uname output
+ EPATCH_SUFFIX="patch" epatch ${PATCHDIR}/generic
+ EPATCH_SUFFIX="patch" epatch ${PATCHDIR}/extra
+
+ use selinux && EPATCH_SUFFIX="patch" epatch ${PATCHDIR}/selinux
+
+ # Sparc32 SMP bug fix -- see bug #46593
+ use sparc && echo -ne "\n\n" >> ${S}/src/pr.c
+
+ # Since we've patched many .c files, the make process will
+ # try to re-build the manpages by running `./bin --help`.
+ # When cross-compiling, we can't do that since 'bin' isn't
+ # a native binary, so let's just install outdated man-pages.
+ [[ ${CTARGET:-${CHOST}} != ${CHOST} ]] && touch man/*.1
+}
+
+src_compile() {
+ if ! type -p cvs > /dev/null ; then
+ # Fix issues with gettext's autopoint if cvs is not installed,
+ # bug #28920.
+ export AUTOPOINT="/bin/true"
+ fi
+
+ ebegin "Reconfiguring configure scripts (be patient)"
+ export WANT_AUTOMAKE=1.8
+ export WANT_AUTOCONF=2.5
+
+ mv m4/inttypes.m4 m4/inttypes-eggert.m4
+ touch aclocal.m4 configure config.hin \
+ Makefile.in */Makefile.in */*/Makefile.in
+
+ aclocal -I m4 || die "aclocal"
+ autoconf || die "autoconf"
+ automake || die "automake"
+ eend $?
+
+ econf \
+ --bindir=/bin \
+ --enable-largefile \
+ $(use_enable nls) \
+ $(use_enable selinux) \
+ || die "econf"
+
+ use static && append-ldflags -static
+ emake LDFLAGS="${LDFLAGS}" || die "emake"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+
+ # add DIRCOLORS
+ insinto /etc
+ doins ${FILESDIR}/DIR_COLORS
+
+ # move non-critical packages into /usr
+ cd "${D}"
+ dodir /usr/bin
+ mv bin/{csplit,expand,factor,fmt,fold,join,md5sum,nl,od} usr/bin
+ mv bin/{paste,pathchk,pinky,pr,printf,sha1sum,shred,sum,tac} usr/bin
+ mv bin/{tail,test,[,tsort,unexpand,users} usr/bin
+ cd bin
+ local x
+ for x in * ; do
+ dosym /bin/${x} /usr/bin/${x}
+ done
+
+ if ! use build ; then
+ cd ${S}
+ dodoc AUTHORS ChangeLog* NEWS README* THANKS TODO
+ else
+ rm -r "${D}"/usr/share
+ fi
+}
+
+pkg_postinst() {
+ # hostname does not get removed as it is included with older stage1
+ # tarballs, and net-tools installs to /bin
+ if [ -e ${ROOT}/usr/bin/hostname ] && [ ! -L ${ROOT}/usr/bin/hostname ]
+ then
+ rm -f ${ROOT}/usr/bin/hostname
+ fi
+}
diff --git a/sys-apps/coreutils/files/digest-coreutils-5.2.1-r3 b/sys-apps/coreutils/files/digest-coreutils-5.2.1-r3
new file mode 100644
index 000000000000..320e96f40457
--- /dev/null
+++ b/sys-apps/coreutils/files/digest-coreutils-5.2.1-r3
@@ -0,0 +1,3 @@
+MD5 172ee3c315af93d3385ddfbeb843c53f coreutils-5.2.1.tar.bz2 4270776
+MD5 df84a126243b0510f44670cf1b5b869b coreutils-5.2.1-gentoo-0.7.tar.bz2 64891
+MD5 7dad35dee7a6517440feac4eef8b64c4 coreutils-5.2.1-i18n-0.2.patch.bz2 21795