summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-05-11 15:00:56 +0000
committerMike Frysinger <vapier@gentoo.org>2011-05-11 15:00:56 +0000
commit2903e2714cb7f6a0901272d91249a95c3eb14be0 (patch)
treee869e7895f43722dd76547e58af29371d48ba4d1 /sys-apps
parentold (diff)
downloadgentoo-2-2903e2714cb7f6a0901272d91249a95c3eb14be0.tar.gz
gentoo-2-2903e2714cb7f6a0901272d91249a95c3eb14be0.tar.bz2
gentoo-2-2903e2714cb7f6a0901272d91249a95c3eb14be0.zip
Version bump.
(Portage version: 2.2.0_alpha32/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/findutils/ChangeLog9
-rw-r--r--sys-apps/findutils/findutils-4.5.10.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/sys-apps/findutils/ChangeLog b/sys-apps/findutils/ChangeLog
index ec3e0160ddac..1a1122827227 100644
--- a/sys-apps/findutils/ChangeLog
+++ b/sys-apps/findutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/findutils
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.194 2010/08/15 05:33:52 vapier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.195 2011/05/11 15:00:56 vapier Exp $
+
+*findutils-4.5.10 (11 May 2011)
+
+ 11 May 2011; Mike Frysinger <vapier@gentoo.org> +findutils-4.5.10.ebuild:
+ Version bump.
*findutils-4.5.9 (15 Aug 2010)
diff --git a/sys-apps/findutils/findutils-4.5.10.ebuild b/sys-apps/findutils/findutils-4.5.10.ebuild
new file mode 100644
index 000000000000..4ea729404db3
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.5.10.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.5.10.ebuild,v 1.1 2011/05/11 15:00:56 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+DESCRIPTION="GNU utilities for finding files"
+HOMEPAGE="http://www.gnu.org/software/findutils/"
+SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.gz"
+# mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls selinux static"
+
+RDEPEND="selinux? ( sys-libs/libselinux )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Don't build or install locate because it conflicts with slocate,
+ # which is a secure version of locate. See bug 18729
+ sed -i '/^SUBDIRS/s/locate//' Makefile.in
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ local myconf
+ use userland_GNU || myconf=" --program-prefix=g"
+
+ if echo "#include <regex.h>" | $(tc-getCPP) > /dev/null ; then
+ myconf="${myconf} --without-included-regex"
+ fi
+
+ econf \
+ $(use_enable nls) \
+ --libexecdir=/usr/$(get_libdir)/find \
+ ${myconf} \
+ || die "configure failed"
+ emake AR="$(tc-getAR)" || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc NEWS README TODO ChangeLog
+}