summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-09-15 08:02:51 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-09-15 08:02:51 +0000
commit34c3cddf08693ce8e4f397d369f33a75d405414f (patch)
tree4984892b336ea98a0a8cb5ee3f911dd0087b8963 /sys-apps
parentVersion bump (diff)
downloadgentoo-2-34c3cddf08693ce8e4f397d369f33a75d405414f.tar.gz
gentoo-2-34c3cddf08693ce8e4f397d369f33a75d405414f.tar.bz2
gentoo-2-34c3cddf08693ce8e4f397d369f33a75d405414f.zip
Version bump
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/which/ChangeLog7
-rw-r--r--sys-apps/which/Manifest4
-rw-r--r--sys-apps/which/files/digest-which-2.161
-rw-r--r--sys-apps/which/which-2.16.ebuild38
4 files changed, 47 insertions, 3 deletions
diff --git a/sys-apps/which/ChangeLog b/sys-apps/which/ChangeLog
index 4340597053b0..78a725bbea62 100644
--- a/sys-apps/which/ChangeLog
+++ b/sys-apps/which/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/which
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/which/ChangeLog,v 1.11 2003/09/12 14:58:16 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/which/ChangeLog,v 1.12 2003/09/15 08:02:43 aliz Exp $
+
+*which-2.16 (15 Sep 2003)
+
+ 15 Sep 2003; Daniel Ahlberg <aliz@gentoo.org> which-2.16.ebuild:
+ Version bump
*which-2.15 (12 Sep 2003)
diff --git a/sys-apps/which/Manifest b/sys-apps/which/Manifest
index ad259770d66c..d2c7fe6e6fac 100644
--- a/sys-apps/which/Manifest
+++ b/sys-apps/which/Manifest
@@ -1,7 +1,7 @@
-MD5 a77a4f515120acf37bfcc68144bb1957 ChangeLog 1155
+MD5 d21285c0128f33a5cc349b68dc6706cd ChangeLog 1262
MD5 61c0625cb66855fea2d92b7e97cc7f13 which-2.15.ebuild 852
MD5 b87b97ac3873b14c038e929b7a109d03 which-2.14.ebuild 843
-MD5 61c0625cb66855fea2d92b7e97cc7f13 which-2.16.ebuild 852
+MD5 016ace6dac30c04d355c606c67c408c3 which-2.16.ebuild 849
MD5 7bd6b39a303581edd118b4461f78f7f8 files/digest-which-2.15 62
MD5 87ef8984e2a7429cc4b76123a8166cab files/digest-which-2.14 62
MD5 96aac684502b2a9affae1d965834dd21 files/which-gentoo.patch 340
diff --git a/sys-apps/which/files/digest-which-2.16 b/sys-apps/which/files/digest-which-2.16
new file mode 100644
index 000000000000..8caf068e7798
--- /dev/null
+++ b/sys-apps/which/files/digest-which-2.16
@@ -0,0 +1 @@
+MD5 830b83af48347a9a3520f561e47cbc9b which-2.16.tar.gz 125696
diff --git a/sys-apps/which/which-2.16.ebuild b/sys-apps/which/which-2.16.ebuild
new file mode 100644
index 000000000000..7b261b554dd3
--- /dev/null
+++ b/sys-apps/which/which-2.16.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/which/which-2.16.ebuild,v 1.1 2003/09/15 08:02:43 aliz Exp $
+
+inherit eutils
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Prints out location of specified executables that are in your path"
+HOMEPAGE="http://www.xs4all.nl/~carlo17/which/"
+SRC_URI="http://www.xs4all.nl/~carlo17/which/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+
+RDEPEND="virtual/glibc
+ sys-apps/texinfo"
+
+DEPEND="${RDEPEND}"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/which-gentoo.patch
+}
+
+src_compile() {
+ ./configure --prefix=/usr || die
+ make || die
+}
+
+src_install() {
+ dobin which
+ doman which.1
+ doinfo which.info
+ dodoc AUTHORS COPYING EXAMPLES NEWS README*
+}