summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-26 08:19:13 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-26 08:19:13 +0000
commit39412e62926fb2cc68e565f76e18fcbfa16efb22 (patch)
tree1c597e817c974a096ba2e865a916be1e9bee8415 /sys-apps
parentversion bump, cleaned up some old versions (Manifest recommit) (diff)
downloadgentoo-2-39412e62926fb2cc68e565f76e18fcbfa16efb22.tar.gz
gentoo-2-39412e62926fb2cc68e565f76e18fcbfa16efb22.tar.bz2
gentoo-2-39412e62926fb2cc68e565f76e18fcbfa16efb22.zip
macs suck
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/thinkpad/thinkpad-4.8.ebuild78
1 files changed, 77 insertions, 1 deletions
diff --git a/sys-apps/thinkpad/thinkpad-4.8.ebuild b/sys-apps/thinkpad/thinkpad-4.8.ebuild
index 75f81544c88e..3d002c289e43 100644
--- a/sys-apps/thinkpad/thinkpad-4.8.ebuild
+++ b/sys-apps/thinkpad/thinkpad-4.8.ebuild
@@ -1 +1,77 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc. # Distributed under the terms of the GNU General Public License v2 # $Header: /var/cvsroot/gentoo-x86/sys-apps/thinkpad/thinkpad-4.8.ebuild,v 1.2 2004/01/26 02:21:30 vapier Exp $ inherit eutils #transform P to match tarball versioning MYPV=${PV/_beta/beta} MYP="${PN}_${MYPV}" DESCRIPTION="Thinkpad system control kernel modules" HOMEPAGE="http://tpctl.sourceforge.net/tpctlhome.htm" SRC_URI="mirror://sourceforge/tpctl/${MYP}.tar.gz" LICENSE="GPL-2" SLOT="0" KEYWORDS="-* ~x86 amd64" DEPEND="virtual/glibc" pkg_setup() { enewgroup thinkpad } src_unpack() { check_KV unpack ${A} || die cd ${S} # Use the correct drivers for your kernel. The standard distro comes # with 2.5. mkdir 2.5 mv drivers include 2.5 # Use your kernel version to build. local ver=${KV:0:3} # first 3 chars of $KV, thank you bash :) ln -s $ver/drivers drivers ln -s $ver/include include } src_compile() { check_KV emake DIR_MOD_VER=/lib/modules/${KV} \ DIR_MODULES_VER=/lib/modules/${KV} \ || die "Make failed" } src_install() { dodoc AUTHORS COPYING ChangeLog README SUPPORTED-MODELS TECHNOTES dodir /lib/modules/${KV}/thinkpad cp ${S}/drivers/{thinkpad,smapi,superio,rtcmosram,thinkpadpm}.o \ ${D}/lib/modules/${KV}/thinkpad dodir /etc/modules.d sed 's/%KV%/'${KV}'/g' ${FILESDIR}/thinkpad > ${D}/etc/modules.d/thinkpad dodir /etc/devfs.d echo 'REGISTER ^thinkpad/.*$ PERMISSIONS root.thinkpad 0664' \ > ${D}/etc/devfs.d/thinkpad doman man/*.4 } pkg_postinst() { /usr/sbin/update-modules || return 0 if ! grep -q '^ *INCLUDE.*devfs\.d' /etc/devfsd.conf; then ewarn 'Your /etc/devfsd.conf is missing the include for' ewarn '/etc/devfs.d/! Please fix this by adding' ewarn 'INCLUDE /etc/devfs.d' ewarn 'to your /etc/devfs.conf' fi if grep -q thinkpad /etc/devfsd.conf; then ewarn 'The thinkpad devfsd entry has moved to' ewarn '/etc/devfs.d/thinkpad, so you can remove it from' ewarn '/etc/devfsd.conf if you like.' fi } pkg_prerm() { /sbin/modprobe -r smapi superion rtcmosram thinkpadpm thinkpad } \ No newline at end of file
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/thinkpad/thinkpad-4.8.ebuild,v 1.3 2004/01/26 08:19:13 vapier Exp $
+
+inherit eutils
+
+#transform P to match tarball versioning
+MYPV=${PV/_beta/beta}
+MYP="${PN}_${MYPV}"
+DESCRIPTION="Thinkpad system control kernel modules"
+HOMEPAGE="http://tpctl.sourceforge.net/tpctlhome.htm"
+SRC_URI="mirror://sourceforge/tpctl/${MYP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~x86 amd64"
+
+DEPEND="virtual/glibc"
+
+pkg_setup() {
+ enewgroup thinkpad
+}
+
+src_unpack() {
+ check_KV
+ unpack ${A} || die
+ cd ${S}
+
+ # Use the correct drivers for your kernel. The standard distro comes
+ # with 2.5.
+ mkdir 2.5
+ mv drivers include 2.5
+ # Use your kernel version to build.
+ local ver=${KV:0:3} # first 3 chars of $KV, thank you bash :)
+ ln -s $ver/drivers drivers
+ ln -s $ver/include include
+}
+
+src_compile() {
+ check_KV
+ emake DIR_MOD_VER=/lib/modules/${KV} \
+ DIR_MODULES_VER=/lib/modules/${KV} \
+ || die "Make failed"
+
+}
+
+src_install() {
+ dodoc AUTHORS COPYING ChangeLog README SUPPORTED-MODELS TECHNOTES
+ dodir /lib/modules/${KV}/thinkpad
+ cp ${S}/drivers/{thinkpad,smapi,superio,rtcmosram,thinkpadpm}.o \
+ ${D}/lib/modules/${KV}/thinkpad
+ dodir /etc/modules.d
+ sed 's/%KV%/'${KV}'/g' ${FILESDIR}/thinkpad > ${D}/etc/modules.d/thinkpad
+ dodir /etc/devfs.d
+ echo 'REGISTER ^thinkpad/.*$ PERMISSIONS root.thinkpad 0664' \
+ > ${D}/etc/devfs.d/thinkpad
+ doman man/*.4
+}
+
+pkg_postinst() {
+ /usr/sbin/update-modules || return 0
+ if ! grep -q '^ *INCLUDE.*devfs\.d' /etc/devfsd.conf; then
+ ewarn 'Your /etc/devfsd.conf is missing the include for'
+ ewarn '/etc/devfs.d/! Please fix this by adding'
+ ewarn 'INCLUDE /etc/devfs.d'
+ ewarn 'to your /etc/devfs.conf'
+ fi
+ if grep -q thinkpad /etc/devfsd.conf; then
+ ewarn 'The thinkpad devfsd entry has moved to'
+ ewarn '/etc/devfs.d/thinkpad, so you can remove it from'
+ ewarn '/etc/devfsd.conf if you like.'
+ fi
+}
+
+pkg_prerm() {
+ /sbin/modprobe -r smapi superion rtcmosram thinkpadpm thinkpad
+}