summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChad Huneycutt <chadh@gentoo.org>2001-08-14 01:59:52 +0000
committerChad Huneycutt <chadh@gentoo.org>2001-08-14 01:59:52 +0000
commit444b0d27db1b68495aca15b32083a0990d626640 (patch)
tree7fc285eed93036d8262d6c9c379c371285e38a35 /sys-apps
parentpatch for broken gzexe. (solution -- don't use gzexe). (diff)
downloadgentoo-2-444b0d27db1b68495aca15b32083a0990d626640.tar.gz
gentoo-2-444b0d27db1b68495aca15b32083a0990d626640.tar.bz2
gentoo-2-444b0d27db1b68495aca15b32083a0990d626640.zip
gzexe puts bad path to sleep in zipped executables.
/bin/sleep -> /usr/bin/sleep
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/gzip/files/gzip-1.2.4a-r6-gentoo.diff38
-rw-r--r--sys-apps/gzip/gzip-1.2.4a-r6.ebuild80
2 files changed, 118 insertions, 0 deletions
diff --git a/sys-apps/gzip/files/gzip-1.2.4a-r6-gentoo.diff b/sys-apps/gzip/files/gzip-1.2.4a-r6-gentoo.diff
new file mode 100644
index 000000000000..61ffdaa5cfad
--- /dev/null
+++ b/sys-apps/gzip/files/gzip-1.2.4a-r6-gentoo.diff
@@ -0,0 +1,38 @@
+diff -r -C2 gzip-1.2.4a.orig/gzexe.in gzip-1.2.4a/gzexe.in
+*** gzip-1.2.4a.orig/gzexe.in Thu Jun 24 06:25:05 1993
+--- gzip-1.2.4a/gzexe.in Mon Aug 13 21:48:59 2001
+***************
+*** 97,105 ****
+ if /bin/ln /tmp/gztmp$$ "/tmp/$prog" 2>/dev/null; then
+ trap '/bin/rm -f /tmp/gztmp$$ "/tmp/$prog"; exit $res' 0
+! (/bin/sleep 5; /bin/rm -f /tmp/gztmp$$ "/tmp/$prog") 2>/dev/null &
+ /tmp/"$prog" ${1+"$@"}; res=$?
+ else
+ trap '/bin/rm -f /tmp/gztmp$$; exit $res' 0
+! (/bin/sleep 5; /bin/rm -f /tmp/gztmp$$) 2>/dev/null &
+ /tmp/gztmp$$ ${1+"$@"}; res=$?
+ fi
+--- 97,105 ----
+ if /bin/ln /tmp/gztmp$$ "/tmp/$prog" 2>/dev/null; then
+ trap '/bin/rm -f /tmp/gztmp$$ "/tmp/$prog"; exit $res' 0
+! (/usr/bin/sleep 5; /bin/rm -f /tmp/gztmp$$ "/tmp/$prog") 2>/dev/null &
+ /tmp/"$prog" ${1+"$@"}; res=$?
+ else
+ trap '/bin/rm -f /tmp/gztmp$$; exit $res' 0
+! (/usr/bin/sleep 5; /bin/rm -f /tmp/gztmp$$) 2>/dev/null &
+ /tmp/gztmp$$ ${1+"$@"}; res=$?
+ fi
+diff -r -C2 gzip-1.2.4a.orig/gzip.texi gzip-1.2.4a/gzip.texi
+*** gzip-1.2.4a.orig/gzip.texi Tue Feb 2 18:51:38 1999
+--- gzip-1.2.4a/gzip.texi Mon Aug 13 21:51:58 2001
+***************
+*** 8,11 ****
+--- 8,15 ----
+
+ @ifinfo
++ @direntry
++ * gzip: (gzip). The GNU compression utility.
++ @end direntry
++
+ This file documents the the GNU @code{gzip} command for compressing files.
+
diff --git a/sys-apps/gzip/gzip-1.2.4a-r6.ebuild b/sys-apps/gzip/gzip-1.2.4a-r6.ebuild
new file mode 100644
index 000000000000..09995ae41049
--- /dev/null
+++ b/sys-apps/gzip/gzip-1.2.4a-r6.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# Chad Huneycutt <chad.huneycutt@acm.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gzip/gzip-1.2.4a-r6.ebuild,v 1.1 2001/08/14 01:59:52 chadh Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard GNU compressor"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/gzip/${A}
+ ftp://prep.ai.mit.edu/gnu/gzip/${A}"
+HOMEPAGE="http://www.gnu.org/software/gzip/gzip.html"
+
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ try ./configure --host=${CHOST} --prefix=/usr --exec-prefix=/ \
+ --mandir=/usr/share/man --infodir=/usr/share/info ${myconf}
+
+ if [ -z "`use static`" ]
+ then
+ try pmake
+ else
+ try pmake LDFLAGS=-static ${MAKEOPTS}
+ fi
+}
+
+src_install() {
+
+ dodir /usr/bin /usr/share/man/man1
+ try make prefix=${D}/usr exec_prefix=${D}/ mandir=${D}/usr/share/man/man1 infodir=${D}/usr/share/info install
+
+ cd ${D}/bin
+ for i in gzexe zforce zgrep zmore znew zcmp
+ do
+ cp ${i} ${i}.orig
+ sed -e "1d" -e "s:${D}::" ${i}.orig > ${i}
+ rm ${i}.orig
+ chmod 755 ${i}
+ done
+
+ if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
+ then
+ cd ${D}/usr/share/man/man1
+
+ for i in gzexe gzip zcat zcmp zdiff zforce \
+ zgrep zmore znew
+ do
+ rm ${i}.1
+ ln -s gunzip.1.gz ${i}.1.gz
+ done
+
+ cd ${S}
+ rm -rf ${D}/usr/man ${D}/usr/lib
+
+ dodoc ChangeLog COPYING NEWS README THANKS TODO
+ docinto txt
+ dodoc algorithm.doc gzip.doc
+ else
+ rm -rf ${D}/usr
+ fi
+}
+
+
+
+