summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKito Danya Dietrich <kito@gentoo.org>2005-02-18 07:40:36 +0000
committerKito Danya Dietrich <kito@gentoo.org>2005-02-18 07:40:36 +0000
commit458026c7246719502068336538c6f708e925e120 (patch)
treeccebbfa26cdb69b0462199adc2a2c439f381c3dc /sys-apps
parentStable on mips, bug #81997 (diff)
downloadgentoo-2-458026c7246719502068336538c6f708e925e120.tar.gz
gentoo-2-458026c7246719502068336538c6f708e925e120.tar.bz2
gentoo-2-458026c7246719502068336538c6f708e925e120.zip
fix config.h declaration of raise conflict with signal.h from xnu. minor ebuild cleanup and IUSE="build"
(Portage version: 2.0.51.16)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/bootstrap_cmds/bootstrap_cmds-44.ebuild31
1 files changed, 19 insertions, 12 deletions
diff --git a/sys-apps/bootstrap_cmds/bootstrap_cmds-44.ebuild b/sys-apps/bootstrap_cmds/bootstrap_cmds-44.ebuild
index dd9b8cb19fd2..5c1a27cc1a34 100644
--- a/sys-apps/bootstrap_cmds/bootstrap_cmds-44.ebuild
+++ b/sys-apps/bootstrap_cmds/bootstrap_cmds-44.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/bootstrap_cmds/bootstrap_cmds-44.ebuild,v 1.6 2004/10/08 03:04:51 kito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/bootstrap_cmds/bootstrap_cmds-44.ebuild,v 1.7 2005/02/18 07:40:36 kito Exp $
DESCRIPTION="Darwin bootstrap_cmds - config, decomment, mig, relpath"
HOMEPAGE="http://darwinsource.opendarwin.org/10.3.5/"
@@ -10,7 +10,7 @@ LICENSE="APSL-2"
SLOT="0"
KEYWORDS="~ppc-macos"
-IUSE=""
+IUSE="build"
DEPEND="virtual/libc"
src_unpack() {
@@ -19,23 +19,30 @@ src_unpack() {
cd ${S}
sed -i -e 's:^NEXTSTEP_BUILD_OUTPUT_DIR = .*:NEXTSTEP_BUILD_OUTPUT_DIR = ${T}:' Makefile
+ cd ${S}/config.tproj
+ sed -i -e '/raise/d' config.h
+
cd ${S}/decomment.tproj
- sed -i -e 's:^NEXTSTEP_INSTALLDIR = .*:NEXTSTEP_INSTALLDIR = /usr/bin:' Makefile
- sed -i -e 's:^NEXTSTEP_BUILD_OUTPUT_DIR = .*:NEXTSTEP_BUILD_OUTPUT_DIR = ${T}:' Makefile
+ sed -i \
+ -e 's:^NEXTSTEP_INSTALLDIR = .*:NEXTSTEP_INSTALLDIR = /usr/bin:' \
+ -e 's:^NEXTSTEP_BUILD_OUTPUT_DIR = .*:NEXTSTEP_BUILD_OUTPUT_DIR = ${T}:' Makefile
cd ${S}/relpath.tproj
- sed -i -e 's:^NEXTSTEP_INSTALLDIR = .*:NEXTSTEP_INSTALLDIR = /usr/bin:' Makefile
- sed -i -e 's:^NEXTSTEP_BUILD_OUTPUT_DIR = .*:NEXTSTEP_BUILD_OUTPUT_DIR = ${T}:' Makefile
+ sed -i \
+ -e 's:^NEXTSTEP_INSTALLDIR = .*:NEXTSTEP_INSTALLDIR = /usr/bin:' \
+ -e 's:^NEXTSTEP_BUILD_OUTPUT_DIR = .*:NEXTSTEP_BUILD_OUTPUT_DIR = ${T}:' Makefile
+
+ rm ${S}/Makefile.postamble ${S}/config.tproj/Makefile.postamble \
+ ${S}/decomment.tproj/Makefile.postamble ${S}/relpath.tproj/Makefile.postamble
+}
- rm ${S}/Makefile.postamble
- rm ${S}/config.tproj/Makefile.postamble
- rm ${S}/decomment.tproj/Makefile.postamble
- rm ${S}/relpath.tproj/Makefile.postamble
+src_compile() {
+ :
}
src_install() {
make install DSTROOT=${D} || die "make install failed"
newbin vers_string.sh vers_string
- doman *.1
+ use build || doman *.1
} \ No newline at end of file