summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2011-11-12 22:16:56 +0000
committerLars Wendler <polynomial-c@gentoo.org>2011-11-12 22:16:56 +0000
commit47afbfacd8d15649cc5350512ac671d6c2f7fd76 (patch)
tree5441910c1283ddc0eaf55780da48fd6375cde12c /sys-apps
parentFixed dependency on libreoffice{,-bin} packages (bug #390271) (diff)
downloadgentoo-2-47afbfacd8d15649cc5350512ac671d6c2f7fd76.tar.gz
gentoo-2-47afbfacd8d15649cc5350512ac671d6c2f7fd76.tar.bz2
gentoo-2-47afbfacd8d15649cc5350512ac671d6c2f7fd76.zip
Really fixed bug #375165 with solution suggested by Jiří Moravec
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/util-linux/ChangeLog8
-rw-r--r--sys-apps/util-linux/files/util-linux-2.19.1-remove-useless-if-stuff-from-loopaes-patchset.diff27
-rw-r--r--sys-apps/util-linux/util-linux-2.19.1-r1.ebuild16
3 files changed, 16 insertions, 35 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index 78872fe0b35a..622dc0531bc2 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/util-linux
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.360 2011/11/12 20:49:10 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.361 2011/11/12 22:16:56 polynomial-c Exp $
+
+ 12 Nov 2011; Lars Wendler <polynomial-c@gentoo.org>
+ util-linux-2.19.1-r1.ebuild,
+ -files/util-linux-2.19.1-remove-useless-if-stuff-from-loopaes-patchset.diff:
+ non-maintainer commit: Really fixed bug #375165 with solution suggested by
+ Jiří Moravec.
12 Nov 2011; Lars Wendler <polynomial-c@gentoo.org>
util-linux-2.19.1-r1.ebuild,
diff --git a/sys-apps/util-linux/files/util-linux-2.19.1-remove-useless-if-stuff-from-loopaes-patchset.diff b/sys-apps/util-linux/files/util-linux-2.19.1-remove-useless-if-stuff-from-loopaes-patchset.diff
deleted file mode 100644
index 4e990b01c10e..000000000000
--- a/sys-apps/util-linux/files/util-linux-2.19.1-remove-useless-if-stuff-from-loopaes-patchset.diff
+++ /dev/null
@@ -1,27 +0,0 @@
-This code coming from the loop-aes patch breaks the umount-l patch from
-Gentoo bug #370051.
-
-Signed-off-by: Lars Wendler (Polynomial-C) <polynomial-c@gentoo.org>
-X-Gentoo-Bug: 375165
-X-Gentoo-Bug-URL: https://bugs.gentoo.org/375165
-
---- util-linux-2.19.1/mount/umount.c
-+++ util-linux-2.19.1/mount/umount.c
-@@ -581,9 +581,6 @@
-
- file = canonicalize(arg); /* mtab paths are canonicalized */
-
--/* This is too buggy code. If find_loopdev_by_backing_file() actually finds matching */
--/* loop device, and assigns file=loopdev, then writable /etc/mtab case fails horribly */
--#if 0
- /* if file is a regular file, check if it is associated
- * with some loop device
- */
-@@ -603,7 +600,6 @@
- break;
- }
- }
--#endif
-
- if (verbose > 1)
- printf(_("Trying to unmount %s\n"), file);
diff --git a/sys-apps/util-linux/util-linux-2.19.1-r1.ebuild b/sys-apps/util-linux/util-linux-2.19.1-r1.ebuild
index f8a30c67f07e..ec56e1752fe1 100644
--- a/sys-apps/util-linux/util-linux-2.19.1-r1.ebuild
+++ b/sys-apps/util-linux/util-linux-2.19.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.19.1-r1.ebuild,v 1.8 2011/11/12 20:49:10 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.19.1-r1.ebuild,v 1.9 2011/11/12 22:16:56 polynomial-c Exp $
EAPI="3"
@@ -45,14 +45,16 @@ src_prepare() {
autopoint --force
eautoreconf
else
- if use loop-aes ; then
- epatch "${WORKDIR}"/util-linux-*.diff \
- "${FILESDIR}"/${P}-remove-useless-if-stuff-from-loopaes-patchset.diff
- fi
-
+ use loop-aes && epatch "${WORKDIR}"/util-linux-*.diff
fi
epatch "${FILESDIR}"/${P}-mount-a-segv.patch #366213
- epatch "${FILESDIR}"/${P}-umount-l-nfs.patch #370051
+ if ! use loop-aes ; then
+ epatch "${FILESDIR}"/${P}-umount-l-nfs.patch #370051
+ else
+ ewarn "loop-aes is incompatible with current solution of #370051 bug!"
+ ewarn "Therefore you're vulnerable to that bug now!"
+ ewarn "Look at https://bugs.gentoo.org/show_bug.cgi?id=370051."
+ fi
use uclibc && sed -i -e s/versionsort/alphasort/g -e s/strverscmp.h/dirent.h/g mount/lomount.c
elibtoolize
}