summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-10-21 23:00:47 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-10-21 23:00:47 +0000
commit53a5da72368ba10106e2baca9233a76d4643e6af (patch)
tree4e9d6eea51e439aca2416848edc90c221ab6fa06 /sys-apps
parentUse MERGE_TYPE variable only for EAPI=4, bug 385589 (diff)
downloadgentoo-2-53a5da72368ba10106e2baca9233a76d4643e6af.tar.gz
gentoo-2-53a5da72368ba10106e2baca9233a76d4643e6af.tar.bz2
gentoo-2-53a5da72368ba10106e2baca9233a76d4643e6af.zip
Revision bump to make the new init script follow the more declarative OpenRC style.
(Portage version: 2.2.0_alpha69/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pcsc-lite/ChangeLog9
-rw-r--r--sys-apps/pcsc-lite/files/pcscd-init.523
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.7.4-r2.ebuild86
3 files changed, 117 insertions, 1 deletions
diff --git a/sys-apps/pcsc-lite/ChangeLog b/sys-apps/pcsc-lite/ChangeLog
index 888bb891a0d8..d27d731d6c47 100644
--- a/sys-apps/pcsc-lite/ChangeLog
+++ b/sys-apps/pcsc-lite/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/pcsc-lite
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.121 2011/10/17 20:44:27 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.122 2011/10/21 23:00:47 flameeyes Exp $
+
+*pcsc-lite-1.7.4-r2 (21 Oct 2011)
+
+ 21 Oct 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ +pcsc-lite-1.7.4-r2.ebuild, +files/pcscd-init.5:
+ Revision bump to make the new init script follow the more declarative OpenRC
+ style.
17 Oct 2011; Markus Meier <maekke@gentoo.org> pcsc-lite-1.7.2-r2.ebuild:
arm stable, bug #386345
diff --git a/sys-apps/pcsc-lite/files/pcscd-init.5 b/sys-apps/pcsc-lite/files/pcscd-init.5
new file mode 100644
index 000000000000..ce4cbee21c66
--- /dev/null
+++ b/sys-apps/pcsc-lite/files/pcscd-init.5
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/files/pcscd-init.5,v 1.1 2011/10/21 23:00:47 flameeyes Exp $
+
+name="PC/SC Daemon"
+
+pidfile=/var/run/pcscd/pcscd.pid
+
+command=/usr/sbin/pcscd
+command_args="${EXTRA_OPTS}"
+
+start_stop_daemon_args="--user pcscd:pcscd"
+
+depend() {
+ need localmount
+
+ after udev openct
+}
+
+start_pre() {
+ checkpath -d -m 0755 -o pcscd:pcscd /var/run/pcscd
+}
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.7.4-r2.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.7.4-r2.ebuild
new file mode 100644
index 000000000000..33da0b0edb69
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.7.4-r2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/pcsc-lite-1.7.4-r2.ebuild,v 1.1 2011/10/21 23:00:47 flameeyes Exp $
+
+EAPI="4"
+
+inherit multilib eutils
+
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="http://pcsclite.alioth.debian.org/"
+
+STUPID_NUM="3598"
+MY_P="${PN}-${PV/_/-}"
+SRC_URI="http://alioth.debian.org/download.php/${STUPID_NUM}/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="usb kernel_linux"
+
+RDEPEND="!kernel_linux? ( usb? ( virtual/libusb:1 ) )
+ kernel_linux? ( sys-fs/udev )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${RDEPEND}
+ !<app-crypt/ccid-1.4.1-r1"
+
+pkg_setup() {
+ enewgroup openct # make sure it exists
+ enewgroup pcscd
+ enewuser pcscd -1 -1 /var/run/pcscd pcscd,openct
+}
+
+src_configure() {
+ local myconf=
+
+ if use kernel_linux; then
+ myconf="${myconf} --enable-libudev --disable-libusb"
+ else
+ myconf="${myconf} --disable-libudev $(use_enable usb libusb)"
+ fi
+
+ econf \
+ --disable-maintainer-mode \
+ --disable-dependency-tracking \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --enable-usbdropdir="${EPREFIX}/usr/$(get_libdir)/readers/usb" \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ find "${D}" -name '*.la' -delete
+
+ dodoc AUTHORS DRIVERS HELP README SECURITY ChangeLog
+
+ newinitd "${FILESDIR}/pcscd-init.5" pcscd
+
+ if use kernel_linux; then
+ insinto /lib/udev/rules.d
+ doins "${FILESDIR}"/99-pcscd-hotplug.rules
+ fi
+}
+
+pkg_postinst() {
+ elog "Starting from version 1.6.5, pcsc-lite will start as user nobody in"
+ elog "the pcscd group, to avoid running as root."
+ elog ""
+ elog "This also means you need the newest drivers available so that the"
+ elog "devices get the proper owner."
+ elog ""
+ elog "Furthermore, a conf.d file is no longer installed by default, as"
+ elog "the default configuration does not require one. If you need to"
+ elog "pass further options to pcscd, create a file and set the"
+ elog "EXTRA_OPTS variable."
+ elog ""
+ if use kernel_linux; then
+ elog "HAL support has been dropped by the ebuild; if you want hotplug"
+ elog "support, that's provided already by UDEV rules; you only need to"
+ elog "tell the init system to hotplug it, by setting this variable in"
+ elog "/etc/rc.conf:"
+ elog ""
+ elog " rc_hotplug=\"pcscd\""
+ fi
+}