summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-10-14 01:33:14 +0000
committerMike Frysinger <vapier@gentoo.org>2006-10-14 01:33:14 +0000
commit5d15933ac5f7a762f5f93a9c90c4b45c63ec4e2f (patch)
tree877f192684035678fb1eb97a1669b39084e10c50 /sys-apps
parentstabilize (diff)
downloadgentoo-2-5d15933ac5f7a762f5f93a9c90c4b45c63ec4e2f.tar.gz
gentoo-2-5d15933ac5f7a762f5f93a9c90c4b45c63ec4e2f.tar.bz2
gentoo-2-5d15933ac5f7a762f5f93a9c90c4b45c63ec4e2f.zip
Version bump.
(Portage version: 2.1.2_pre2-r9)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/iproute2/ChangeLog8
-rw-r--r--sys-apps/iproute2/files/digest-iproute2-2.6.18.200610023
-rw-r--r--sys-apps/iproute2/iproute2-2.6.18.20061002.ebuild92
3 files changed, 102 insertions, 1 deletions
diff --git a/sys-apps/iproute2/ChangeLog b/sys-apps/iproute2/ChangeLog
index b210847d0ac3..0d17b0c02cec 100644
--- a/sys-apps/iproute2/ChangeLog
+++ b/sys-apps/iproute2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/iproute2
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/ChangeLog,v 1.58 2006/09/06 08:40:00 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/ChangeLog,v 1.59 2006/10/14 01:33:14 vapier Exp $
+
+*iproute2-2.6.18.20061002 (14 Oct 2006)
+
+ 14 Oct 2006; Mike Frysinger <vapier@gentoo.org>
+ +iproute2-2.6.18.20061002.ebuild:
+ Version bump.
06 Sep 2006; Roy Marples <uberlord@gentoo.org>
iproute2-2.6.16.20060323.ebuild:
diff --git a/sys-apps/iproute2/files/digest-iproute2-2.6.18.20061002 b/sys-apps/iproute2/files/digest-iproute2-2.6.18.20061002
new file mode 100644
index 000000000000..edcf99081fec
--- /dev/null
+++ b/sys-apps/iproute2/files/digest-iproute2-2.6.18.20061002
@@ -0,0 +1,3 @@
+MD5 193b570128cf852afba337438413adf9 iproute2-2.6.18-061002.tar.gz 390298
+RMD160 3e55f4e7d5022f84073157d943cd0002b304f5b7 iproute2-2.6.18-061002.tar.gz 390298
+SHA256 038aabd2894f46d3a4a7583ab2bff13b2da51682ccb921ceb7c87326ec1d344f iproute2-2.6.18-061002.tar.gz 390298
diff --git a/sys-apps/iproute2/iproute2-2.6.18.20061002.ebuild b/sys-apps/iproute2/iproute2-2.6.18.20061002.ebuild
new file mode 100644
index 000000000000..b27c1b2100cc
--- /dev/null
+++ b/sys-apps/iproute2/iproute2-2.6.18.20061002.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.6.18.20061002.ebuild,v 1.1 2006/10/14 01:33:14 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+MY_PV=${PV%.*}
+SNAP=${PV##*.}
+SNAP=${SNAP:2}
+DESCRIPTION="kernel routing and traffic control utilities"
+HOMEPAGE="http://linux-net.osdl.org/index.php/Iproute2"
+SRC_URI="http://developer.osdl.org/dev/iproute2/download/${PN}-${MY_PV}-${SNAP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="atm berkdb minimal"
+
+RDEPEND="!minimal? ( berkdb? ( sys-libs/db ) )
+ atm? ( net-dialup/linux-atm )"
+DEPEND="${RDEPEND}
+ >=virtual/os-headers-2.4.21"
+
+S=${WORKDIR}/${PN}-${MY_PV}-${SNAP}
+
+pkg_setup() {
+ if use kernel_linux ; then
+ ewarn
+ ewarn "${PN} requires kernel support for Netlink (CONFIG_NETLINK)."
+ ewarn "This is only applies for kernels prior to 2.4.17"
+ ewarn
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i "s:-O2:${CFLAGS}:" Makefile || die "sed Makefile failed"
+
+ epatch "${FILESDIR}"/${PN}-2.6.16.20060323-build.patch #137574
+ epatch "${FILESDIR}"/${PN}-2.6.16.20060323-routef-safe.patch #139853
+
+ #68948 - esfq/wrr patches
+ epatch "${FILESDIR}"/${PN}-051007-esfq-2.6.13.patch
+ epatch "${FILESDIR}"/${PN}-2.6.11.20050330-wrr.patch
+
+ # don't build arpd if USE=-berkdb #81660
+ use berkdb || sed -i '/^TARGETS=/s: arpd : :' misc/Makefile
+ # Multilib fixes
+ sed -i 's:/usr/local:/usr:' tc/m_ipt.c include/iptables.h
+ sed -i "s:/usr/lib:/usr/$(get_libdir):g" \
+ netem/Makefile tc/{Makefile,tc.c,q_netem.c,m_ipt.c} include/iptables.h || die
+ # Use correct iptables dir, #144265.
+ sed -i "s:/usr/local/lib/iptables:/$(get_libdir)/iptables:g" \
+ include/iptables.h
+}
+
+src_compile() {
+ echo -n 'TC_CONFIG_ATM:=' > Config
+ use atm \
+ && echo 'y' >> Config \
+ || echo 'n' >> Config
+
+ local SUBDIRS="lib ip tc misc netem"
+ use minimal && SUBDIRS="lib tc"
+ emake \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ SUBDIRS="${SUBDIRS}" \
+ || die "make"
+}
+
+src_install() {
+ if use minimal ; then
+ into /
+ dosbin tc/tc || die "minimal"
+ return 0
+ fi
+
+ make \
+ DESTDIR="${D}" \
+ SBINDIR=/sbin \
+ DOCDIR=/usr/share/doc/${PF} \
+ install \
+ || die "make install failed"
+ if use berkdb ; then
+ dodir /var/lib/arpd
+ # bug 47482, arpd doesn't need to be in /sbin
+ dodir /usr/sbin
+ mv "${D}"/sbin/arpd "${D}"/usr/sbin/
+ fi
+}