summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-04-06 20:13:13 +0000
committerMichał Górny <mgorny@gentoo.org>2012-04-06 20:13:13 +0000
commit6ffc5e486fff8a641a6c7906f83129acb070191b (patch)
tree6ede2ea99ff5defc369aa61e6c7f1f8b14e34988 /sys-apps
parentVersion bump. Ebuild rewritten and largely simplified. (diff)
downloadgentoo-2-6ffc5e486fff8a641a6c7906f83129acb070191b.tar.gz
gentoo-2-6ffc5e486fff8a641a6c7906f83129acb070191b.tar.bz2
gentoo-2-6ffc5e486fff8a641a6c7906f83129acb070191b.zip
Add a patch for ARM and keyword wrt bug #410973.
(Portage version: 2.2.0_alpha99_p2/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd/ChangeLog6
-rw-r--r--sys-apps/systemd/files/0002-journal-PAGE_SIZE-is-not-known-on-ppc-and-other-arch.patch48
-rw-r--r--sys-apps/systemd/systemd-44.ebuild6
3 files changed, 57 insertions, 3 deletions
diff --git a/sys-apps/systemd/ChangeLog b/sys-apps/systemd/ChangeLog
index 3ae572f220c6..0e5bf6e26e25 100644
--- a/sys-apps/systemd/ChangeLog
+++ b/sys-apps/systemd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/systemd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.28 2012/04/05 18:40:59 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.29 2012/04/06 20:13:13 mgorny Exp $
+
+ 06 Apr 2012; Michał Górny <mgorny@gentoo.org> systemd-44.ebuild,
+ +files/0002-journal-PAGE_SIZE-is-not-known-on-ppc-and-other-arch.patch:
+ Add a patch for ARM and keyword wrt bug #410973.
05 Apr 2012; Michał Górny <mgorny@gentoo.org> systemd-44.ebuild:
Avoid installing duplicate systemadm manpage.
diff --git a/sys-apps/systemd/files/0002-journal-PAGE_SIZE-is-not-known-on-ppc-and-other-arch.patch b/sys-apps/systemd/files/0002-journal-PAGE_SIZE-is-not-known-on-ppc-and-other-arch.patch
new file mode 100644
index 000000000000..61277af03eca
--- /dev/null
+++ b/sys-apps/systemd/files/0002-journal-PAGE_SIZE-is-not-known-on-ppc-and-other-arch.patch
@@ -0,0 +1,48 @@
+From 7264278fbbdc1dc6c30fedc902d1337594aa6ff6 Mon Sep 17 00:00:00 2001
+From: Lennart Poettering <lennart@poettering.net>
+Date: Wed, 21 Mar 2012 23:47:44 +0100
+Subject: [PATCH] journal: PAGE_SIZE is not known on ppc and other archs
+
+Let's use NAME_MAX, as suggested by Dan Walsh
+---
+ src/journal/journald.c | 15 ++++++++++++---
+ 1 file changed, 12 insertions(+), 3 deletions(-)
+
+diff --git a/src/journal/journald.c b/src/journal/journald.c
+index d27cb60..87390bd 100644
+--- a/src/journal/journald.c
++++ b/src/journal/journald.c
+@@ -29,7 +29,6 @@
+ #include <sys/ioctl.h>
+ #include <linux/sockios.h>
+ #include <sys/statvfs.h>
+-#include <sys/user.h>
+
+ #include <systemd/sd-journal.h>
+ #include <systemd/sd-login.h>
+@@ -2149,10 +2148,20 @@ static int process_event(Server *s, struct epoll_event *ev) {
+ size_t label_len = 0;
+ union {
+ struct cmsghdr cmsghdr;
++
++ /* We use NAME_MAX space for the
++ * SELinux label here. The kernel
++ * currently enforces no limit, but
++ * according to suggestions from the
++ * SELinux people this will change and
++ * it will probably be identical to
++ * NAME_MAX. For now we use that, but
++ * this should be updated one day when
++ * the final limit is known.*/
+ uint8_t buf[CMSG_SPACE(sizeof(struct ucred)) +
+ CMSG_SPACE(sizeof(struct timeval)) +
+- CMSG_SPACE(sizeof(int)) +
+- CMSG_SPACE(PAGE_SIZE)]; /* selinux label */
++ CMSG_SPACE(sizeof(int)) + /* fd */
++ CMSG_SPACE(NAME_MAX)]; /* selinux label */
+ } control;
+ ssize_t n;
+ int v;
+--
+1.7.9.4
+
diff --git a/sys-apps/systemd/systemd-44.ebuild b/sys-apps/systemd/systemd-44.ebuild
index 563da5a8894f..f0d347944b0d 100644
--- a/sys-apps/systemd/systemd-44.ebuild
+++ b/sys-apps/systemd/systemd-44.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-44.ebuild,v 1.2 2012/04/05 18:40:59 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-44.ebuild,v 1.3 2012/04/06 20:13:13 mgorny Exp $
EAPI=4
@@ -12,7 +12,7 @@ SRC_URI="http://www.freedesktop.org/software/systemd/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~arm ~x86"
IUSE="acl audit cryptsetup lzma pam plymouth selinux tcpd"
# We need to depend on sysvinit for sulogin which is used in the rescue
@@ -50,6 +50,8 @@ DEPEND="${RDEPEND}
PATCHES=(
# bug #408879: Session Logout File Deletion Weakness (CVE-2012-1174)
"${FILESDIR}"/0001-util-never-follow-symlinks-in-rm_rf_children.patch
+ # bug #410973: fails to build on ARM due to PAGE_SIZE not being defined
+ "${FILESDIR}"/0002-journal-PAGE_SIZE-is-not-known-on-ppc-and-other-arch.patch
)
pkg_setup() {