summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-07-25 09:26:12 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-07-25 09:26:12 +0000
commit863dcefc8ea92e19b9b54c60d89a768113ac7d3d (patch)
tree2dae79a2feea8f2e912b6c9ee3e32eab91de1012 /sys-apps
parentAdd check for boost build with python use flag when python-bindings is enabled. (diff)
downloadgentoo-2-863dcefc8ea92e19b9b54c60d89a768113ac7d3d.tar.gz
gentoo-2-863dcefc8ea92e19b9b54c60d89a768113ac7d3d.tar.bz2
gentoo-2-863dcefc8ea92e19b9b54c60d89a768113ac7d3d.zip
Conditionalize libpcre built_with_use check under either qa or inquisitio use flags.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/paludis/ChangeLog6
-rw-r--r--sys-apps/paludis/paludis-0.38.1.ebuild12
2 files changed, 12 insertions, 6 deletions
diff --git a/sys-apps/paludis/ChangeLog b/sys-apps/paludis/ChangeLog
index b199937f90c1..c05a8561912d 100644
--- a/sys-apps/paludis/ChangeLog
+++ b/sys-apps/paludis/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/paludis
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/paludis/ChangeLog,v 1.135 2009/07/25 09:22:43 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paludis/ChangeLog,v 1.136 2009/07/25 09:26:12 betelgeuse Exp $
+
+ 25 Jul 2009; Petteri Räty <betelgeuse@gentoo.org> paludis-0.38.1.ebuild:
+ Conditionalize libpcre built_with_use check under either qa or inquisitio
+ use flags.
25 Jul 2009; Petteri Räty <betelgeuse@gentoo.org> paludis-0.38.1.ebuild:
Add check for boost build with python use flag when python-bindings is
diff --git a/sys-apps/paludis/paludis-0.38.1.ebuild b/sys-apps/paludis/paludis-0.38.1.ebuild
index 53dec4501cc7..63417d6aa993 100644
--- a/sys-apps/paludis/paludis-0.38.1.ebuild
+++ b/sys-apps/paludis/paludis-0.38.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/paludis/paludis-0.38.1.ebuild,v 1.2 2009/07/25 09:22:43 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paludis/paludis-0.38.1.ebuild,v 1.3 2009/07/25 09:26:12 betelgeuse Exp $
inherit bash-completion eutils flag-o-matic
@@ -48,10 +48,12 @@ create-paludis-user() {
}
pkg_setup() {
- if ! built_with_use dev-libs/libpcre cxx ; then
- eerror "Paludis needs dev-libs/libpcre built with C++ support"
- eerror "Please build dev-libs/libpcre with USE=cxx support"
- die "Rebuild dev-libs/libpcre with USE=cxx"
+ if use inquisitio || use qa; then
+ if ! built_with_use dev-libs/libpcre cxx ; then
+ eerror "Paludis needs dev-libs/libpcre built with C++ support"
+ eerror "Please build dev-libs/libpcre with USE=cxx support"
+ die "Rebuild dev-libs/libpcre with USE=cxx"
+ fi
fi
if use python-bindings && \