summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-06-14 00:25:26 +0000
committerMike Frysinger <vapier@gentoo.org>2012-06-14 00:25:26 +0000
commit8f7d0b1fff179e87af2310790d54f749d637fb70 (patch)
treeb49de685495c75bf94611b187f6cc95860130f53 /sys-apps
parentFix manifest (diff)
downloadgentoo-2-8f7d0b1fff179e87af2310790d54f749d637fb70.tar.gz
gentoo-2-8f7d0b1fff179e87af2310790d54f749d637fb70.tar.bz2
gentoo-2-8f7d0b1fff179e87af2310790d54f749d637fb70.zip
Version bump #420927 by Hans de Graaff.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/xinetd/ChangeLog10
-rw-r--r--sys-apps/xinetd/xinetd-2.3.15.ebuild51
2 files changed, 58 insertions, 3 deletions
diff --git a/sys-apps/xinetd/ChangeLog b/sys-apps/xinetd/ChangeLog
index ded391ce38c7..517f111bfc46 100644
--- a/sys-apps/xinetd/ChangeLog
+++ b/sys-apps/xinetd/ChangeLog
@@ -1,6 +1,10 @@
-# ChangeLog for sys-apps/xinetd
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/ChangeLog,v 1.60 2012/04/26 15:30:38 aballier Exp $
+# ChangeLog for sys-apps/xinetd# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/ChangeLog,v 1.61 2012/06/14 00:25:26 vapier Exp $
+
+*xinetd-2.3.15 (14 Jun 2012)
+
+ 14 Jun 2012; Mike Frysinger <vapier@gentoo.org> +xinetd-2.3.15.ebuild:
+ Version bump #420927 by Hans de Graaff.
26 Apr 2012; Alexis Ballier <aballier@gentoo.org> xinetd-2.3.14-r1.ebuild:
keyword ~amd64-fbsd
diff --git a/sys-apps/xinetd/xinetd-2.3.15.ebuild b/sys-apps/xinetd/xinetd-2.3.15.ebuild
new file mode 100644
index 000000000000..b86fd64d24af
--- /dev/null
+++ b/sys-apps/xinetd/xinetd-2.3.15.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/xinetd-2.3.15.ebuild,v 1.1 2012/06/14 00:25:26 vapier Exp $
+
+EAPI="4"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="powerful replacement for inetd"
+HOMEPAGE="http://www.xinetd.org/"
+SRC_URI="http://www.xinetd.org/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="perl rpc tcpd"
+
+DEPEND="tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )
+ rpc? ( net-libs/libtirpc )"
+RDEPEND="${DEPEND}
+ perl? ( dev-lang/perl )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.3.14-DESTDIR.patch
+ epatch "${FILESDIR}"/${PN}-2.3.14-install-contrib.patch
+ epatch "${FILESDIR}"/${PN}-2.3.14-config.patch
+ find -name Makefile.in -exec sed -i 's:\<ar\>:$(AR):' {} +
+}
+
+src_configure() {
+ if ! use rpc ; then
+ append-cppflags -DNO_RPC
+ export ac_cv_header_{rpc_{rpc,rpcent,pmap_clnt},netdb}_h=no
+ fi
+ tc-export AR PKG_CONFIG
+ LIBS=$(${PKG_CONFIG} --libs libtirpc) \
+ econf \
+ $(use_with tcpd libwrap) \
+ --with-loadavg
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install install-contrib
+ use perl || rm -f "${ED}"/usr/sbin/xconv.pl
+
+ newinitd "${FILESDIR}"/xinetd.rc6 xinetd
+ newconfd "${FILESDIR}"/xinetd.confd xinetd
+
+ newdoc contrib/xinetd.conf xinetd.conf.dist.sample
+ dodoc AUDIT INSTALL README TODO CHANGELOG
+}