summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-02-05 19:03:24 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-02-05 19:03:24 +0000
commit93fa2f5c494512b01a99981ca81308c461de4222 (patch)
treea228bc3124d4b0ead17dd26333d30ac32f016fb8 /sys-apps
parentFix init.d script, only sleep on restart (diff)
downloadgentoo-2-93fa2f5c494512b01a99981ca81308c461de4222.tar.gz
gentoo-2-93fa2f5c494512b01a99981ca81308c461de4222.tar.bz2
gentoo-2-93fa2f5c494512b01a99981ca81308c461de4222.zip
Backport an upstream patch to fix runtime error on FreeBSD, bug #236779 and rekeyword it for x86-fbsd
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/dbus/ChangeLog7
-rw-r--r--sys-apps/dbus/dbus-1.2.3-r1.ebuild9
-rw-r--r--sys-apps/dbus/files/dbus-1.2.3-bsd.patch50
3 files changed, 62 insertions, 4 deletions
diff --git a/sys-apps/dbus/ChangeLog b/sys-apps/dbus/ChangeLog
index a50440cbba46..cb9ad15a76f2 100644
--- a/sys-apps/dbus/ChangeLog
+++ b/sys-apps/dbus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/dbus
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.230 2009/01/15 22:37:33 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.231 2009/02/05 19:03:24 aballier Exp $
+
+ 05 Feb 2009; Alexis Ballier <aballier@gentoo.org>
+ +files/dbus-1.2.3-bsd.patch, dbus-1.2.3-r1.ebuild:
+ Backport an upstream patch to fix runtime error on FreeBSD, bug #236779
+ and rekeyword it for x86-fbsd
15 Jan 2009; Peter Alfredsen <loki_val@gentoo.org> metadata.xml:
Compnerd retired.
diff --git a/sys-apps/dbus/dbus-1.2.3-r1.ebuild b/sys-apps/dbus/dbus-1.2.3-r1.ebuild
index a8849638c383..95a1c7163aba 100644
--- a/sys-apps/dbus/dbus-1.2.3-r1.ebuild
+++ b/sys-apps/dbus/dbus-1.2.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.2.3-r1.ebuild,v 1.9 2008/11/25 05:15:16 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.2.3-r1.ebuild,v 1.10 2009/02/05 19:03:24 aballier Exp $
inherit eutils multilib flag-o-matic
@@ -10,7 +10,7 @@ SRC_URI="http://dbus.freedesktop.org/releases/dbus/${P}.tar.gz"
LICENSE="|| ( GPL-2 AFL-2.1 )"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 -x86-fbsd"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
IUSE="debug doc selinux X"
RDEPEND="X? ( x11-libs/libXt x11-libs/libX11 )
@@ -28,6 +28,9 @@ src_unpack() {
cd "${S}"
# Fix potential DoS issue. fdo bug #17803. Gentoo bug #240308
epatch "${FILESDIR}"/${PN}-1.2.3-panic-from-dbus_signature_validate.patch
+ # Fix runtime error on FreeBSD. Gentoo bug #236779, fdo bug #17061
+ # From upstream, drop at next bump
+ epatch "${FILESDIR}"/${P}-bsd.patch
}
src_compile() {
diff --git a/sys-apps/dbus/files/dbus-1.2.3-bsd.patch b/sys-apps/dbus/files/dbus-1.2.3-bsd.patch
new file mode 100644
index 000000000000..d85b93daa225
--- /dev/null
+++ b/sys-apps/dbus/files/dbus-1.2.3-bsd.patch
@@ -0,0 +1,50 @@
+https://bugs.gentoo.org/show_bug.cgi?id=236779
+
+
+commit 3564e5cbe4d9c0538d6eb519904ef0befab39d75
+Author: Joe Marcus Clarke <marcus@freedesktop.org>
+Date: Thu Sep 4 22:13:30 2008 -0400
+
+ Bug 17061: Handle error return from sysconf correctly
+
+ * dbus/dbus-sysdeps-unix.c:
+ * dbus/dbus-sysdeps-util-unix.c: Cast return
+ from sysconf temporarily so we actually see
+ -1.
+
+ Signed-off-by: Colin Walters <walters@verbum.org>
+
+diff --git a/dbus/dbus-sysdeps-unix.c b/dbus/dbus-sysdeps-unix.c
+index 3f963bc..24a3774 100644
+--- a/dbus/dbus-sysdeps-unix.c
++++ b/dbus/dbus-sysdeps-unix.c
+@@ -1493,7 +1493,11 @@ fill_user_info (DBusUserInfo *info,
+ /* retrieve maximum needed size for buf */
+ buflen = sysconf (_SC_GETPW_R_SIZE_MAX);
+
+- if (buflen <= 0)
++ /* sysconf actually returns a long, but everything else expects size_t,
++ * so just recast here.
++ * https://bugs.freedesktop.org/show_bug.cgi?id=17061
++ */
++ if ((long) buflen <= 0)
+ buflen = 1024;
+
+ result = -1;
+diff --git a/dbus/dbus-sysdeps-util-unix.c b/dbus/dbus-sysdeps-util-unix.c
+index 55eb934..0343a90 100644
+--- a/dbus/dbus-sysdeps-util-unix.c
++++ b/dbus/dbus-sysdeps-util-unix.c
+@@ -836,7 +836,11 @@ fill_group_info (DBusGroupInfo *info,
+ /* retrieve maximum needed size for buf */
+ buflen = sysconf (_SC_GETGR_R_SIZE_MAX);
+
+- if (buflen <= 0)
++ /* sysconf actually returns a long, but everything else expects size_t,
++ * so just recast here.
++ * https://bugs.freedesktop.org/show_bug.cgi?id=17061
++ */
++ if ((long) buflen <= 0)
+ buflen = 1024;
+
+ result = -1;