summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2015-02-21 14:28:25 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2015-02-21 14:28:25 +0000
commit9b34b1c7d5513cbef0bd81dedb77153febc3ae03 (patch)
treef6bd670a1c7fd709432ef39f4545df9604377b49 /sys-apps
parentDrop roccat_ryos and add roccat_ryosmk. Bug #539906 by Dmitry Pisklov (diff)
downloadgentoo-2-9b34b1c7d5513cbef0bd81dedb77153febc3ae03.tar.gz
gentoo-2-9b34b1c7d5513cbef0bd81dedb77153febc3ae03.tar.bz2
gentoo-2-9b34b1c7d5513cbef0bd81dedb77153febc3ae03.zip
Version bump. Bug #539906 by Dmitry Pisklov. Update input devices to old ebuilds as well
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0x09BF4F54C2BA7F3C!)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/roccat-tools/ChangeLog10
-rw-r--r--sys-apps/roccat-tools/metadata.xml3
-rw-r--r--sys-apps/roccat-tools/roccat-tools-2.0.0.ebuild7
-rw-r--r--sys-apps/roccat-tools/roccat-tools-2.1.0.ebuild7
-rw-r--r--sys-apps/roccat-tools/roccat-tools-2.2.0.ebuild7
-rw-r--r--sys-apps/roccat-tools/roccat-tools-2.4.0.ebuild5
-rw-r--r--sys-apps/roccat-tools/roccat-tools-3.0.0.ebuild91
7 files changed, 118 insertions, 12 deletions
diff --git a/sys-apps/roccat-tools/ChangeLog b/sys-apps/roccat-tools/ChangeLog
index a6b509d48e38..bf37ad078003 100644
--- a/sys-apps/roccat-tools/ChangeLog
+++ b/sys-apps/roccat-tools/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/roccat-tools
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/ChangeLog,v 1.13 2015/01/27 01:14:23 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/ChangeLog,v 1.14 2015/02/21 14:28:25 hwoarang Exp $
+
+*roccat-tools-3.0.0 (21 Feb 2015)
+
+ 21 Feb 2015; Markos Chandras <hwoarang@gentoo.org> +roccat-tools-3.0.0.ebuild,
+ metadata.xml, roccat-tools-2.0.0.ebuild, roccat-tools-2.1.0.ebuild,
+ roccat-tools-2.2.0.ebuild, roccat-tools-2.4.0.ebuild:
+ Version bump. Bug #539906 by Dmitry Pisklov. Update input devices to old
+ ebuilds as well
*roccat-tools-2.4.0 (27 Jan 2015)
diff --git a/sys-apps/roccat-tools/metadata.xml b/sys-apps/roccat-tools/metadata.xml
index b0aa25f7e4e8..6c0474ad26fc 100644
--- a/sys-apps/roccat-tools/metadata.xml
+++ b/sys-apps/roccat-tools/metadata.xml
@@ -7,4 +7,7 @@
<name>Dmitry Pisklov</name>
<description>Proxy maintainer. Assign bugs to him</description>
</maintainer>
+<use>
+ <flag name="lua">Build support for Lua scripting for RyosMKPro ripple effects</flag>
+</use>
</pkgmetadata>
diff --git a/sys-apps/roccat-tools/roccat-tools-2.0.0.ebuild b/sys-apps/roccat-tools/roccat-tools-2.0.0.ebuild
index 21e8e91f33ce..81cd44c7610b 100644
--- a/sys-apps/roccat-tools/roccat-tools-2.0.0.ebuild
+++ b/sys-apps/roccat-tools/roccat-tools-2.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/roccat-tools-2.0.0.ebuild,v 1.2 2014/07/24 17:46:58 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/roccat-tools-2.0.0.ebuild,v 1.3 2015/02/21 14:28:25 hwoarang Exp $
EAPI=5
@@ -28,7 +28,7 @@ IUSE_INPUT_DEVICES="
input_devices_roccat_lua
input_devices_roccat_pyra
input_devices_roccat_savu
- input_devices_roccat_ryos
+ input_devices_roccat_ryosmk
"
IUSE="${IUSE_INPUT_DEVICES}"
@@ -51,6 +51,7 @@ pkg_setup() {
src_configure() {
local UDEVDIR="$(get_udevdir)"/rules.d
local MODELS=${INPUT_DEVICES//roccat_/}
+ MODELS=${MODELS/ryosmk/ryos}
mycmakeargs=( -DDEVICES=${MODELS// /;} \
-DUDEVDIR="${UDEVDIR/"//"//}" )
cmake-utils_src_configure
diff --git a/sys-apps/roccat-tools/roccat-tools-2.1.0.ebuild b/sys-apps/roccat-tools/roccat-tools-2.1.0.ebuild
index 32b6d3286783..7d2d515a8d48 100644
--- a/sys-apps/roccat-tools/roccat-tools-2.1.0.ebuild
+++ b/sys-apps/roccat-tools/roccat-tools-2.1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/roccat-tools-2.1.0.ebuild,v 1.1 2014/09/06 08:21:54 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/roccat-tools-2.1.0.ebuild,v 1.2 2015/02/21 14:28:25 hwoarang Exp $
EAPI=5
@@ -28,7 +28,7 @@ IUSE_INPUT_DEVICES="
input_devices_roccat_lua
input_devices_roccat_pyra
input_devices_roccat_savu
- input_devices_roccat_ryos
+ input_devices_roccat_ryosmk
"
IUSE="${IUSE_INPUT_DEVICES}"
@@ -51,6 +51,7 @@ pkg_setup() {
src_configure() {
local UDEVDIR="$(get_udevdir)"/rules.d
local MODELS=${INPUT_DEVICES//roccat_/}
+ MODELS=${MODELS/ryosmk/ryos}
mycmakeargs=( -DDEVICES=${MODELS// /;} \
-DUDEVDIR="${UDEVDIR/"//"//}" )
cmake-utils_src_configure
diff --git a/sys-apps/roccat-tools/roccat-tools-2.2.0.ebuild b/sys-apps/roccat-tools/roccat-tools-2.2.0.ebuild
index 2f185c1d9d85..6c64785f8458 100644
--- a/sys-apps/roccat-tools/roccat-tools-2.2.0.ebuild
+++ b/sys-apps/roccat-tools/roccat-tools-2.2.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/roccat-tools-2.2.0.ebuild,v 1.1 2014/10/04 12:34:01 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/roccat-tools-2.2.0.ebuild,v 1.2 2015/02/21 14:28:25 hwoarang Exp $
EAPI=5
@@ -28,7 +28,7 @@ IUSE_INPUT_DEVICES="
input_devices_roccat_lua
input_devices_roccat_pyra
input_devices_roccat_savu
- input_devices_roccat_ryos
+ input_devices_roccat_ryosmk
"
IUSE="${IUSE_INPUT_DEVICES}"
@@ -51,6 +51,7 @@ pkg_setup() {
src_configure() {
local UDEVDIR="$(get_udevdir)"/rules.d
local MODELS=${INPUT_DEVICES//roccat_/}
+ MODELS=${MODELS/ryosmk/ryos}
mycmakeargs=( -DDEVICES=${MODELS// /;} \
-DUDEVDIR="${UDEVDIR/"//"//}" )
cmake-utils_src_configure
diff --git a/sys-apps/roccat-tools/roccat-tools-2.4.0.ebuild b/sys-apps/roccat-tools/roccat-tools-2.4.0.ebuild
index 6dec4c98784c..5f1de056e169 100644
--- a/sys-apps/roccat-tools/roccat-tools-2.4.0.ebuild
+++ b/sys-apps/roccat-tools/roccat-tools-2.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/roccat-tools-2.4.0.ebuild,v 1.1 2015/01/27 01:14:23 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/roccat-tools-2.4.0.ebuild,v 1.2 2015/02/21 14:28:25 hwoarang Exp $
EAPI=5
@@ -28,7 +28,7 @@ IUSE_INPUT_DEVICES="
input_devices_roccat_lua
input_devices_roccat_pyra
input_devices_roccat_savu
- input_devices_roccat_ryos
+ input_devices_roccat_ryosmk
input_devices_roccat_tyon
"
IUSE="${IUSE_INPUT_DEVICES}"
@@ -52,6 +52,7 @@ pkg_setup() {
src_configure() {
local UDEVDIR="$(get_udevdir)"/rules.d
local MODELS=${INPUT_DEVICES//roccat_/}
+ MODELS=${MODELS/ryosmk/ryos}
mycmakeargs=( -DDEVICES=${MODELS// /;} \
-DUDEVDIR="${UDEVDIR/"//"//}" )
cmake-utils_src_configure
diff --git a/sys-apps/roccat-tools/roccat-tools-3.0.0.ebuild b/sys-apps/roccat-tools/roccat-tools-3.0.0.ebuild
new file mode 100644
index 000000000000..ed6185cdab9e
--- /dev/null
+++ b/sys-apps/roccat-tools/roccat-tools-3.0.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/roccat-tools-3.0.0.ebuild,v 1.1 2015/02/21 14:28:25 hwoarang Exp $
+
+EAPI=5
+
+inherit readme.gentoo cmake-utils gnome2-utils udev user
+
+DESCRIPTION="Utility for advanced configuration of Roccat devices"
+
+HOMEPAGE="http://roccat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/roccat/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE_INPUT_DEVICES="
+ input_devices_roccat_arvo
+ input_devices_roccat_isku
+ input_devices_roccat_iskufx
+ input_devices_roccat_kone
+ input_devices_roccat_koneplus
+ input_devices_roccat_konepure
+ input_devices_roccat_konepuremilitary
+ input_devices_roccat_konepureoptical
+ input_devices_roccat_konextd
+ input_devices_roccat_konextdoptical
+ input_devices_roccat_kovaplus
+ input_devices_roccat_lua
+ input_devices_roccat_pyra
+ input_devices_roccat_savu
+ input_devices_roccat_ryosmk
+ input_devices_roccat_tyon
+"
+IUSE="${IUSE_INPUT_DEVICES} lua"
+REQUIRED_USE="
+ lua? ( input_devices_roccat_ryosmk )
+"
+
+RDEPEND="
+ >=dev-libs/libgaminggear-0.6
+ x11-libs/gtk+:2
+ x11-libs/libnotify
+ media-libs/libcanberra
+ virtual/libusb:1
+ dev-libs/dbus-glib
+ virtual/libgudev:=
+"
+
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ enewgroup roccat
+}
+
+src_configure() {
+ local UDEVDIR="$(get_udevdir)"/rules.d
+ local MODELS=${INPUT_DEVICES//roccat_/}
+ mycmakeargs=(
+ -DDEVICES=${MODELS// /;} \
+ -DUDEVDIR="${UDEVDIR/"//"//}"
+ $(cmake-utils_use_with lua LUA)
+ )
+ cmake-utils_src_configure
+}
+src_install() {
+ cmake-utils_src_install
+ local stat_dir=/var/lib/roccat
+ keepdir $stat_dir
+ fowners root:roccat $stat_dir
+ fperms 2770 $stat_dir
+ readme.gentoo_src_install
+}
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+pkg_postinst() {
+ gnome2_icon_cache_update
+ readme.gentoo_print_elog
+ ewarn
+ ewarn "Starting from version 3.0.0, executables were renamed and now prefixed with 'roccat',"
+ ewarn "so konextdconfig is now roccatkonextdconfig and so on"
+ ewarn "Everything that was ryos is now ryosmk to distinguish it from the ryostkl product range"
+ ewarn
+ ewarn "In version ${P} the support for Python as a scripting language for RyosMKPro"
+ ewarn "ripple effects was dropped and replaced with Lua. Use USE=lua to enable it"
+ ewarn
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}