summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-23 03:32:07 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-23 03:32:07 +0000
commita51fc882336383c487460a42640745cd7eb9f0b4 (patch)
tree96fce50f8ce0aa66102f35119dc959d93af59294 /sys-apps
parentold (diff)
downloadgentoo-2-a51fc882336383c487460a42640745cd7eb9f0b4.tar.gz
gentoo-2-a51fc882336383c487460a42640745cd7eb9f0b4.tar.bz2
gentoo-2-a51fc882336383c487460a42640745cd7eb9f0b4.zip
tweak how we insert bindnow flags
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/man/files/man-1.6b-build.patch2
-rw-r--r--sys-apps/man/man-1.6c.ebuild6
2 files changed, 4 insertions, 4 deletions
diff --git a/sys-apps/man/files/man-1.6b-build.patch b/sys-apps/man/files/man-1.6b-build.patch
index d900b722d48a..cfced4b6add3 100644
--- a/sys-apps/man/files/man-1.6b-build.patch
+++ b/sys-apps/man/files/man-1.6b-build.patch
@@ -5,7 +5,7 @@
# LDFLAGS = -g
-LDFLAGS = -s
-+LDFLAGS ?= -s
++LDFLAGS += $(BINDNOW_FLAGS)
LIBOBJS = @LIBOBJS@
diff --git a/sys-apps/man/man-1.6c.ebuild b/sys-apps/man/man-1.6c.ebuild
index 98e175308168..5e5c30904ae5 100644
--- a/sys-apps/man/man-1.6c.ebuild
+++ b/sys-apps/man/man-1.6c.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.6c.ebuild,v 1.2 2006/02/22 00:14:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.6c.ebuild,v 1.3 2006/02/23 03:32:07 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -29,7 +29,6 @@ src_unpack() {
# We love to cross-compile
epatch "${FILESDIR}"/man-1.6-cross-compile.patch
- epatch "${FILESDIR}"/man-1.6b-build.patch
# Fix search order in man.conf so that system installed manpages
# will be found first ...
@@ -60,7 +59,7 @@ src_unpack() {
epatch "${FILESDIR}"/man-1.5p-mandirlist.patch
# use non-lazy binds for man
- append-ldflags $(bindnow-flags)
+ epatch "${FILESDIR}"/man-1.6b-build.patch
strip-linguas $(eval $(grep ^LANGUAGES= configure) ; echo ${LANGUAGES//,/ })
}
@@ -84,6 +83,7 @@ src_compile() {
+lang ${mylang} \
|| die "configure failed"
+ export BINDNOW_FLAGS=$(bindnow-flags)
emake || die "emake failed"
}