summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-04-25 21:54:35 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-04-25 21:54:35 +0000
commitac4c1ba51cdc956e385976327fa015dfc3a2ba93 (patch)
treeff7844331f42ba0db2ac7596e80f3bc80994e0db /sys-apps
parentUse Python 2 (bug #313991). (diff)
downloadgentoo-2-ac4c1ba51cdc956e385976327fa015dfc3a2ba93.tar.gz
gentoo-2-ac4c1ba51cdc956e385976327fa015dfc3a2ba93.tar.bz2
gentoo-2-ac4c1ba51cdc956e385976327fa015dfc3a2ba93.zip
Version bump, fixes test on x86
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/elfix/ChangeLog5
-rw-r--r--sys-apps/elfix/elfix-0.1.2.ebuild27
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-apps/elfix/ChangeLog b/sys-apps/elfix/ChangeLog
index 6bcb5e2484f6..1136907981a5 100644
--- a/sys-apps/elfix/ChangeLog
+++ b/sys-apps/elfix/ChangeLog
@@ -1,5 +1,10 @@
+*elfix-0.1.2 (25 Apr 2011)
+
+ 25 Apr 2011; Anthony G. Basile <blueness@gentoo.org> +elfix-0.1.2.ebuild:
+ Version bump, fixes test on x86
+
*elfix-0.1.1 (16 Apr 2011)
16 Apr 2011; Anthony G. Basile <blueness@gentoo.org> +elfix-0.1.1.ebuild,
diff --git a/sys-apps/elfix/elfix-0.1.2.ebuild b/sys-apps/elfix/elfix-0.1.2.ebuild
new file mode 100644
index 000000000000..220ec2aea3c6
--- /dev/null
+++ b/sys-apps/elfix/elfix-0.1.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/elfix/elfix-0.1.2.ebuild,v 1.1 2011/04/25 21:54:35 blueness Exp $
+
+EAPI=3
+
+DESCRIPTION="Tool to query or clear the ELF GNU_STACK executable flag"
+HOMEPAGE="http://dev.gentoo.org/~blueness/elfix/"
+SRC_URI="http://dev.gentoo.org/~blueness/elfix/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-libs/elfutils
+ test? ( dev-lang/yasm )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_enable test tests)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog INSTALL README THANKS TODO
+}