summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-22 23:40:25 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-22 23:40:25 +0000
commitb6f8c9c1c4d1f9054de2c2c8eca811dd5ca172e8 (patch)
treeecc6e045fdbfab17ce99ef017c9896874bdf9e5a /sys-apps
parentold (diff)
downloadgentoo-2-b6f8c9c1c4d1f9054de2c2c8eca811dd5ca172e8.tar.gz
gentoo-2-b6f8c9c1c4d1f9054de2c2c8eca811dd5ca172e8.tar.bz2
gentoo-2-b6f8c9c1c4d1f9054de2c2c8eca811dd5ca172e8.zip
Version bump.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/man/ChangeLog8
-rw-r--r--sys-apps/man/files/digest-man-1.6a1
-rw-r--r--sys-apps/man/files/man-1.6a-parallel-make.patch15
-rw-r--r--sys-apps/man/man-1.6a.ebuild106
4 files changed, 129 insertions, 1 deletions
diff --git a/sys-apps/man/ChangeLog b/sys-apps/man/ChangeLog
index d966b2450c5c..8c6305cc08c5 100644
--- a/sys-apps/man/ChangeLog
+++ b/sys-apps/man/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/man
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.73 2005/08/11 04:09:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.74 2005/08/22 23:40:25 vapier Exp $
+
+*man-1.6a (22 Aug 2005)
+
+ 22 Aug 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/man-1.6a-parallel-make.patch, +man-1.6a.ebuild:
+ Version bump.
11 Aug 2005; Mike Frysinger <vapier@gentoo.org>
+files/man-1.6-cross-compile.patch, man-1.6-r1.ebuild:
diff --git a/sys-apps/man/files/digest-man-1.6a b/sys-apps/man/files/digest-man-1.6a
new file mode 100644
index 000000000000..3913498e8b6b
--- /dev/null
+++ b/sys-apps/man/files/digest-man-1.6a
@@ -0,0 +1 @@
+MD5 d53114b9ec030be32b858b1618da3c25 man-1.6a.tar.gz 234660
diff --git a/sys-apps/man/files/man-1.6a-parallel-make.patch b/sys-apps/man/files/man-1.6a-parallel-make.patch
new file mode 100644
index 000000000000..27e05f59c336
--- /dev/null
+++ b/sys-apps/man/files/man-1.6a-parallel-make.patch
@@ -0,0 +1,15 @@
+Fix parallel building
+
+src/Makefile.in fixes by Octavio Ruiz http://bugs.gentoo.org/97439
+
+--- man-1.6/src/Makefile.in
++++ man-1.6/src/Makefile.in
+@@ -52,7 +52,7 @@
+ man-config.o man-getopt.o man.o manpath.o to_cat.o: defs.h
+ different.o man.o: different.h
+ man.o manfile.o: glob.h
+-different.o gripes.o man-config.o man-getopt.o man.o manpath.o util.o: gripes.h gripedefs.h
++different.o gripes.o man-config.o man-getopt.o man.o manfile.o manpath.o util.o: gripes.h gripedefs.h
+ different.o man-config.o man-getopt.o man.o manpath.o: man-config.h
+ gripes.o man-config.o man-getopt.o man.o manpath.o util.o: man.h
+ man-getopt.o man.o manpath.o: man-getopt.h
diff --git a/sys-apps/man/man-1.6a.ebuild b/sys-apps/man/man-1.6a.ebuild
new file mode 100644
index 000000000000..ad6655a88b3b
--- /dev/null
+++ b/sys-apps/man/man-1.6a.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.6a.ebuild,v 1.1 2005/08/22 23:40:25 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Standard commands to read man pages"
+HOMEPAGE="http://primates.ximian.com/~flucifredi/man/"
+SRC_URI="http://primates.ximian.com/~flucifredi/man/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls"
+
+DEPEND=""
+RDEPEND="sys-process/cronbase
+ >=sys-apps/groff-1.18
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Make sure we can build with -j :)
+ epatch "${FILESDIR}"/man-1.6a-parallel-make.patch
+
+ # We love to cross-compile
+ epatch "${FILESDIR}"/man-1.6-cross-compile.patch
+
+ # Fix search order in man.conf so that system installed manpages
+ # will be found first ...
+ epatch "${FILESDIR}"/man-1.5p-search-order.patch
+
+ # For groff-1.18 or later we need to call nroff with '-c'
+ epatch "${FILESDIR}"/man-1.5m-groff-1.18.patch
+
+ # makewhatis traverses manpages twice, as default manpath
+ # contains two directories that are symlinked together
+ epatch "${FILESDIR}"/man-1.5p-defmanpath-symlinks.patch
+
+ # use non-lazy binds for man. And let portage handling stripping.
+ append-ldflags -Wl,-z,now
+ sed -i \
+ -e "/^LDFLAGS = -s/s:=.*:=${LDFLAGS}:" \
+ src/Makefile.in \
+ || die "failed to edit default LDLFAGS"
+
+cp -a ${S}{,.orig}
+}
+
+src_compile() {
+ tc-export CC BUILD_CC
+
+ local myconf=
+ if use nls ; then
+ strip-linguas $(cd man; echo ??)
+ if [[ -z ${LINGUAS} ]] ; then
+ myconf="+lang all"
+ else
+ myconf="+lang ${LINGUAS// /,}"
+ fi
+ else
+ myconf="+lang none"
+ fi
+ ./configure \
+ -confdir=/etc \
+ +sgid +fhs \
+ ${myconf} || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make PREFIX="${D}" install || die "make install failed"
+ dosym man /usr/bin/manpath
+
+ dodoc LSM README* TODO
+
+ exeinto /etc/cron.weekly
+ newexe "${FILESDIR}"/makewhatis.cron makewhatis
+
+ keepdir /var/cache/man
+ diropts -m0775 -g man
+ local mansects=$(grep ^MANSECT "${D}"/etc/man.conf | cut -f2-)
+ for x in ${mansects//:/ } ; do
+ keepdir /var/cache/man/cat${x}
+ done
+}
+
+pkg_postinst() {
+ einfo "Forcing sane permissions onto ${ROOT}/var/cache/man (Bug #40322)"
+ chown -R root:man "${ROOT}"/var/cache/man
+ chmod -R g+w "${ROOT}"/var/cache/man
+ [[ -e ${ROOT}/var/cache/man/whatis ]] \
+ && chown root:root "${ROOT}"/var/cache/man/whatis
+
+ echo
+
+ local files=$(ls "${ROOT}"/etc/cron.{daily,weekly}/makewhatis{,.cron} 2>/dev/null)
+ if [[ ${files/$'\n'} != ${files} ]] ; then
+ ewarn "You have multiple makewhatis cron files installed."
+ ewarn "You might want to delete all but one of these:"
+ echo ${files}
+ fi
+}