summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-04-08 21:43:20 +0000
committerTim Harder <radhermit@gentoo.org>2012-04-08 21:43:20 +0000
commitbb408f7f07c0c6b9e2ea8eb06df3d4bde8605a19 (patch)
treeee6c241a3df1d6159d276ba8aa8a4a27d5062cf7 /sys-apps
parentVersion bump. (diff)
downloadgentoo-2-bb408f7f07c0c6b9e2ea8eb06df3d4bde8605a19.tar.gz
gentoo-2-bb408f7f07c0c6b9e2ea8eb06df3d4bde8605a19.tar.bz2
gentoo-2-bb408f7f07c0c6b9e2ea8eb06df3d4bde8605a19.zip
Version bump.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/help2man/ChangeLog7
-rw-r--r--sys-apps/help2man/help2man-1.40.8.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/sys-apps/help2man/ChangeLog b/sys-apps/help2man/ChangeLog
index 6caf275a31af..fc37b2271a5a 100644
--- a/sys-apps/help2man/ChangeLog
+++ b/sys-apps/help2man/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/help2man
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/help2man/ChangeLog,v 1.75 2012/04/01 11:20:37 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/help2man/ChangeLog,v 1.76 2012/04/08 21:43:20 radhermit Exp $
+
+*help2man-1.40.8 (08 Apr 2012)
+
+ 08 Apr 2012; Tim Harder <radhermit@gentoo.org> +help2man-1.40.8.ebuild:
+ Version bump.
01 Apr 2012; Raúl Porcel <armin76@gentoo.org> help2man-1.40.5.ebuild:
alpha/ia64/m68k/s390/sh/sparc stable wrt #405377
diff --git a/sys-apps/help2man/help2man-1.40.8.ebuild b/sys-apps/help2man/help2man-1.40.8.ebuild
new file mode 100644
index 000000000000..210d7f29a884
--- /dev/null
+++ b/sys-apps/help2man/help2man-1.40.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/help2man/help2man-1.40.8.ebuild,v 1.1 2012/04/08 21:43:20 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="GNU utility to convert program --help output to a man page"
+HOMEPAGE="http://www.gnu.org/software/help2man"
+SRC_URI="mirror://gnu/help2man/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls elibc_glibc"
+
+RDEPEND="dev-lang/perl
+ elibc_glibc? ( nls? (
+ dev-perl/Locale-gettext
+ ) )"
+DEPEND="${RDEPEND}
+ elibc_glibc? ( nls? (
+ dev-perl/Locale-gettext
+ ) )"
+
+DOCS=( debian/changelog NEWS README THANKS ) #385753
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.36.4-respect-LDFLAGS.patch \
+ "${FILESDIR}"/${PN}-1.38.4-linguas.patch
+}
+
+src_configure() {
+ local myconf
+ use elibc_glibc \
+ && myconf="${myconf} $(use_enable nls)" \
+ || myconf="${myconf} --disable-nls"
+ econf ${myconf}
+}