summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-08-29 22:12:18 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-08-29 22:12:18 +0000
commitbd72e920ec6b4d8a3fe713bc7f4540620fbe7ed4 (patch)
tree30e2dc28dbf09d752c7e7be8aa1643370eec9b86 /sys-apps
parentNew rev of iptables-1.2.6a with the IMQ support. See http://luxik.cdi.cz/~pat... (diff)
downloadgentoo-2-bd72e920ec6b4d8a3fe713bc7f4540620fbe7ed4.tar.gz
gentoo-2-bd72e920ec6b4d8a3fe713bc7f4540620fbe7ed4.tar.bz2
gentoo-2-bd72e920ec6b4d8a3fe713bc7f4540620fbe7ed4.zip
meep
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/iptables/iptables-1.2.6a-r2.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/sys-apps/iptables/iptables-1.2.6a-r2.ebuild b/sys-apps/iptables/iptables-1.2.6a-r2.ebuild
new file mode 100644
index 000000000000..f422ae70ca57
--- /dev/null
+++ b/sys-apps/iptables/iptables-1.2.6a-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iptables/iptables-1.2.6a-r2.ebuild,v 1.1 2002/08/29 22:12:18 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Kernel 2.4 firewall, NAT and packet mangling tools"
+SRC_URI="http://netfilter.samba.org/files/${P}.tar.bz2"
+HOMEPAGE="http://www.iptables.org"
+KEYWORDS="x86 ppc sparc sparc64"
+SLOT="0"
+# iptables is dependent on kernel sources. Strange but true.
+DEPEND="virtual/glibc"
+LICENSE="GPL-2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cat ${FILESDIR}/iptables-1.2.6a-imq.diff-3 | patch -p1 || die
+ chmod +x extensions/.IMQ-test*
+ mv Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/g" -e "s:/usr/local::g" Makefile.orig > Makefile
+}
+
+src_compile() {
+
+ # iptables and libraries are now installed to /sbin and /lib, so that
+ # systems with remote network-mounted /usr filesystems can get their
+ # network interfaces up and running correctly without /usr.
+
+ # use make, not emake
+ make \
+ LIBDIR=/lib \
+ BINDIR=/sbin \
+ MANDIR=/usr/share/man \
+ INCDIR=/usr/include \
+ KERNEL_DIR=/usr/src/linux \
+ || die
+
+}
+
+src_install() {
+
+ dodir /usr/{lib,share/man/man8,sbin}
+ make \
+ LIBDIR=${D}/lib \
+ BINDIR=${D}/sbin \
+ MANDIR=${D}/usr/share/man \
+ INCDIR=${D}/usr/include \
+ install || die
+
+ dodoc COPYING KNOWN_BUGS
+ dodir /var/lib/iptables
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/iptables.init iptables
+ insinto /etc/conf.d
+ newins ${FILESDIR}/iptables.confd iptables
+}
+
+pkg_postinst() {
+ einfo "This package now includes an initscript which loads and saves"
+ einfo "rules stored in /var/lib/iptables/rules-save"
+ einfo "This location can be changed in /etc/conf.d/iptables"
+}