summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2002-09-28 05:23:21 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2002-09-28 05:23:21 +0000
commitd1f4fe4c65ce1670dfcbb4749850216e5f6c2347 (patch)
tree42a4fe6305834866cef03e685332cf3b5c07260f /sys-apps
parentCommented out wmfpo-81.patch as it no longer seems to be available. See (diff)
downloadgentoo-2-d1f4fe4c65ce1670dfcbb4749850216e5f6c2347.tar.gz
gentoo-2-d1f4fe4c65ce1670dfcbb4749850216e5f6c2347.tar.bz2
gentoo-2-d1f4fe4c65ce1670dfcbb4749850216e5f6c2347.zip
updated version including all patches and bugfixes over the last 2 years
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/procps/ChangeLog10
-rw-r--r--sys-apps/procps/files/digest-procps-2.0.81
-rw-r--r--sys-apps/procps/procps-2.0.8.ebuild62
3 files changed, 72 insertions, 1 deletions
diff --git a/sys-apps/procps/ChangeLog b/sys-apps/procps/ChangeLog
index bee3237c0a3f..ddc554f8191d 100644
--- a/sys-apps/procps/ChangeLog
+++ b/sys-apps/procps/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/procps
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/ChangeLog,v 1.2 2002/09/27 10:26:50 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/ChangeLog,v 1.3 2002/09/28 05:23:21 bcowan Exp $
+
+*procps-2.0.8 (27 Sep 2002)
+
+ 27 Sep 2002; Brad Cowan <bcowan@gentoo.org> procps-2.0.8.ebuild
+ files/digest-procps-2.0.8 :
+
+ Version bump with many bugfixes. Removed patches as they have been
+ added to the main tree
*procps-2.0.7-r6 (26 Sep 2002)
diff --git a/sys-apps/procps/files/digest-procps-2.0.8 b/sys-apps/procps/files/digest-procps-2.0.8
new file mode 100644
index 000000000000..fd6f7b268d96
--- /dev/null
+++ b/sys-apps/procps/files/digest-procps-2.0.8
@@ -0,0 +1 @@
+MD5 3068ff299caa726eb52f5a2758bcbb92 procps-2.0.8.tar.bz2 158164
diff --git a/sys-apps/procps/procps-2.0.8.ebuild b/sys-apps/procps/procps-2.0.8.ebuild
new file mode 100644
index 000000000000..bc93e707cf81
--- /dev/null
+++ b/sys-apps/procps/procps-2.0.8.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/procps-2.0.8.ebuild,v 1.1 2002/09/28 05:23:21 bcowan Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard informational utilities and process-handling tools"
+SRC_URI="http://surriel.com/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://surriel.com/procps/"
+RDEPEND=">=sys-libs/ncurses-5.2-r2"
+DEPEND="${RDEPEND} >=sys-devel/gettext-0.10.35"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+SLOT="0"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ # Use the CFLAGS from /etc/make.conf.
+
+ mv Makefile Makefile.orig
+ sed -e "s/-O3/${CFLAGS}/" -e 's/all: config/all: /' \
+ -e "s:--strip::" Makefile.orig > Makefile
+
+ # WARNING! In case of a version bump, check the line below that removes a line from the Makefile file.
+ cd ${S}/ps
+ mv Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/" -e "s:--strip::" -e "33d" Makefile.orig > Makefile
+
+ cd ${S}/proc
+ mv Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/" -e "s:--strip::" Makefile.orig > Makefile
+
+ #remove /etc/X11/applnk/Desktop/top.app from makefile
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e "{16d;29d;201d;202d}" -e "s:\$(DESKTOP)::" Makefile.orig > Makefile
+
+}
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /sbin
+ dodir /usr/X11R6/bin
+ dodir /usr/share/man/man{1,5,8}
+ dodir /lib
+ dodir /bin
+
+ make DESTDIR=${D} MANDIR=/usr/share/man install || die
+
+ dodoc BUGS COPYING COPYING.LIB NEWS TODO
+ docinto proc
+ dodoc proc/COPYING
+ docinto ps
+ dodoc ps/COPYING ps/HACKING
+}
+