summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2009-02-05 10:18:24 +0000
committerTony Vroon <chainsaw@gentoo.org>2009-02-05 10:18:24 +0000
commitd3b178f93e618250665cbe9a59c4613d4dea7a02 (patch)
tree9c03b4b45e681a062bcb1c04afb9397737bb5233 /sys-apps
parentx86 stable wrt #255540 (diff)
downloadgentoo-2-d3b178f93e618250665cbe9a59c4613d4dea7a02.tar.gz
gentoo-2-d3b178f93e618250665cbe9a59c4613d4dea7a02.tar.bz2
gentoo-2-d3b178f93e618250665cbe9a59c4613d4dea7a02.zip
As per Christian Schmitt, PowerPC plans to stop masking the laptop USE-flag. This would break compilation with the current setup, so enable MacBook/MacBook Pro support unconditionally on both AMD64 & X86. It introduces no additional dependencies. No revision bump, those that care already had the laptop USE-flag on anyway.
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hal/ChangeLog9
-rw-r--r--sys-apps/hal/hal-0.5.11-r1.ebuild4
-rw-r--r--sys-apps/hal/hal-0.5.11-r4.ebuild4
-rw-r--r--sys-apps/hal/hal-0.5.11-r8.ebuild6
-rw-r--r--sys-apps/hal/hal-0.5.9.1-r3.ebuild4
5 files changed, 18 insertions, 9 deletions
diff --git a/sys-apps/hal/ChangeLog b/sys-apps/hal/ChangeLog
index 912a7a01993b..1801c951e124 100644
--- a/sys-apps/hal/ChangeLog
+++ b/sys-apps/hal/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/hal
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.270 2009/02/04 22:58:27 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.271 2009/02/05 10:18:24 chainsaw Exp $
+
+ 05 Feb 2009; <chainsaw@gentoo.org> hal-0.5.11-r8.ebuild:
+ As per Christian Schmitt, PowerPC plans to stop masking the laptop
+ USE-flag. This would break compilation with the current setup, so enable
+ MacBook/MacBook Pro support unconditionally on both AMD64 & X86. It
+ introduces no additional dependencies. No revision bump, those that care
+ already had the laptop USE-flag on anyway.
*hal-0.5.11-r8 (04 Feb 2009)
diff --git a/sys-apps/hal/hal-0.5.11-r1.ebuild b/sys-apps/hal/hal-0.5.11-r1.ebuild
index b5a0e57d7632..27cbfb85b415 100644
--- a/sys-apps/hal/hal-0.5.11-r1.ebuild
+++ b/sys-apps/hal/hal-0.5.11-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.11-r1.ebuild,v 1.15 2008/12/28 15:02:55 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.11-r1.ebuild,v 1.16 2009/02/05 10:18:24 chainsaw Exp $
inherit eutils linux-info autotools flag-o-matic
diff --git a/sys-apps/hal/hal-0.5.11-r4.ebuild b/sys-apps/hal/hal-0.5.11-r4.ebuild
index 97590997382a..3ed430e8cc44 100644
--- a/sys-apps/hal/hal-0.5.11-r4.ebuild
+++ b/sys-apps/hal/hal-0.5.11-r4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.11-r4.ebuild,v 1.5 2008/12/24 15:39:11 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.11-r4.ebuild,v 1.6 2009/02/05 10:18:24 chainsaw Exp $
inherit eutils linux-info autotools flag-o-matic
diff --git a/sys-apps/hal/hal-0.5.11-r8.ebuild b/sys-apps/hal/hal-0.5.11-r8.ebuild
index c04d7b0ed1eb..00491803d1c0 100644
--- a/sys-apps/hal/hal-0.5.11-r8.ebuild
+++ b/sys-apps/hal/hal-0.5.11-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.11-r8.ebuild,v 1.1 2009/02/04 22:58:27 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.11-r8.ebuild,v 1.2 2009/02/05 10:18:24 chainsaw Exp $
inherit eutils linux-info autotools flag-o-matic
@@ -166,7 +166,9 @@ src_compile() {
hardware="--with-cpufreq --with-usb-csr --with-keymaps"
use arm && hardware="$hardware --with-omap --enable-pmu"
use ppc && hardware="$hardware --enable-pmu"
- use laptop && hardware="--with-macbook --with-macbookpro"
+ if use x86 || use amd64; then
+ hardware="$hardware --with-macbook --with-macbookpro"
+ fi
if use dell ; then
hardware="$hardware --with-dell-backlight"
diff --git a/sys-apps/hal/hal-0.5.9.1-r3.ebuild b/sys-apps/hal/hal-0.5.9.1-r3.ebuild
index 540f0db8aa18..273810fd8329 100644
--- a/sys-apps/hal/hal-0.5.9.1-r3.ebuild
+++ b/sys-apps/hal/hal-0.5.9.1-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.9.1-r3.ebuild,v 1.12 2008/12/19 17:37:01 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.9.1-r3.ebuild,v 1.13 2009/02/05 10:18:24 chainsaw Exp $
inherit eutils linux-info autotools flag-o-matic