summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-01-04 17:15:58 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-01-04 17:15:58 +0000
commitd57c6aa49edba2fb98a3fdcbaf7f7e013900d5cb (patch)
treea44a00f484e08b74fd753c0b3af37f5ff0d06661 /sys-apps
parentFixed pciproxy debug patch (diff)
downloadgentoo-2-d57c6aa49edba2fb98a3fdcbaf7f7e013900d5cb.tar.gz
gentoo-2-d57c6aa49edba2fb98a3fdcbaf7f7e013900d5cb.tar.bz2
gentoo-2-d57c6aa49edba2fb98a3fdcbaf7f7e013900d5cb.zip
Some more ideas with QT. Even though it's now acknowledged by the QT guys that it's a bug on their side. Changed gcj to detect current running version rather then best installed. (thx eradicator)
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/dbus/ChangeLog8
-rw-r--r--sys-apps/dbus/dbus-0.23-r3.ebuild140
-rw-r--r--sys-apps/dbus/dbus-0.60-r3.ebuild8
-rw-r--r--sys-apps/dbus/files/digest-dbus-0.23-r31
4 files changed, 11 insertions, 146 deletions
diff --git a/sys-apps/dbus/ChangeLog b/sys-apps/dbus/ChangeLog
index 6fb0383c5ec5..876d71a20759 100644
--- a/sys-apps/dbus/ChangeLog
+++ b/sys-apps/dbus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/dbus
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.83 2006/01/03 22:00:25 killerfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.84 2006/01/04 17:15:58 cardoe Exp $
+
+ 04 Jan 2006; Doug Goldstein <cardoe@gentoo.org> -dbus-0.23-r3.ebuild,
+ dbus-0.60-r3.ebuild:
+ Some more ideas with QT. Even though it's now acknowledged by the QT guys
+ that it's a bug on their side. Changed gcj to detect current running version
+ rather then best installed. (thx eradicator)
03 Jan 2006; Rene Nussbaumer <killerfox@gentoo.org> dbus-0.23.4-r1.ebuild:
Stable on hppa.
diff --git a/sys-apps/dbus/dbus-0.23-r3.ebuild b/sys-apps/dbus/dbus-0.23-r3.ebuild
deleted file mode 100644
index f4826fb1eb36..000000000000
--- a/sys-apps/dbus/dbus-0.23-r3.ebuild
+++ /dev/null
@@ -1,140 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-0.23-r3.ebuild,v 1.11 2005/12/31 13:56:08 flameeyes Exp $
-
-# because of the experimental nature debug by default
-inherit debug eutils mono python multilib
-
-# FIXME : fix docs
-#IUSE="X gtk qt python mono doc xml2"
-IUSE="X gtk qt python xml2"
-
-DESCRIPTION="A message bus system, a simple way for applications to talk to eachother"
-HOMEPAGE="http://dbus.freedesktop.org/"
-SRC_URI="http://dbus.freedesktop.org/releases/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="|| ( GPL-2 AFL-2.1 )"
-KEYWORDS="x86 ppc amd64 ppc64 ia64 sparc hppa"
-
-RDEPEND=">=dev-libs/glib-2
- xml2? ( >=dev-libs/libxml2-2.6 )
- !xml2? ( dev-libs/expat )
- X? ( virtual/x11 )
- gtk? ( >=x11-libs/gtk+-2 )
- python? ( >=dev-lang/python-2.2
- >=dev-python/pyrex-0.9 )
- qt? ( =x11-libs/qt-3* )"
-# !ppc64? (
-# mono? ( >=dev-lang/mono-0.95 )
-# )
-
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-# doc? ( app-doc/doxygen
-# app-text/xmlto )"
-
-# needs gcj, we have no neat way of knowing if it was enabled
-# java? ( sys-devel/gcc )
-
-src_unpack() {
-
- unpack ${A}
- cd ${S}
-
- epatch ${FILESDIR}/${P}-qt.patch
- # fix security issue (#80601)
- epatch ${FILESDIR}/${P}-dbus_session_connect.patch
- # add missing include (#78617)
- epatch ${FILESDIR}/${P}-fd_set.patch
-
- # It stupidly tries to install python stuff to platform-independent
- # libdir
- epatch ${FILESDIR}/dbus-0.23-pyexecdir.patch
-
- # Don't rerun auto*
- sleep 1
- touch ${S}/python/Makefile.in
- sleep 1
- touch ${S}/configure
-}
-
-src_compile() {
-
- local myconf
-
- if use xml2; then
- myconf="--with-xml=libxml";
- else
- myconf="--with-xml=expat";
- fi
-
- econf \
- `use_with X x` \
- `use_enable gtk` \
- `use_enable qt` \
- `use_enable python` \
- --disable-mono \
- --enable-glib \
- --enable-verbose-mode \
- --enable-checks \
- --enable-asserts \
- --with-system-pid-file=/var/run/dbus.pid \
- --with-system-socket=/var/lib/dbus/system_bus_socket \
- --with-session-socket-dir=/tmp \
- --disable-doxygen-docs \
- --disable-xml-docs \
- --disable-mono-docs \
- ${myconf} \
- || die
-
-# `use_enable mono` \
-# `use_enable doc doxygen-docs` \
-# `use_enable doc xml-docs` \
-
- # do not build the mono examples, they need gtk-sharp
- touch ${S}/mono/example/{bus-listener,echo-{server,client}}.exe
-
- # this gets around a lib64 sandbox bug. note that this addpredict is
- # added automatically by sandbox.c for lib.
- addpredict /usr/lib64/python2.3/
- addpredict /usr/lib64/python2.2/
- addpredict /usr/lib64/python2.1/
-
- emake || die
-
-}
-
-src_install() {
-
- make DESTDIR=${D} install || die
-
- # initscript
- exeinto /etc/init.d/
- doexe ${FILESDIR}/dbus
-
- # needs to exist for the system socket
- keepdir /var/lib/dbus
-
- keepdir /usr/lib/dbus-1.0/services
- keepdir /usr/share/dbus-1/services
-
- dodoc AUTHORS ChangeLog HACKING NEWS README doc/TODO doc/*html
-
-}
-
-pkg_preinst() {
-
- enewgroup messagebus || die "Problem adding messagebus group"
- enewuser messagebus -1 -1 /dev/null messagebus || die "Problem adding messagebus user"
-
-}
-
-pkg_postinst() {
-
- einfo "To start the DBUS system-wide messagebus by default"
- einfo "you should add it to the default runlevel :"
- einfo "\`rc-update add dbus default\`"
-
-}
diff --git a/sys-apps/dbus/dbus-0.60-r3.ebuild b/sys-apps/dbus/dbus-0.60-r3.ebuild
index a648637ef3eb..f0767c015af3 100644
--- a/sys-apps/dbus/dbus-0.60-r3.ebuild
+++ b/sys-apps/dbus/dbus-0.60-r3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-0.60-r3.ebuild,v 1.2 2006/01/03 23:32:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-0.60-r3.ebuild,v 1.3 2006/01/04 17:15:58 cardoe Exp $
-inherit eutils mono python multilib debug qt3 autotools
+inherit eutils mono python multilib debug qt3 autotools toolchain-funcs
DESCRIPTION="A message bus system, a simple way for applications to talk to each other"
HOMEPAGE="http://dbus.freedesktop.org/"
@@ -30,7 +30,7 @@ DEPEND="${RDEPEND}
>=dev-util/mono-tools-1.1.9 ) )"
pkg_setup() {
- if use gcj && ! built_with_use sys-devel/gcc gcj; then
+ if use gcj && ! built_with_use "=sys-devel/gcc-$(gcc-fullversion)*" gcj; then
eerror "To build the Java bindings for dbus, you must re-build gcc"
eerror "with the 'gcj' USE flag. Add 'gcj' to USE and re-emerge gcc."
die "gcc needs gcj support to use the java bindings"
@@ -69,7 +69,7 @@ src_compile() {
use mono && myconf="${myconf} $(use_enable doc mono-docs)"
if use qt; then
- myconf="${myconf} --enable-qt3=${QTDIR} QT_MOC=${QTDIR}/bin/moc"
+ myconf="${myconf} --enable-qt3=${QTDIR} QT_MOC=${QTDIR}/bin/moc QT3_MOC=${QTDIR}/bin/moc"
else
myconf="${myconf} --disable-qt --disable-qt3"
fi
diff --git a/sys-apps/dbus/files/digest-dbus-0.23-r3 b/sys-apps/dbus/files/digest-dbus-0.23-r3
deleted file mode 100644
index 729896ce139d..000000000000
--- a/sys-apps/dbus/files/digest-dbus-0.23-r3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 56a6a06144bd349f21afbd4cc386a60f dbus-0.23.tar.gz 1280646