summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-11-30 02:21:31 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-11-30 02:21:31 +0000
commite8216a7d023c8324aa3fd8425dbea85354102c74 (patch)
treeb301d192266bb76e085492f65ad50fb6d7991b9b /sys-apps
parentRemove broken version (diff)
downloadgentoo-2-e8216a7d023c8324aa3fd8425dbea85354102c74.tar.gz
gentoo-2-e8216a7d023c8324aa3fd8425dbea85354102c74.tar.bz2
gentoo-2-e8216a7d023c8324aa3fd8425dbea85354102c74.zip
Version bump.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key D4301342)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hwids/ChangeLog7
-rw-r--r--sys-apps/hwids/hwids-20121130.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/sys-apps/hwids/ChangeLog b/sys-apps/hwids/ChangeLog
index 2ccedee12de8..c3054a7b387d 100644
--- a/sys-apps/hwids/ChangeLog
+++ b/sys-apps/hwids/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hwids
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.40 2012/11/23 06:14:01 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.41 2012/11/30 02:21:31 flameeyes Exp $
+
+*hwids-20121130 (30 Nov 2012)
+
+ 30 Nov 2012; Diego E. Pettenò <flameeyes@gentoo.org> +hwids-20121130.ebuild:
+ Version bump.
23 Nov 2012; Diego E. Pettenò <flameeyes@gentoo.org> hwids-20121123.ebuild:
Use the new SRC_URI that actually simplifies this quite a bit.
diff --git a/sys-apps/hwids/hwids-20121130.ebuild b/sys-apps/hwids/hwids-20121130.ebuild
new file mode 100644
index 000000000000..68a371cdaabe
--- /dev/null
+++ b/sys-apps/hwids/hwids-20121130.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20121130.ebuild,v 1.1 2012/11/30 02:21:31 flameeyes Exp $
+
+EAPI="4"
+
+DESCRIPTION="Hardware (PCI, USB) IDs databases"
+HOMEPAGE="https://github.com/gentoo/hwids"
+SRC_URI="https://github.com/gentoo/hwids/archive/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 BSD )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!<sys-apps/pciutils-3.1.9-r2
+ !<sys-apps/usbutils-005-r1"
+
+S="${WORKDIR}/hwids-${P}"
+
+src_compile() {
+ for file in {usb,pci}.ids; do
+ gzip -c ${file} > ${file}.gz || die
+ done
+}
+
+src_install() {
+ insinto /usr/share/misc
+ doins {usb,pci}.ids{,.gz}
+
+ dodoc README.md
+}