summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-11-16 17:13:01 +0000
committerMike Frysinger <vapier@gentoo.org>2011-11-16 17:13:01 +0000
commitf13ff5f36714e6a9be1e25fd214073598e9df829 (patch)
tree3cbeb87217a5fd542949d9fc780b6b5da071e45d /sys-apps
parentadd ~amd64-linux ~x86-linux, bug 384745 (diff)
downloadgentoo-2-f13ff5f36714e6a9be1e25fd214073598e9df829.tar.gz
gentoo-2-f13ff5f36714e6a9be1e25fd214073598e9df829.tar.bz2
gentoo-2-f13ff5f36714e6a9be1e25fd214073598e9df829.zip
Version bump.
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/grep/ChangeLog7
-rw-r--r--sys-apps/grep/grep-2.10.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/sys-apps/grep/ChangeLog b/sys-apps/grep/ChangeLog
index 07b08cf5c1e1..d69001fe705f 100644
--- a/sys-apps/grep/ChangeLog
+++ b/sys-apps/grep/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/grep
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.101 2011/08/13 11:18:27 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.102 2011/11/16 17:13:01 vapier Exp $
+
+*grep-2.10 (16 Nov 2011)
+
+ 16 Nov 2011; Mike Frysinger <vapier@gentoo.org> +grep-2.10.ebuild:
+ Version bump.
13 Aug 2011; Fabian Groffen <grobian@gentoo.org> grep-2.9.ebuild:
Add Prefix support, transferred Prefix keywords
diff --git a/sys-apps/grep/grep-2.10.ebuild b/sys-apps/grep/grep-2.10.ebuild
new file mode 100644
index 000000000000..a1a55f2b08d1
--- /dev/null
+++ b/sys-apps/grep/grep-2.10.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.10.ebuild,v 1.1 2011/11/16 17:13:01 vapier Exp $
+
+EAPI="3"
+
+DESCRIPTION="GNU regular expression matcher"
+HOMEPAGE="http://www.gnu.org/software/grep/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
+ mirror://gentoo/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-aix ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls pcre"
+
+RDEPEND="nls? ( virtual/libintl )
+ pcre? ( >=dev-libs/libpcre-7.8-r1 )
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ econf \
+ --bindir="${EPREFIX}"/bin \
+ $(use_enable nls) \
+ $(use_enable pcre perl-regexp) \
+ $(use !elibc_glibc || echo --without-included-regex)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}