summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-08-15 14:27:31 +0000
committerAchim Gottinger <achim@gentoo.org>2001-08-15 14:27:31 +0000
commitf2082757b652c2cdda8b6ee7d37854ff0d44914e (patch)
tree5bc0d7d3a579c4d02da2c1c05c411a21ecc540d4 /sys-apps
parentmade a -r2 with the changes from CVS applied, this solves some focusing issue... (diff)
downloadgentoo-2-f2082757b652c2cdda8b6ee7d37854ff0d44914e.tar.gz
gentoo-2-f2082757b652c2cdda8b6ee7d37854ff0d44914e.tar.bz2
gentoo-2-f2082757b652c2cdda8b6ee7d37854ff0d44914e.zip
I made a new rev which uses USE ipv6 to enable ipv6 support
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/xinetd/files/digest-xinetd-2.3.0-r11
-rw-r--r--sys-apps/xinetd/xinetd-2.3.0-r1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sys-apps/xinetd/files/digest-xinetd-2.3.0-r1 b/sys-apps/xinetd/files/digest-xinetd-2.3.0-r1
new file mode 100644
index 000000000000..0204640db050
--- /dev/null
+++ b/sys-apps/xinetd/files/digest-xinetd-2.3.0-r1
@@ -0,0 +1 @@
+MD5 f9e4363a0838ae3e5065b1c0c2b307a8 xinetd-2.3.0.tar.gz
diff --git a/sys-apps/xinetd/xinetd-2.3.0-r1.ebuild b/sys-apps/xinetd/xinetd-2.3.0-r1.ebuild
new file mode 100644
index 000000000000..a44c8d6965aa
--- /dev/null
+++ b/sys-apps/xinetd/xinetd-2.3.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/xinetd-2.3.0-r1.ebuild,v 1.1 2001/08/15 14:27:31 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Replacement for inetd."
+HOMEPAGE="http://www.xinetd.org"
+SRC_URI="http://www.xinetd.org/${A}"
+DEPEND="virtual/glibc
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
+
+RDEPEND="virtual/glibc
+ sys-devel/perl"
+
+src_compile() {
+
+ local myconf
+ if [ "`use tcpd`" ] ; then
+ myconf="--with-libwrap"
+ fi
+ if [ "`use ipv6`" ] ; then
+ myconf="$myconf --with-inet6"
+ fi
+
+ try ./configure --with-loadavg --prefix=/usr --mandir=/usr/share/man --host=${CHOST} $myconf
+ # Parallel make does not work
+ try make
+
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/usr MANDIR=${D}/usr/share/man install
+ dodoc CHANGELOG README COPYRIGHT
+ exeinto /etc/rc.d/init.d
+ doexe ${FILESDIR}/xinetd ${FILESDIR}/svc-xinetd
+ insinto /etc
+ #doins ${FILESDIR}/xinetd.conf
+ exeinto /var/lib/supervise/services/xinetd
+ newexe ${FILESDIR}/xinetd-run-${PV} run
+ exeinto /usr/sbin
+ doexe ${FILESDIR}/xconv.pl
+}
+
+
+
+