summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-12-26 17:13:24 +0000
committerMike Frysinger <vapier@gentoo.org>2009-12-26 17:13:24 +0000
commitfa7186714c8878c5d32086bb3683b0715dda5778 (patch)
tree4fe277c6b9a50f7d7edb2f70311bfd38ab446e57 /sys-apps
parentBump revision and fix case sensitivity for require statement. (diff)
downloadgentoo-2-fa7186714c8878c5d32086bb3683b0715dda5778.tar.gz
gentoo-2-fa7186714c8878c5d32086bb3683b0715dda5778.tar.bz2
gentoo-2-fa7186714c8878c5d32086bb3683b0715dda5778.zip
old
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/busybox/busybox-1.13.2.ebuild250
-rw-r--r--sys-apps/busybox/files/busybox-1.12.0-mdev-exec.patch11
-rw-r--r--sys-apps/busybox/files/busybox-1.13.2-depmod.patch121
-rw-r--r--sys-apps/busybox/files/busybox-1.13.2-init.patch50
-rw-r--r--sys-apps/busybox/files/busybox-1.13.2-killall.patch17
-rw-r--r--sys-apps/busybox/files/busybox-1.13.2-mdev.patch39
-rw-r--r--sys-apps/busybox/files/busybox-1.13.2-modprobe.patch99
-rw-r--r--sys-apps/busybox/files/busybox-1.13.2-tar.patch11
8 files changed, 0 insertions, 598 deletions
diff --git a/sys-apps/busybox/busybox-1.13.2.ebuild b/sys-apps/busybox/busybox-1.13.2.ebuild
deleted file mode 100644
index 3c55f21e84d6..000000000000
--- a/sys-apps/busybox/busybox-1.13.2.ebuild
+++ /dev/null
@@ -1,250 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.13.2.ebuild,v 1.10 2009/04/15 02:44:42 solar Exp $
-
-inherit eutils flag-o-matic savedconfig toolchain-funcs
-
-################################################################################
-# BUSYBOX ALTERNATE CONFIG MINI-HOWTO
-#
-# Busybox can be modified in many different ways. Here's a few ways to do it:
-#
-# (1) Emerge busybox with FEATURES=keepwork so the work directory won't
-# get erased afterwards. Add a definition like ROOT=/my/root/path to the
-# start of the line if you're installing to somewhere else than the root
-# directory. This command will save the default configuration to
-# ${PORTAGE_CONFIGROOT} (or ${ROOT} if ${PORTAGE_CONFIGROOT} is not
-# defined), and it will tell you that it has done this. Note the location
-# where the config file was saved.
-#
-# FEATURES=keepwork USE=savedconfig emerge busybox
-#
-# (2) Go to the work directory and change the configuration of busybox using its
-# menuconfig feature.
-#
-# cd /var/tmp/portage/busybox*/work/busybox-*
-# make menuconfig
-#
-# (3) Save your configuration to the default location and copy it to the
-# one of the locations listed in /usr/portage/eclass/savedconfig.eclass
-#
-# (4) Emerge busybox with USE=savedconfig to use the configuration file you
-# just generated.
-#
-################################################################################
-#
-# (1) Alternatively skip the above steps and simply emerge busybox without
-# USE=savedconfig.
-#
-# (2) Edit the file it saves by hand. ${ROOT}"/etc/portage/savedconfig/${CATEGORY}/${PF}
-#
-# (3) Remerge busybox as using USE=savedconfig.
-#
-################################################################################
-
-#SNAPSHOT=20040726
-SNAPSHOT=""
-
-DESCRIPTION="Utilities for rescue and embedded systems"
-HOMEPAGE="http://www.busybox.net/"
-if [[ -n ${SNAPSHOT} ]] ; then
- MY_P=${PN}
- SRC_URI="http://www.busybox.net/downloads/snapshots/${PN}-${SNAPSHOT}.tar.bz2"
-else
- MY_P=${PN}-${PV/_/-}
- SRC_URI="http://www.busybox.net/downloads/${MY_P}.tar.bz2"
-fi
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="debug make-symlinks pam selinux static"
-RESTRICT="test"
-
-DEPEND="selinux? ( sys-libs/libselinux )
- pam? ( sys-libs/pam )"
-
-S=${WORKDIR}/${MY_P}
-
-busybox_config_option() {
- case $1 in
- y) sed -i -e "s:.*CONFIG_$2.*set:CONFIG_$2=y:g" .config;;
- n) sed -i -e "s:CONFIG_$2=y:# CONFIG_$2 is not set:g" .config;;
- *) use $1 \
- && busybox_config_option y $2 \
- || busybox_config_option n $2
- return 0
- ;;
- esac
- einfo $(grep "CONFIG_$2[= ]" .config || echo Could not find CONFIG_$2 ...)
-}
-
-src_unpack() {
- unset KBUILD_OUTPUT #88088
-
- unpack ${MY_P}.tar.bz2
- cd "${S}"
-
- # patches go here!
- epatch "${FILESDIR}"/busybox-1.11.1-bb.patch
- epatch "${FILESDIR}"/busybox-${PV}-*.patch
-
- epatch "${FILESDIR}"/busybox-1.12.0-mdev-exec.patch
-
- # work around broken ass powerpc compilers
- use ppc64 && append-flags -mminimal-toc
- # flag cleanup
- sed -i -r \
- -e 's:[[:space:]]?-(Werror|Os|falign-(functions|jumps|loops|labels)=1|fomit-frame-pointer)\>::g' \
- Makefile.flags || die
- sed -i '/^#error Aborting compilation./d' applets/applets.c || die
- use elibc_glibc && sed -i 's:-Wl,--gc-sections::' Makefile
- sed -i \
- -e "/^CROSS_COMPILE/s:=.*:= ${CHOST}-:" \
- -e "/^HOSTCC/s:=.*:= $(tc-getBUILD_CC):" \
- Makefile || die
-
- # check for a busybox config before making one of our own.
- # if one exist lets return and use it.
-
- restore_config .config
- if [ -f .config ]; then
- yes "" | emake -j1 oldconfig > /dev/null
- return 0
- else
- ewarn "Could not locate user configfile, so we will save a default one"
- fi
-
- # setup the config file
- emake -j1 allyesconfig > /dev/null
- busybox_config_option n DMALLOC
- busybox_config_option n FEATURE_SUID_CONFIG
- busybox_config_option n BUILD_AT_ONCE
- busybox_config_option n BUILD_LIBBUSYBOX
- busybox_config_option n NOMMU
- busybox_config_option n MONOTONIC_SYSCALL
-
- # If these are not set and we are using a uclibc/busybox setup
- # all calls to system() will fail.
- busybox_config_option y FEATURE_SH_IS_ASH
- busybox_config_option n FEATURE_SH_IS_NONE
-
- if use static && use pam ; then
- ewarn "You cannot have USE='static pam'. Assuming static is more important."
- fi
- use static \
- && busybox_config_option n PAM \
- || busybox_config_option pam PAM
- busybox_config_option static STATIC
- busybox_config_option debug DEBUG
- use debug \
- && busybox_config_option y NO_DEBUG_LIB \
- && busybox_config_option n DMALLOC \
- && busybox_config_option n EFENCE
-
- busybox_config_option selinux SELINUX
-
- # default a bunch of uncommon options to off
- local opt
- for opt in \
- CRONTAB \
- DC DPKG \
- FAKEIDENTD FBSPLASH FOLD FTP{GET,PUT} \
- HUSH \
- INETD INOTIFYD IPCALC \
- LASH LOCALE_SUPPORT LOGNAME \
- MSH \
- OD \
- SULOGIN \
- TASKSET \
- RPM RPM2CPIO \
- UDPSVD UUDECODE UUENCODE
- do
- busybox_config_option n ${opt}
- done
-
- emake -j1 oldconfig > /dev/null
-}
-
-src_compile() {
- unset KBUILD_OUTPUT #88088
- export SKIP_STRIP=y
-
- emake busybox || die "build failed"
- if ! use static && ! use pam ; then
- mv busybox_unstripped{,.bak}
- emake CONFIG_STATIC=y busybox || die "static build failed"
- mv busybox_unstripped bb
- mv busybox_unstripped{.bak,}
- fi
-}
-
-src_install() {
- unset KBUILD_OUTPUT #88088
- save_config .config
-
- into /
- newbin busybox_unstripped busybox || die
- if use static || use pam ; then
- dosym busybox /bin/bb || die
- dosym bb /bin/busybox.static || die
- else
- dobin bb || die
- fi
-
- insinto /$(get_libdir)/rcscripts/addons
- doins "${FILESDIR}"/mdev-start.sh || die
-
- # bundle up the symlink files for use later
- emake install || die
- rm _install/bin/busybox
- tar cf busybox-links.tar -C _install . || : #;die
- insinto /usr/share/${PN}
- doins busybox-links.tar || die
- newins .config ${PF}.config || die
-
- dodoc AUTHORS README TODO
-
- cd docs || die
- docinto txt
- dodoc *.txt
- docinto pod
- dodoc *.pod
- dohtml *.html *.sgml
-
- cd ../examples || die
- docinto examples
- dodoc inittab depmod.pl *.conf *.script undeb unrpm
-
- cd bootfloppy || die
- docinto bootfloppy
- dodoc $(find . -type f)
-}
-
-pkg_preinst() {
- if use make-symlinks && [[ ! ${VERY_BRAVE_OR_VERY_DUMB} == "yes" ]] && [[ ${ROOT} == "/" ]] ; then
- ewarn "setting USE=make-symlinks and emerging to / is very dangerous."
- ewarn "it WILL overwrite lots of system programs like: ls bash awk grep (bug 60805 for full list)."
- ewarn "If you are creating a binary only and not merging this is probably ok."
- ewarn "set env VERY_BRAVE_OR_VERY_DUMB=yes if this is realy what you want."
- die "silly options will destroy your system"
- fi
-
- if use make-symlinks ; then
- mv "${D}"/usr/share/${PN}/busybox-links.tar "${T}"/ || die
- fi
-}
-
-pkg_postinst() {
- if use make-symlinks ; then
- cd "${T}" || die
- mkdir _install
- tar xf busybox-links.tar -C _install || die
- cp -vpPR _install/* "${ROOT}"/ || die "copying links for ${x} failed"
- fi
-
- echo
- einfo "This ebuild has support for user defined configs"
- einfo "Please read this ebuild for more details and re-emerge as needed"
- einfo "if you want to add or remove functionality for ${PN}"
- echo
-}
diff --git a/sys-apps/busybox/files/busybox-1.12.0-mdev-exec.patch b/sys-apps/busybox/files/busybox-1.12.0-mdev-exec.patch
deleted file mode 100644
index 78f022c0dc2c..000000000000
--- a/sys-apps/busybox/files/busybox-1.12.0-mdev-exec.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- util-linux/mdev.c.orig 2008-08-21 14:18:38.000000000 +0200
-+++ util-linux/mdev.c 2008-08-21 14:24:18.000000000 +0200
-@@ -220,7 +220,7 @@
- break;
- {
- const char *s = "@$*";
-- const char *s2 = strchr(s, *val);
-+ char *s2 = strchr(s, *val);
-
- if (!s2)
- bb_error_msg_and_die("bad line %u", parser->lineno);
diff --git a/sys-apps/busybox/files/busybox-1.13.2-depmod.patch b/sys-apps/busybox/files/busybox-1.13.2-depmod.patch
deleted file mode 100644
index 32d616384371..000000000000
--- a/sys-apps/busybox/files/busybox-1.13.2-depmod.patch
+++ /dev/null
@@ -1,121 +0,0 @@
---- busybox-1.13.2/modutils/depmod.c Sun Nov 9 18:28:03 2008
-+++ busybox-1.13.2-depmod/modutils/depmod.c Mon Jan 12 23:12:59 2009
-@@ -33,7 +33,7 @@
- enum {
- ARG_a = (1<<0), /* All modules, ignore mods in argv */
- ARG_A = (1<<1), /* Only emit .ko that are newer than modules.dep file */
-- ARG_b = (1<<2), /* not /lib/modules/$(uname -r)/ but this base-dir */
-+ ARG_b = (1<<2), /* base directory when modules are in staging area */
- ARG_e = (1<<3), /* with -F, print unresolved symbols */
- ARG_F = (1<<4), /* System.map that contains the symbols */
- ARG_n = (1<<5) /* dry-run, print to stdout only */
-@@ -57,7 +57,7 @@
- *first = info;
-
- info->dnext = info->dprev = info;
-- info->name = xstrdup(fname);
-+ info->name = xasprintf("/%s", fname);
- info->modname = filename2modname(fname, NULL);
- for (ptr = image; ptr < image + len - 10; ptr++) {
- if (strncmp(ptr, "depends=", 8) == 0) {
-@@ -123,44 +123,61 @@
- }
- }
-
-+static void xfreopen_write(const char *file, FILE *f)
-+{
-+ if (freopen(file, "w", f) == NULL)
-+ bb_perror_msg_and_die("can't open '%s'", file);
-+}
-+
- int depmod_main(int argc, char **argv) MAIN_EXTERNALLY_VISIBLE;
- int depmod_main(int argc UNUSED_PARAM, char **argv)
- {
- module_info *modules = NULL, *m, *dep;
-- char *moddir_base = (char *)CONFIG_DEFAULT_MODULES_DIR;
-+ const char *moddir_base = "/";
-+ char *moddir, *version;
-+ struct utsname uts;
- int tmp;
-
- getopt32(argv, "aAb:eF:n", &moddir_base, NULL);
- argv += optind;
-
- /* goto modules location */
-+ xchdir(moddir_base);
-
- /* If a version is provided, then that kernel version's module directory
- * is used, rather than the current kernel version (as returned by
- * "uname -r"). */
-- xchdir(moddir_base);
-- if (*argv && (sscanf(*argv, "%d.%d.%d", &tmp, &tmp, &tmp) == 3)) {
-- xchdir(*argv++);
-+ if (*argv && sscanf(*argv, "%d.%d.%d", &tmp, &tmp, &tmp) == 3) {
-+ version = *argv++;
- } else {
-- struct utsname uts;
- uname(&uts);
-- xchdir(uts.release);
-+ version = uts.release;
- }
-- /* If no modules are given on the command-line, -a is on per default. */
-- option_mask32 |= *argv == NULL;
-+ moddir = concat_path_file(&CONFIG_DEFAULT_MODULES_DIR[1], version);
-
- /* Scan modules */
-- moddir_base = xrealloc_getcwd_or_warn(NULL);
-- do {
-- recursive_action((option_mask32 & ARG_a) ? moddir_base : *argv,
-- ACTION_RECURSE, parse_module, NULL, &modules, 0);
-- } while (!(option_mask32 & ARG_a) && *(++argv));
-+ if (*argv) {
-+ char *modfile;
-+ struct stat sb;
-+ do {
-+ modfile = concat_path_file(moddir, *argv);
-+ xstat(modfile, &sb);
-+ parse_module(modfile, &sb, &modules, 0);
-+ free(modfile);
-+ } while (*(++argv));
-+ } else {
-+ recursive_action(moddir, ACTION_RECURSE,
-+ parse_module, NULL, &modules, 0);
-+ }
-+
-+ /* Prepare for writing out the dep files */
-+ xchdir(moddir);
- if (ENABLE_FEATURE_CLEAN_UP)
-- free(moddir_base);
-+ free(moddir);
-
- /* Generate dependency and alias files */
- if (!(option_mask32 & ARG_n))
-- freopen(CONFIG_DEFAULT_DEPMOD_FILE, "w", stdout);
-+ xfreopen_write(CONFIG_DEFAULT_DEPMOD_FILE, stdout);
- for (m = modules; m != NULL; m = m->next) {
- printf("%s:", m->name);
-
-@@ -174,12 +191,12 @@
- dep->dprev->dnext = dep->dnext;
- dep->dnext = dep->dprev = dep;
- }
-- puts("");
-+ bb_putchar('\n');
- }
-
- #if ENABLE_FEATURE_MODUTILS_ALIAS
- if (!(option_mask32 & ARG_n))
-- freopen("modules.alias", "w", stdout);
-+ xfreopen_write("modules.alias", stdout);
- for (m = modules; m != NULL; m = m->next) {
- while (m->aliases) {
- printf("alias %s %s\n",
-@@ -190,7 +207,7 @@
- #endif
- #if ENABLE_FEATURE_MODUTILS_SYMBOLS
- if (!(option_mask32 & ARG_n))
-- freopen("modules.symbols", "w", stdout);
-+ xfreopen_write("modules.symbols", stdout);
- for (m = modules; m != NULL; m = m->next) {
- while (m->symbols) {
- printf("alias symbol:%s %s\n",
diff --git a/sys-apps/busybox/files/busybox-1.13.2-init.patch b/sys-apps/busybox/files/busybox-1.13.2-init.patch
deleted file mode 100644
index 1d98467ac646..000000000000
--- a/sys-apps/busybox/files/busybox-1.13.2-init.patch
+++ /dev/null
@@ -1,50 +0,0 @@
---- busybox-1.13.2/init/init.c Wed Dec 31 04:06:45 2008
-+++ busybox-1.13.2-init/init/init.c Thu Jan 29 03:02:13 2009
-@@ -671,15 +671,14 @@
- */
- static void parse_inittab(void)
- {
-+#if ENABLE_FEATURE_USE_INITTAB
- char *token[4];
-- /* order must correspond to SYSINIT..RESTART constants */
-- static const char actions[] ALIGN1 =
-- "sysinit\0""respawn\0""askfirst\0""wait\0""once\0"
-- "ctrlaltdel\0""shutdown\0""restart\0";
-+ parser_t *parser = config_open2("/etc/inittab", fopen_for_read);
-
-- parser_t *parser = config_open2(INITTAB, fopen_for_read);
-- /* No inittab file -- set up some default behavior */
-- if (parser == NULL) {
-+ if (parser == NULL)
-+#endif
-+ {
-+ /* No inittab file -- set up some default behavior */
- /* Reboot on Ctrl-Alt-Del */
- new_init_action(CTRLALTDEL, "reboot", "");
- /* Umount all filesystems on halt/reboot */
-@@ -699,11 +698,17 @@
- new_init_action(SYSINIT, INIT_SCRIPT, "");
- return;
- }
-+
-+#if ENABLE_FEATURE_USE_INITTAB
- /* optional_tty:ignored_runlevel:action:command
- * Delims are not to be collapsed and need exactly 4 tokens
- */
- while (config_read(parser, token, 4, 0, "#:",
- PARSE_NORMAL & ~(PARSE_TRIM | PARSE_COLLAPSE))) {
-+ /* order must correspond to SYSINIT..RESTART constants */
-+ static const char actions[] ALIGN1 =
-+ "sysinit\0""respawn\0""askfirst\0""wait\0""once\0"
-+ "ctrlaltdel\0""shutdown\0""restart\0";
- int action;
- char *tty = token[0];
-
-@@ -727,6 +732,7 @@
- parser->lineno);
- }
- config_close(parser);
-+#endif
- }
-
- #if ENABLE_FEATURE_USE_INITTAB
diff --git a/sys-apps/busybox/files/busybox-1.13.2-killall.patch b/sys-apps/busybox/files/busybox-1.13.2-killall.patch
deleted file mode 100644
index 9524f5281aa0..000000000000
--- a/sys-apps/busybox/files/busybox-1.13.2-killall.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- busybox-1.13.2/include/libbb.h Wed Dec 31 04:06:45 2008
-+++ busybox-1.13.2-killall/include/libbb.h Sat Feb 14 02:41:18 2009
-@@ -1275,7 +1275,13 @@
- PSSCAN_UTIME = 1 << 13,
- PSSCAN_TTY = 1 << 14,
- PSSCAN_SMAPS = (1 << 15) * ENABLE_FEATURE_TOPMEM,
-- PSSCAN_ARGVN = (1 << 16) * (ENABLE_PGREP || ENABLE_PKILL || ENABLE_PIDOF),
-+ /* NB: used by find_pid_by_name(). Any applet using it
-+ * needs to be mentioned here. */
-+ PSSCAN_ARGVN = (1 << 16) * (ENABLE_KILLALL
-+ || ENABLE_PGREP || ENABLE_PKILL
-+ || ENABLE_PIDOF
-+ || ENABLE_SESTATUS
-+ ),
- USE_SELINUX(PSSCAN_CONTEXT = 1 << 17,)
- PSSCAN_START_TIME = 1 << 18,
- PSSCAN_CPU = 1 << 19,
diff --git a/sys-apps/busybox/files/busybox-1.13.2-mdev.patch b/sys-apps/busybox/files/busybox-1.13.2-mdev.patch
deleted file mode 100644
index bd17f991291b..000000000000
--- a/sys-apps/busybox/files/busybox-1.13.2-mdev.patch
+++ /dev/null
@@ -1,39 +0,0 @@
---- busybox-1.13.2/testsuite/mdev.tests Sun Nov 9 18:28:19 2008
-+++ busybox-1.13.2-mdev/testsuite/mdev.tests Mon Jan 12 08:59:15 2009
-@@ -111,6 +111,22 @@
-
- # continuing to use directory structure from prev test
- rm -rf mdev.testdir/dev/*
-+echo "sda 0:0 644 =block/ @echo @echo TEST" >mdev.testdir/etc/mdev.conf
-+testing "mdev move and command" \
-+ "env - PATH=$PATH ACTION=add DEVPATH=/block/sda chroot mdev.testdir /mdev 2>&1;
-+ ls -lnR mdev.testdir/dev | $FILTER_LS2" \
-+"\
-+@echo TEST
-+mdev.testdir/dev:
-+drwxr-xr-x 2 0 0 block
-+
-+mdev.testdir/dev/block:
-+brw-r--r-- 1 0 0 sda
-+" \
-+ "" ""
-+
-+# continuing to use directory structure from prev test
-+rm -rf mdev.testdir/dev/*
- echo "@8,0 :1 644" >mdev.testdir/etc/mdev.conf
- testing "mdev #maj,min and no explicit uid" \
- "env - PATH=$PATH ACTION=add DEVPATH=/block/sda chroot mdev.testdir /mdev 2>&1;
---- busybox-1.13.2/util-linux/mdev.c Sun Nov 9 18:28:22 2008
-+++ busybox-1.13.2-mdev/util-linux/mdev.c Mon Jan 12 08:59:15 2009
-@@ -179,8 +179,9 @@
- unsigned i, n;
- #endif
- char *a = val;
-- s = strchr(val, ' ');
-- val = (s && s[1]) ? s+1 : NULL;
-+ s = strchrnul(val, ' ');
-+ val = (s[0] && s[1]) ? s+1 : NULL;
-+ s[0] = '\0';
- #if ENABLE_FEATURE_MDEV_RENAME_REGEXP
- /* substitute %1..9 with off[1..9], if any */
- n = 0;
diff --git a/sys-apps/busybox/files/busybox-1.13.2-modprobe.patch b/sys-apps/busybox/files/busybox-1.13.2-modprobe.patch
deleted file mode 100644
index 8fd7dc428bce..000000000000
--- a/sys-apps/busybox/files/busybox-1.13.2-modprobe.patch
+++ /dev/null
@@ -1,99 +0,0 @@
---- busybox-1.13.2/modutils/modutils-24.c Sat Nov 29 07:48:56 2008
-+++ busybox-1.13.2-modprobe/modutils/modutils-24.c Sun Feb 1 00:08:26 2009
-@@ -2150,7 +2150,7 @@
- sec->name = name;
- sec->idx = newidx;
- if (size)
-- sec->contents = xmalloc(size);
-+ sec->contents = xzalloc(size);
-
- obj_insert_section_load_order(f, sec);
-
-@@ -2165,7 +2165,7 @@
- int newidx = f->header.e_shnum++;
- struct obj_section *sec;
-
-- f->sections = xrealloc(f->sections, (newidx + 1) * sizeof(sec));
-+ f->sections = xrealloc_vector(f->sections, 2, newidx);
- f->sections[newidx] = sec = arch_new_section();
-
- sec->header.sh_type = SHT_PROGBITS;
-@@ -2175,7 +2175,7 @@
- sec->name = name;
- sec->idx = newidx;
- if (size)
-- sec->contents = xmalloc(size);
-+ sec->contents = xzalloc(size);
-
- sec->load_next = f->load_order;
- f->load_order = sec;
-@@ -2571,8 +2571,7 @@
- /* Collect the modules' symbols. */
-
- if (nmod) {
-- ext_modules = modules = xmalloc(nmod * sizeof(*modules));
-- memset(modules, 0, nmod * sizeof(*modules));
-+ ext_modules = modules = xzalloc(nmod * sizeof(*modules));
- for (i = 0, mn = module_names, m = modules;
- i < nmod; ++i, ++m, mn += strlen(mn) + 1) {
- struct new_module_info info;
-@@ -2652,13 +2651,14 @@
- }
-
-
--static void new_create_this_module(struct obj_file *f, const char *m_name)
-+static void new_create_this_module(struct obj_file *f, const char *m_name)
- {
- struct obj_section *sec;
-
- sec = obj_create_alloced_section_first(f, ".this", tgt_sizeof_long,
- sizeof(struct new_module));
-- memset(sec->contents, 0, sizeof(struct new_module));
-+ /* done by obj_create_alloced_section_first: */
-+ /*memset(sec->contents, 0, sizeof(struct new_module));*/
-
- obj_add_symbol(f, SPFX "__this_module", -1,
- ELF_ST_INFO(STB_LOCAL, STT_OBJECT), sec->idx, 0,
-@@ -2965,9 +2965,9 @@
- if (i == f->header.e_shnum) {
- struct obj_section *sec;
-
-+ f->header.e_shnum++;
- f->sections = xrealloc_vector(f->sections, 2, i);
- f->sections[i] = sec = arch_new_section();
-- f->header.e_shnum = i + 1;
-
- sec->header.sh_type = SHT_PROGBITS;
- sec->header.sh_flags = SHF_WRITE | SHF_ALLOC;
-@@ -3006,12 +3006,9 @@
- for (i = 0; i < f->header.e_shnum; ++i) {
- struct obj_section *s = f->sections[i];
- if (s->header.sh_type == SHT_NOBITS) {
-+ s->contents = NULL;
- if (s->header.sh_size != 0)
-- s->contents = memset(xmalloc(s->header.sh_size),
-- 0, s->header.sh_size);
-- else
-- s->contents = NULL;
--
-+ s->contents = xzalloc(s->header.sh_size);
- s->header.sh_type = SHT_PROGBITS;
- }
- }
-@@ -3275,14 +3272,13 @@
- case SHT_SYMTAB:
- case SHT_STRTAB:
- case SHT_RELM:
-+ sec->contents = NULL;
- if (sec->header.sh_size > 0) {
-- sec->contents = xmalloc(sec->header.sh_size);
-+ sec->contents = xzalloc(sec->header.sh_size);
- fseek(fp, sec->header.sh_offset, SEEK_SET);
- if (fread(sec->contents, sec->header.sh_size, 1, fp) != 1) {
- bb_perror_msg_and_die("error reading ELF section data");
- }
-- } else {
-- sec->contents = NULL;
- }
- break;
-
diff --git a/sys-apps/busybox/files/busybox-1.13.2-tar.patch b/sys-apps/busybox/files/busybox-1.13.2-tar.patch
deleted file mode 100644
index 3a59081c8239..000000000000
--- a/sys-apps/busybox/files/busybox-1.13.2-tar.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- busybox-1.13.2/archival/tar.c Sun Nov 9 18:28:02 2008
-+++ busybox-1.13.2-tar/archival/tar.c Tue Jan 20 03:52:04 2009
-@@ -591,8 +591,6 @@
- struct TarBallInfo tbInfo;
-
- tbInfo.hlInfoHead = NULL;
--
-- fchmod(tar_fd, 0644);
- tbInfo.tarFd = tar_fd;
- tbInfo.verboseFlag = verboseFlag;
-