summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-02-10 02:05:51 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-02-10 02:05:51 +0000
commitf89c281ed4608ab8522f1edd63f332ac3f27c226 (patch)
treee4c3039e1dd256808865ce6390445f333941e26e /sys-auth/icmpdn/icmpdn-0.4.ebuild
parentVersion bump which fixes #108219 by Morten Cools / Pierre Cassimans. (diff)
downloadgentoo-2-f89c281ed4608ab8522f1edd63f332ac3f27c226.tar.gz
gentoo-2-f89c281ed4608ab8522f1edd63f332ac3f27c226.tar.bz2
gentoo-2-f89c281ed4608ab8522f1edd63f332ac3f27c226.zip
Initial commit. Original ebuild submitted by Fredrik Tolf <fredrik@dolda2000.com>, bug #93870.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'sys-auth/icmpdn/icmpdn-0.4.ebuild')
-rw-r--r--sys-auth/icmpdn/icmpdn-0.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-auth/icmpdn/icmpdn-0.4.ebuild b/sys-auth/icmpdn/icmpdn-0.4.ebuild
new file mode 100644
index 000000000000..1f0dc83c48eb
--- /dev/null
+++ b/sys-auth/icmpdn/icmpdn-0.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/icmpdn/icmpdn-0.4.ebuild,v 1.1 2006/02/10 02:05:51 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="ICMP Domain Name utilities & NSS backend"
+HOMEPAGE="http://www.dolda2000.com/~fredrik/icmp-dn/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="sys-libs/glibc"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ LDFLAGS='-Wl,-z,now' \
+ econf \
+ --sysconfdir=/etc \
+ --libdir=/lib \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ newinitd ${FILESDIR}/init.d-icmpdnd icmpdnd
+ newconfd ${FILESDIR}/conf.d-icmpdnd icmpdnd
+ dodoc AUTHORS ChangeLog README
+ # must always run as root
+ fperms 4711 /usr/bin/idnlookup
+ # useless as nothing should link against this lib
+ rm ${D}/lib/*.la
+}
+
+pkg_postinst() {
+ einfo "To use the ICMP nameswitch module, add 'icmp'"
+ einfo "to the 'hosts' line in your /etc/nsswitch.conf"
+}
+