summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-02-19 12:53:38 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-02-19 12:53:38 +0000
commitb5c8c8785bc61215cb2127ca6fa046e6152ba023 (patch)
treee2021d49d9028b10100fa6e3dc288c659591040e /sys-auth/pam_passwdqc/pam_passwdqc-1.0.5.ebuild
parentVersion bump (diff)
downloadgentoo-2-b5c8c8785bc61215cb2127ca6fa046e6152ba023.tar.gz
gentoo-2-b5c8c8785bc61215cb2127ca6fa046e6152ba023.tar.bz2
gentoo-2-b5c8c8785bc61215cb2127ca6fa046e6152ba023.zip
Version bump, new patch, the pre-stripped files were fixed already upstream, so it's just to respect LDFLAGS now.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-auth/pam_passwdqc/pam_passwdqc-1.0.5.ebuild')
-rw-r--r--sys-auth/pam_passwdqc/pam_passwdqc-1.0.5.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-auth/pam_passwdqc/pam_passwdqc-1.0.5.ebuild b/sys-auth/pam_passwdqc/pam_passwdqc-1.0.5.ebuild
new file mode 100644
index 000000000000..0a5c91292621
--- /dev/null
+++ b/sys-auth/pam_passwdqc/pam_passwdqc-1.0.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_passwdqc/pam_passwdqc-1.0.5.ebuild,v 1.1 2008/02/19 12:53:37 flameeyes Exp $
+
+inherit pam eutils toolchain-funcs
+
+DESCRIPTION="Password strength checking for PAM aware password changing programs"
+HOMEPAGE="http://www.openwall.com/passwdqc/"
+SRC_URI="http://www.openwall.com/pam/modules/pam_passwdqc/${P}.tar.gz"
+
+LICENSE="BSD as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+
+DEPEND="virtual/pam"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ emake \
+ OPTCFLAGS="${CFLAGS}" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ || die "emake failed"
+}
+
+src_install() {
+ dopammod pam_passwdqc.so
+
+ doman pam_passwdqc.8
+ dodoc README PLATFORMS INTERNALS LICENSE
+}
+
+pkg_postinst() {
+ elog
+ elog "To activate pam_passwdqc use pam_passwdqc.so instead"
+ elog "of pam_cracklib.so in /etc/pam.d/system-auth."
+ elog "Also, if you want to change the parameters, read up"
+ elog "on the pam_passwdqc(8) man page."
+ elog
+}