summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-12-07 16:09:26 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-12-07 16:09:26 +0000
commit1a9d519c1c4ac1c1a677886a68ea885cb550fde3 (patch)
treec65a59f703d1673ad5865c198234ac9250e48be1 /sys-auth/polkit
parentAdd support for x32 ABIs. (diff)
downloadgentoo-2-1a9d519c1c4ac1c1a677886a68ea885cb550fde3.tar.gz
gentoo-2-1a9d519c1c4ac1c1a677886a68ea885cb550fde3.tar.bz2
gentoo-2-1a9d519c1c4ac1c1a677886a68ea885cb550fde3.zip
Version bump. Remove unrequired keepdir of /var/run/polkit-1 wrt #387903 by "i.Dark_Templar"
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/polkit')
-rw-r--r--sys-auth/polkit/ChangeLog8
-rw-r--r--sys-auth/polkit/polkit-0.103.ebuild95
2 files changed, 102 insertions, 1 deletions
diff --git a/sys-auth/polkit/ChangeLog b/sys-auth/polkit/ChangeLog
index 5c8e0ca93f7e..18453e7d05e7 100644
--- a/sys-auth/polkit/ChangeLog
+++ b/sys-auth/polkit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/polkit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.57 2011/11/05 17:56:15 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.58 2011/12/07 16:09:26 ssuominen Exp $
+
+*polkit-0.103 (07 Dec 2011)
+
+ 07 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.103.ebuild:
+ Version bump. Remove unrequired keepdir of /var/run/polkit-1 wrt #387903 by
+ "i.Dark_Templar"
05 Nov 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.102.ebuild:
alpha/arm/ia64/sh/sparc stable wrt #387163
diff --git a/sys-auth/polkit/polkit-0.103.ebuild b/sys-auth/polkit/polkit-0.103.ebuild
new file mode 100644
index 000000000000..3391f04343fd
--- /dev/null
+++ b/sys-auth/polkit/polkit-0.103.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.103.ebuild,v 1.1 2011/12/07 16:09:26 ssuominen Exp $
+
+EAPI=4
+inherit eutils pam
+
+DESCRIPTION="Policy framework for controlling privileges for system-wide services"
+HOMEPAGE="http://hal.freedesktop.org/docs/polkit/"
+SRC_URI="http://hal.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples gtk +introspection kde nls pam"
+
+RDEPEND=">=dev-libs/glib-2.28
+ dev-libs/expat
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2 )
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/docbook-xsl-stylesheets
+ dev-util/pkgconfig
+ dev-util/intltool
+ doc? ( >=dev-util/gtk-doc-1.13 )"
+PDEPEND=">=sys-auth/consolekit-0.4.5[policykit]
+ pam? ( sys-auth/pambase[consolekit] )
+ gtk? ( || ( >=gnome-extra/polkit-gnome-${PV} lxde-base/lxpolkit ) )
+ kde? ( sys-auth/polkit-kde-agent )"
+
+DOCS=( docs/TODO HACKING NEWS README )
+
+src_configure() {
+ local myauth="--with-authfw=shadow"
+ use pam && myauth="--with-authfw=pam --with-pam-module-dir=$(getpam_mod_dir)"
+
+ econf \
+ --localstatedir="${EPREFIX}"/var \
+ --disable-static \
+ $(use_enable debug verbose-mode) \
+ --enable-man-pages \
+ $(use_enable doc gtk-doc) \
+ $(use_enable introspection) \
+ --disable-examples \
+ $(use_enable nls) \
+ --with-os-type=gentoo \
+ ${myauth}
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -exec rm -f {} +
+
+ # We disable example compilation above, and handle it here
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins src/examples/{*.c,*.policy*}
+ fi
+
+ # Need to keep a few directories around...
+ diropts -m0700 -o root -g root
+ keepdir /var/lib/polkit-1
+ #keepdir /var/run/polkit-1 #387903
+}
+
+pkg_postinst() {
+ # Make sure that the user has consolekit sessions working so that the
+ # 'allow_active' directive in polkit action policies works
+ if has_version 'gnome-base/gdm' && ! has_version 'gnome-base/gdm[consolekit]'; then
+ # If user has GDM installed, but USE=-consolekit, warn them
+ ewarn "You have GDM installed, but it does not have USE=consolekit"
+ ewarn "If you login using GDM, polkit authorizations will not work"
+ ewarn "unless you enable USE=consolekit"
+ einfo
+ fi
+ if has_version 'kde-base/kdm' && ! has_version 'kde-base/kdm[consolekit]'; then
+ # If user has KDM installed, but USE=-consolekit, warn them
+ ewarn "You have KDM installed, but it does not have USE=consolekit"
+ ewarn "If you login using KDM, polkit authorizations will not work"
+ ewarn "unless you enable USE=consolekit"
+ einfo
+ fi
+ if ! has_version 'gnome-base/gdm[consolekit]' && \
+ ! has_version 'kde-base/kdm[consolekit]'; then
+ # Inform user about the alternative method
+ ewarn "If you don't use GDM or KDM for logging in,"
+ ewarn "you must start your desktop environment (DE) as follows:"
+ ewarn " ck-launch-session \$STARTGUI"
+ ewarn "Where \$STARTGUI is a DE-starting command such as 'gnome-session'."
+ ewarn "You should add this to your ~/.xinitrc if you use startx."
+ fi
+}