summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-06-24 10:32:39 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-06-24 10:32:39 +0000
commitfac3b9fbbb2d1c67627901296ae4463e16da2a8e (patch)
treeb2753c0f3d68785ca2182d7a899914ab277edd80 /sys-auth/ykclient
parentVersion bump yubikey-related packages. Close bugs #394565, #394563, #423289, ... (diff)
downloadgentoo-2-fac3b9fbbb2d1c67627901296ae4463e16da2a8e.tar.gz
gentoo-2-fac3b9fbbb2d1c67627901296ae4463e16da2a8e.tar.bz2
gentoo-2-fac3b9fbbb2d1c67627901296ae4463e16da2a8e.zip
Version bump yubikey-related packages. Close bugs #394565, #394563, #423289, #371345, #394567. Remove old and old patch.
(Portage version: 2.2.0_alpha112/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/ykclient')
-rw-r--r--sys-auth/ykclient/ChangeLog12
-rw-r--r--sys-auth/ykclient/files/ykclient-2.3-rpath.patch12
-rw-r--r--sys-auth/ykclient/ykclient-2.8.ebuild33
3 files changed, 42 insertions, 15 deletions
diff --git a/sys-auth/ykclient/ChangeLog b/sys-auth/ykclient/ChangeLog
index caf9a26b3044..fe82b42482fc 100644
--- a/sys-auth/ykclient/ChangeLog
+++ b/sys-auth/ykclient/ChangeLog
@@ -1,10 +1,16 @@
# ChangeLog for sys-auth/ykclient
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykclient/ChangeLog,v 1.1 2010/11/20 00:28:32 flameeyes Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykclient/ChangeLog,v 1.2 2012/06/24 10:32:39 flameeyes Exp $
+
+*ykclient-2.8 (24 Jun 2012)
+
+ 24 Jun 2012; Diego E. Pettenò <flameeyes@gentoo.org> +ykclient-2.8.ebuild,
+ -files/ykclient-2.3-rpath.patch:
+ Version bump yubikey-related packages. Close bugs #394565, #394563, #423289,
+ #371345, #394567. Remove old and old patch.
*ykclient-2.3 (20 Nov 2010)
20 Nov 2010; Diego E. Pettenò <flameeyes@gentoo.org> +ykclient-2.3.ebuild,
+files/ykclient-2.3-rpath.patch, +metadata.xml:
Initial import of ykclient ebuild; ebuild by Brant Gurganus in bug #343551.
-
diff --git a/sys-auth/ykclient/files/ykclient-2.3-rpath.patch b/sys-auth/ykclient/files/ykclient-2.3-rpath.patch
deleted file mode 100644
index 56e196a961c1..000000000000
--- a/sys-auth/ykclient/files/ykclient-2.3-rpath.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: ykclient-2.3/Makefile.am
-===================================================================
---- ykclient-2.3.orig/Makefile.am
-+++ ykclient-2.3/Makefile.am
-@@ -54,7 +54,6 @@ ykclient_LDADD = ./libykclient.la
-
- # Self tests.
-
--AM_LDFLAGS = -no-install
- LDADD = libykclient.la
-
- check_PROGRAMS = selftest
diff --git a/sys-auth/ykclient/ykclient-2.8.ebuild b/sys-auth/ykclient/ykclient-2.8.ebuild
new file mode 100644
index 000000000000..a8a001b804e9
--- /dev/null
+++ b/sys-auth/ykclient/ykclient-2.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykclient/ykclient-2.8.ebuild,v 1.1 2012/06/24 10:32:39 flameeyes Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Yubico C client library"
+SRC_URI="http://yubico-c-client.googlecode.com/files/${P}.tar.gz"
+HOMEPAGE="https://github.com/Yubico/yubico-c-client"
+
+KEYWORDS="~amd64"
+SLOT="0"
+LICENSE="BSD-2"
+IUSE="static-libs"
+
+RDEPEND=">=net-misc/curl-7.21.1"
+DEPEND="${RDEPEND}"
+
+# Tests require an active network connection, we don't want to run them
+RESTRICT="test"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_install() {
+ default
+ prune_libtool_files
+}