summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConstanze Hausner <constanze@gentoo.org>2010-11-25 20:28:10 +0000
committerConstanze Hausner <constanze@gentoo.org>2010-11-25 20:28:10 +0000
commit38cbd53582728d5944acdbe3e3ec71119eb8ed21 (patch)
tree65eab398ee34d4c111a2f87e114b977a87dcbe37 /sys-auth
parentVersion bump. Remove beta package (diff)
downloadgentoo-2-38cbd53582728d5944acdbe3e3ec71119eb8ed21.tar.gz
gentoo-2-38cbd53582728d5944acdbe3e3ec71119eb8ed21.tar.bz2
gentoo-2-38cbd53582728d5944acdbe3e3ec71119eb8ed21.zip
Version bump, contains only bugfixes (requested by bug #302765)
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_ldap/ChangeLog9
-rw-r--r--sys-auth/pam_ldap/pam_ldap-186.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/sys-auth/pam_ldap/ChangeLog b/sys-auth/pam_ldap/ChangeLog
index 8fb391390856..8994c23bcaad 100644
--- a/sys-auth/pam_ldap/ChangeLog
+++ b/sys-auth/pam_ldap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_ldap
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ldap/ChangeLog,v 1.40 2009/05/29 13:26:11 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ldap/ChangeLog,v 1.41 2010/11/25 20:28:10 constanze Exp $
+
+*pam_ldap-186 (25 Nov 2010)
+
+ 25 Nov 2010; Constanze Hausner <constanze@gentoo.org> +pam_ldap-186.ebuild:
+ Version bump, contains only bugfixes (requested by bug #302765)
29 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
-pam_ldap-180.ebuild, -pam_ldap-182.ebuild:
diff --git a/sys-auth/pam_ldap/pam_ldap-186.ebuild b/sys-auth/pam_ldap/pam_ldap-186.ebuild
new file mode 100644
index 000000000000..979ab6b4653b
--- /dev/null
+++ b/sys-auth/pam_ldap/pam_ldap-186.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ldap/pam_ldap-186.ebuild,v 1.1 2010/11/25 20:28:10 constanze Exp $
+
+inherit eutils pam
+
+DESCRIPTION="PAM LDAP Module"
+HOMEPAGE="http://www.padl.com/OSS/pam_ldap.html"
+SRC_URI="http://www.padl.com/download/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ssl sasl"
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/pam-0.72
+ >=net-nds/openldap-2.1.30-r5
+ sasl? ( dev-libs/cyrus-sasl )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+}
+
+src_compile() {
+ econf --with-ldap-lib=openldap `use_enable ssl` || die
+ emake || die
+}
+
+src_install() {
+ dopammod pam_ldap.so
+
+ dodoc pam.conf ldap.conf ldapns.schema chsh chfn certutil
+ dodoc ChangeLog CVSVersionInfo.txt README AUTHORS ns-pwd-policy.schema
+ doman pam_ldap.5
+
+ docinto pam.d
+ dodoc pam.d/*
+}