summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2015-03-11 22:29:56 +0000
committerPatrick McLean <chutzpah@gentoo.org>2015-03-11 22:29:56 +0000
commit4554b0e5c9324d07d6cc00e60d1086ef5da584c8 (patch)
treecb1f54dd50a02570392dce357a68f57c45dd5cf8 /sys-auth
parentEAPI=5 (diff)
downloadgentoo-2-4554b0e5c9324d07d6cc00e60d1086ef5da584c8.tar.gz
gentoo-2-4554b0e5c9324d07d6cc00e60d1086ef5da584c8.tar.bz2
gentoo-2-4554b0e5c9324d07d6cc00e60d1086ef5da584c8.zip
Revision bump, add "utils" USE flag to control installation of userspace utilities written in python. Use python-r1 eclass to install python code rather than the automake-based internal code.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xE3F69979BB4B8928DA78E3D17CBF44EF)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/nss-pam-ldapd/ChangeLog11
-rw-r--r--sys-auth/nss-pam-ldapd/files/nss-pam-ldapd-0.9.4-disable-py3-only-linters.patch13
-rw-r--r--sys-auth/nss-pam-ldapd/metadata.xml3
-rw-r--r--sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.4-r2.ebuild117
4 files changed, 143 insertions, 1 deletions
diff --git a/sys-auth/nss-pam-ldapd/ChangeLog b/sys-auth/nss-pam-ldapd/ChangeLog
index cdede0eb56dd..1048704fc311 100644
--- a/sys-auth/nss-pam-ldapd/ChangeLog
+++ b/sys-auth/nss-pam-ldapd/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-auth/nss-pam-ldapd
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-pam-ldapd/ChangeLog,v 1.17 2015/03/09 00:36:52 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-pam-ldapd/ChangeLog,v 1.18 2015/03/11 22:29:56 chutzpah Exp $
+
+*nss-pam-ldapd-0.9.4-r2 (11 Mar 2015)
+
+ 11 Mar 2015; Patrick McLean <chutzpah@gentoo.org>
+ +files/nss-pam-ldapd-0.9.4-disable-py3-only-linters.patch,
+ +nss-pam-ldapd-0.9.4-r2.ebuild, metadata.xml:
+ Revision bump, add "utils" USE flag to control installation of userspace
+ utilities written in python. Use python-r1 eclass to install python code
+ rather than the automake-based internal code.
*nss-pam-ldapd-0.9.4-r1 (09 Mar 2015)
diff --git a/sys-auth/nss-pam-ldapd/files/nss-pam-ldapd-0.9.4-disable-py3-only-linters.patch b/sys-auth/nss-pam-ldapd/files/nss-pam-ldapd-0.9.4-disable-py3-only-linters.patch
new file mode 100644
index 000000000000..06dcc2513a39
--- /dev/null
+++ b/sys-auth/nss-pam-ldapd/files/nss-pam-ldapd-0.9.4-disable-py3-only-linters.patch
@@ -0,0 +1,13 @@
+diff --git a/tests/pylint.rc b/tests/pylint.rc
+index 7f0bc13..b66d018 100644
+--- a/tests/pylint.rc
++++ b/tests/pylint.rc
+@@ -19,7 +19,7 @@ enable=
+ # can either give multiple identifier separated by comma (,) or put this option
+ # multiple time (only on the command line, not in the configuration file where
+ # it should appear only once).
+-disable=E1101
++disable=E1101,E1608,E1606,E1601
+
+
+ [REPORTS]
diff --git a/sys-auth/nss-pam-ldapd/metadata.xml b/sys-auth/nss-pam-ldapd/metadata.xml
index ea0924767f7f..b925b639cb3f 100644
--- a/sys-auth/nss-pam-ldapd/metadata.xml
+++ b/sys-auth/nss-pam-ldapd/metadata.xml
@@ -5,6 +5,9 @@
<email>prometheanfire@gentoo.org</email>
<name>Matthew Thode</name>
</maintainer>
+ <use>
+ <flag name="utils">Install the command-line utilities</flag>
+ </use>
<longdescription lang="en">
Provides a Name Service Switch (NSS) module that allows your LDAP
server to provide user account, group, host name, alias, netgroup, and
diff --git a/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.4-r2.ebuild b/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.4-r2.ebuild
new file mode 100644
index 000000000000..ff78640e81c1
--- /dev/null
+++ b/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.4-r2.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.4-r2.ebuild,v 1.1 2015/03/11 22:29:56 chutzpah Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=(python2_7)
+inherit eutils prefix user python-r1 multilib multilib-minimal
+
+DESCRIPTION="NSS module for name lookups using LDAP"
+HOMEPAGE="http://arthurdejong.org/nss-pam-ldapd/"
+SRC_URI="http://arthurdejong.org/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug kerberos +pam sasl test +utils"
+
+RDEPEND="
+ net-nds/openldap[${MULTILIB_USEDEP}]
+ sasl? ( dev-libs/cyrus-sasl[${MULTILIB_USEDEP}] )
+ kerberos? ( virtual/krb5[${MULTILIB_USEDEP}] )
+ pam? ( virtual/pam[${MULTILIB_USEDEP}] )
+ utils? ( ${PYTHON_DEPS} )
+ test? (
+ ${PYTHON_DEPS}
+ dev-python/pylint[${PYTHON_USEDEP}]
+ )
+ !sys-auth/nss_ldap
+ !sys-auth/pam_ldap"
+DEPEND="${RDEPEND}
+ sys-devel/automake"
+
+REQUIRED_USE="
+ utils? ( ${PYTHON_REQUIRED_USE} )
+ test? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ enewgroup nslcd
+ enewuser nslcd -1 -1 -1 nslcd
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-disable-py3-only-linters.patch
+ epatch_user
+ use utils && python_setup
+}
+
+multilib_src_configure() {
+ local -a myconf
+
+ myconf=(
+ --disable-utils
+ --enable-warnings
+ --with-ldap-lib=openldap
+ --with-ldap-conf-file=/etc/nslcd.conf
+ --with-nslcd-pidfile=/run/nslcd/nslcd.pid
+ --with-nslcd-socket=/run/nslcd/socket
+ $(usex x86-fbsd '--with-nss-flavour=' '--with-nss-flavour=' 'freebsd' 'glibc')
+ $(use_enable debug)
+ $(use_enable kerberos)
+ $(use_enable pam)
+ $(use_enable sasl)
+ )
+
+ # nss libraries always go in /lib on Gentoo
+ if multilib_is_native_abi ; then
+ myconf+=("--with-pam-seclib-dir=${EPREFIX}/$(get_libdir)/security")
+ myconf+=("--libdir=${EPREFIX}/$(get_libdir)")
+ else
+ myconf+=("--with-pam-seclib-dir=/$(get_libdir)/security")
+ myconf+=("--libdir=/$(get_libdir)")
+ fi
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+multilib_src_install_all() {
+ local script
+
+ newinitd "${FILESDIR}"/nslcd-init-r1 nslcd
+
+ insinto /usr/share/nss-pam-ldapd
+ doins nslcd.conf
+
+ fperms o-r /etc/nslcd.conf
+
+ if use utils; then
+ python_moduleinto nslcd
+ python_foreach_impl && python_domodule utils/*.py
+
+ for script in chsh getent; do
+ python_foreach_impl python_newscript utils/${script}.py ${script}.ldap
+ done
+ fi
+}
+
+multilib_src_test() {
+ python_foreach_impl emake check
+}
+
+pkg_postinst() {
+ echo
+ elog "For this to work you must configure /etc/nslcd.conf"
+ elog "This configuration is similar to pam_ldap's /etc/ldap.conf"
+ echo
+ elog "In order to use nss-pam-ldapd, nslcd needs to be running. You can"
+ elog "start it like this:"
+ elog " # /etc/init.d/nslcd start"
+ echo
+ elog "You can add it to the default runlevel like so:"
+ elog " # rc-update add nslcd default"
+ elog
+ elog "If you are upgrading, keep in mind that /etc/nss-ldapd.conf"
+ elog " is now named /etc/nslcd.conf"
+ echo
+}