summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-03-05 22:30:01 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-03-05 22:30:01 +0000
commitbb23e842a6cdca22535c4d9d300b5879c907f11b (patch)
tree0f2b950616302558ffdb407a2de2c322c04f2120 /sys-block/buffer/buffer-1.19-r2.ebuild
parentadd sys-block (diff)
downloadgentoo-2-bb23e842a6cdca22535c4d9d300b5879c907f11b.tar.gz
gentoo-2-bb23e842a6cdca22535c4d9d300b5879c907f11b.tar.bz2
gentoo-2-bb23e842a6cdca22535c4d9d300b5879c907f11b.zip
Moved from sys-apps/buffer to sys-block/buffer.
Diffstat (limited to 'sys-block/buffer/buffer-1.19-r2.ebuild')
-rw-r--r--sys-block/buffer/buffer-1.19-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-block/buffer/buffer-1.19-r2.ebuild b/sys-block/buffer/buffer-1.19-r2.ebuild
new file mode 100644
index 000000000000..2b64f57e78ab
--- /dev/null
+++ b/sys-block/buffer/buffer-1.19-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/buffer/buffer-1.19-r2.ebuild,v 1.1 2005/03/05 22:30:01 ciaranm Exp $
+
+inherit eutils flag-o-matic gcc
+
+DESCRIPTION="a tapedrive tool for speeding up reading from and writing to tape"
+HOMEPAGE="http://www.microwerks.net/~hugo/"
+SRC_URI="mirror://gentoo/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64 ppc"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-deb-gentoo.patch
+ make clean || die "make clean failed"
+}
+
+src_compile() {
+ append-lfs-flags
+ emake CC="$(gcc-getCC)" CFLAGS="${CFLAGS}" || die "make failed"
+}
+
+src_install() {
+ dobin buffer || die
+ dodoc README
+ newman buffer.man buffer.1
+}