summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-05-31 00:34:05 +0000
committerJeroen Roovers <jer@gentoo.org>2011-05-31 00:34:05 +0000
commita0a61e235be8d0d83fafd3a56d8c16c04c2d2745 (patch)
treecdfc6c105027d80614d3ef438ef9482a0fb79f37 /sys-block
parentVersion bump. (diff)
downloadgentoo-2-a0a61e235be8d0d83fafd3a56d8c16c04c2d2745.tar.gz
gentoo-2-a0a61e235be8d0d83fafd3a56d8c16c04c2d2745.tar.bz2
gentoo-2-a0a61e235be8d0d83fafd3a56d8c16c04c2d2745.zip
Version bump.
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/parted/ChangeLog7
-rw-r--r--sys-block/parted/parted-3.0.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/sys-block/parted/ChangeLog b/sys-block/parted/ChangeLog
index eda3e237d239..2d0146957e2c 100644
--- a/sys-block/parted/ChangeLog
+++ b/sys-block/parted/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-block/parted
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/parted/ChangeLog,v 1.6 2011/05/19 03:25:57 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/parted/ChangeLog,v 1.7 2011/05/31 00:34:05 jer Exp $
+
+*parted-3.0 (31 May 2011)
+
+ 31 May 2011; Jeroen Roovers <jer@gentoo.org> +parted-3.0.ebuild:
+ Version bump.
*parted-2.4 (19 May 2011)
diff --git a/sys-block/parted/parted-3.0.ebuild b/sys-block/parted/parted-3.0.ebuild
new file mode 100644
index 000000000000..b4982dd2207e
--- /dev/null
+++ b/sys-block/parted/parted-3.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/parted/parted-3.0.ebuild,v 1.1 2011/05/31 00:34:05 jer Exp $
+
+EAPI="3"
+
+WANT_AUTOMAKE="1.11"
+
+inherit autotools eutils
+
+DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
+HOMEPAGE="http://www.gnu.org/software/parted"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="+debug device-mapper nls readline selinux static-libs"
+
+# specific version for gettext needed
+# to fix bug 85999
+RDEPEND="
+ >=sys-fs/e2fsprogs-1.27
+ >=sys-libs/ncurses-5.2
+ nls? ( >=sys-devel/gettext-0.12.1-r2 )
+ readline? ( >=sys-libs/readline-5.2 )
+ selinux? ( sys-libs/libselinux )
+ device-mapper? ( || ( >=sys-fs/lvm2-2.02.45 sys-fs/device-mapper ) )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/pkgconfig
+"
+
+src_prepare() {
+ # Remove tests known to FAIL instead of SKIP without OS/userland support
+ sed -i libparted/tests/Makefile.am \
+ -e 's|t3000-symlink.sh||g' || die "sed failed"
+ sed -i tests/Makefile.am \
+ -e '/t4100-msdos-partition-limits.sh/d' \
+ -e '/t4100-dvh-partition-limits.sh/d' \
+ -e '/t6000-dm.sh/d' || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with readline) \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_enable selinux) \
+ $(use_enable device-mapper) \
+ $(use_enable static-libs static) \
+ --disable-rpath \
+ || die "Configure failed"
+}
+
+src_test() {
+ if use debug; then
+ # Do not die when tests fail - some requirements are not
+ # properly checked and should not lead to the ebuild failing.
+ emake check
+ else
+ ewarn "Skipping tests because USE=-debug is set."
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Install failed"
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
+ dodoc doc/{API,FAT,USER.jp}
+ find "${ED}" -name '*.la' -exec rm -f '{}' +
+}