summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-15 21:25:41 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-15 21:25:41 +0000
commit988483f7cfac97b683705f255cb90a958308d2a8 (patch)
tree04ec054d115ca9f8ec3b2ac60ece20782c133013 /sys-boot/syslinux/syslinux-3.07.ebuild
parentRemoved cpio symlink and closing bug #78122. (diff)
downloadgentoo-2-988483f7cfac97b683705f255cb90a958308d2a8.tar.gz
gentoo-2-988483f7cfac97b683705f255cb90a958308d2a8.tar.bz2
gentoo-2-988483f7cfac97b683705f255cb90a958308d2a8.zip
Version bump #78098 by Ziga Boehm.
(Portage version: 2.0.51-r13)
Diffstat (limited to 'sys-boot/syslinux/syslinux-3.07.ebuild')
-rw-r--r--sys-boot/syslinux/syslinux-3.07.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-boot/syslinux/syslinux-3.07.ebuild b/sys-boot/syslinux/syslinux-3.07.ebuild
new file mode 100644
index 000000000000..a255fd9dac53
--- /dev/null
+++ b/sys-boot/syslinux/syslinux-3.07.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-3.07.ebuild,v 1.1 2005/01/15 21:25:41 vapier Exp $
+
+inherit eutils gcc
+
+DESCRIPTION="SysLinux, IsoLinux and PXELinux bootloader"
+HOMEPAGE="http://syslinux.zytor.com/"
+SRC_URI="mirror://kernel/linux/utils/boot/syslinux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/mtools"
+DEPEND="${RDEPEND}
+ dev-lang/nasm"
+
+# This ebuild is a departure from the old way of rebuilding everything in syslinux
+# This departure is necessary since hpa doesn't support the rebuilding of anything other
+# than the installers.
+
+# removed all the unpack/patching stuff since we aren't rebuilding the core stuff anymore
+
+src_compile() {
+ emake installer || die
+}
+
+src_install() {
+ make INSTALLROOT="${D}" install || die
+ dodoc README NEWS TODO *.doc memdisk/memdisk.doc
+}