summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-02-18 18:27:52 +0000
committerJeroen Roovers <jer@gentoo.org>2010-02-18 18:27:52 +0000
commitaf0b0702805bb869eb0b3af85e741990d5f0ee89 (patch)
tree81ea2cf0331001744f28e8e1b9354f3500fb311f /sys-boot/syslinux
parentVersion bump. Fixed build issue with USE=debug, bug #304301, thank Arttu Valo... (diff)
downloadgentoo-2-af0b0702805bb869eb0b3af85e741990d5f0ee89.tar.gz
gentoo-2-af0b0702805bb869eb0b3af85e741990d5f0ee89.tar.bz2
gentoo-2-af0b0702805bb869eb0b3af85e741990d5f0ee89.zip
Switch to IUSE=custom-cflags (bug #305783).
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'sys-boot/syslinux')
-rw-r--r--sys-boot/syslinux/ChangeLog5
-rw-r--r--sys-boot/syslinux/syslinux-3.84.ebuild26
2 files changed, 18 insertions, 13 deletions
diff --git a/sys-boot/syslinux/ChangeLog b/sys-boot/syslinux/ChangeLog
index 8005734aba4f..df04c7dec054 100644
--- a/sys-boot/syslinux/ChangeLog
+++ b/sys-boot/syslinux/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-boot/syslinux
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.51 2010/02/18 17:40:22 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.52 2010/02/18 18:27:52 jer Exp $
+
+ 18 Feb 2010; Jeroen Roovers <jer@gentoo.org> syslinux-3.84.ebuild:
+ Switch to IUSE=custom-cflags (bug #305783).
18 Feb 2010; Jeroen Roovers <jer@gentoo.org> syslinux-3.84.ebuild:
Respect CFLAGS, LDFLAGS, CC.
diff --git a/sys-boot/syslinux/syslinux-3.84.ebuild b/sys-boot/syslinux/syslinux-3.84.ebuild
index 8ce810e74bac..229e601d55d8 100644
--- a/sys-boot/syslinux/syslinux-3.84.ebuild
+++ b/sys-boot/syslinux/syslinux-3.84.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-3.84.ebuild,v 1.2 2010/02/18 17:40:22 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-3.84.ebuild,v 1.3 2010/02/18 18:27:52 jer Exp $
inherit eutils toolchain-funcs
@@ -11,7 +11,7 @@ SRC_URI="mirror://kernel/linux/utils/boot/syslinux/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
-IUSE=""
+IUSE="custom-cflags"
RDEPEND="sys-fs/mtools
dev-perl/Crypt-PasswdMD5
@@ -34,16 +34,18 @@ src_unpack() {
rm -f gethostip #bug 137081
- sed -i \
- extlinux/Makefile \
- linux/Makefile \
- mtools/Makefile \
- sample/Makefile \
- utils/Makefile \
- -e '/^LDFLAGS/d' \
- -e 's|-Os||g' \
- -e 's|CFLAGS[[:space:]]\+=|CFLAGS +=|g' \
- || die "sed failed"
+ local SYSLINUX_MAKEFILES="extlinux/Makefile linux/Makefile mtools/Makefile \
+ sample/Makefile utils/Makefile"
+ sed -i ${SYSLINUX_MAKEFILES} -e '/^LDFLAGS/d' || die "sed failed"
+
+ if use custom-cflags; then
+ sed -i ${SYSLINUX_MAKEFILES} \
+ -e 's|-g -Os||g' \
+ -e 's|-Os||g' \
+ -e 's|CFLAGS[[:space:]]\+=|CFLAGS +=|g' \
+ || die "sed custom-cflags failed"
+ fi
+
}
src_compile() {