summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-02-01 23:10:27 +0000
committerJeroen Roovers <jer@gentoo.org>2011-02-01 23:10:27 +0000
commit3bbf69e6d09aaf9f274cd725f06baecbdc9c12c3 (patch)
tree525eb01c69d3bfe7d5665091ae0d01cd23723d90 /sys-boot
parentVersion bump wrt #353464 by Bernd Lommerzheim. (diff)
downloadgentoo-2-3bbf69e6d09aaf9f274cd725f06baecbdc9c12c3.tar.gz
gentoo-2-3bbf69e6d09aaf9f274cd725f06baecbdc9c12c3.tar.bz2
gentoo-2-3bbf69e6d09aaf9f274cd725f06baecbdc9c12c3.zip
Version bump.
(Portage version: 2.2.0_alpha19/cvs/Linux i686)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/unetbootin/ChangeLog9
-rw-r--r--sys-boot/unetbootin/unetbootin-502.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/sys-boot/unetbootin/ChangeLog b/sys-boot/unetbootin/ChangeLog
index 9ae919d7d0ff..7b031a0f6044 100644
--- a/sys-boot/unetbootin/ChangeLog
+++ b/sys-boot/unetbootin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/unetbootin
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.52 2010/11/17 10:58:47 maekke Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.53 2011/02/01 23:10:27 jer Exp $
+
+*unetbootin-502 (01 Feb 2011)
+
+ 01 Feb 2011; Jeroen Roovers <jer@gentoo.org> +unetbootin-502.ebuild:
+ Version bump.
17 Nov 2010; Markus Meier <maekke@gentoo.org> unetbootin-494.ebuild:
x86 stable, bug #344881
diff --git a/sys-boot/unetbootin/unetbootin-502.ebuild b/sys-boot/unetbootin/unetbootin-502.ebuild
new file mode 100644
index 000000000000..e23d4ac61d53
--- /dev/null
+++ b/sys-boot/unetbootin/unetbootin-502.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-502.ebuild,v 1.1 2011/02/01 23:10:27 jer Exp $
+
+EAPI="3"
+
+inherit qt4-r2
+
+DESCRIPTION="Universal Netboot Installer creates Live USB systems for various OS
+distributions."
+HOMEPAGE="http://unetbootin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/unetbootin/${PN}-source-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+DEPEND="x11-libs/qt-gui"
+RDEPEND="${DEPEND}
+ sys-fs/mtools
+ sys-boot/syslinux
+ app-arch/p7zip"
+
+src_configure() {
+ lupdate unetbootin.pro || die "lupdate failed"
+ lrelease unetbootin.pro || die "lrelease failed"
+ eqmake4 unetbootin.pro || die "eqmake4 failed"
+}
+
+src_install() {
+ dobin unetbootin || die "dobin failed"
+ insinto /usr/share/applications
+ doins unetbootin.desktop || die "doins failed"
+}